aboutsummaryrefslogtreecommitdiffstats
path: root/filters
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2012-03-19 05:23:30 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2012-03-19 05:23:30 (JST)
commit08352c7a02f057f6cbaf817ca7e53c53be590a62 (patch)
treef1fbe011c9279d3e7fd699e6ae3fe1fc89627126 /filters
parent6e63ebfe004342cbe35e0b0f28de646ffa61933a (diff)
parentf50be7fda0a7ab57009169dd5905fcbab8eb5166 (diff)
downloadcgit-08352c7a02f057f6cbaf817ca7e53c53be590a62.zip
cgit-08352c7a02f057f6cbaf817ca7e53c53be590a62.tar.gz
Merge branch 'stable'
Diffstat (limited to 'filters')
-rwxr-xr-xfilters/syntax-highlighting.sh28
1 files changed, 28 insertions, 0 deletions
diff --git a/filters/syntax-highlighting.sh b/filters/syntax-highlighting.sh
index 6283ce9..5fcc9c9 100755
--- a/filters/syntax-highlighting.sh
+++ b/filters/syntax-highlighting.sh
@@ -42,4 +42,32 @@ EXTENSION="${BASENAME##*.}"
42# map Makefile and Makefile.* to .mk 42# map Makefile and Makefile.* to .mk
43[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk 43[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk
44 44
45# highlight versions 2 and 3 have different commandline options. Specifically,
46# the -X option that is used for version 2 is replaced by the -O xhtml option
47# for version 3.
48#
49# Version 2 can be found (for example) on EPEL 5, while version 3 can be
50# found (for example) on EPEL 6.
51#
52# This is for version 2
45exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null 53exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null
54
55# This is for version 3
56#
57# On CentOS 6.2 (using highlight from EPEL), when highlight doesn't know about
58# an EXTENSION, it outputs a lua error and _no_ text, even when the --force
59# option is used.
60#
61# Also see the bug reports at:
62# http://sourceforge.net/tracker/?func=detail&aid=3490017&group_id=215618&atid=1034391
63# https://bugzilla.redhat.com/show_bug.cgi?id=795567
64#
65# This workaround can be removed when the bug is fixed upstream and the new
66# version is packaged in most distributions.
67#
68# The workaround is to set the extension to 'txt' (plain text) when highlight
69# exits with an error (doesn't know the format).
70#
71#echo "test" | highlight -f -I -O xhtml -S $EXTENSION &>/dev/null
72#[ ${?} -ne 0 ] && EXTENSION="txt"
73#exec highlight --force -f -I -O xhtml -S $EXTENSION 2>/dev/null