aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2012-03-19 05:23:30 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2012-03-19 05:23:30 (JST)
commit08352c7a02f057f6cbaf817ca7e53c53be590a62 (patch)
treef1fbe011c9279d3e7fd699e6ae3fe1fc89627126
parent6e63ebfe004342cbe35e0b0f28de646ffa61933a (diff)
parentf50be7fda0a7ab57009169dd5905fcbab8eb5166 (diff)
downloadcgit-08352c7a02f057f6cbaf817ca7e53c53be590a62.zip
cgit-08352c7a02f057f6cbaf817ca7e53c53be590a62.tar.gz
Merge branch 'stable'
-rwxr-xr-xfilters/syntax-highlighting.sh28
-rwxr-xr-xtests/setup.sh4
-rwxr-xr-xtests/t0108-patch.sh2
3 files changed, 31 insertions, 3 deletions
diff --git a/filters/syntax-highlighting.sh b/filters/syntax-highlighting.sh
index 6283ce9..5fcc9c9 100755
--- a/filters/syntax-highlighting.sh
+++ b/filters/syntax-highlighting.sh
@@ -42,4 +42,32 @@ EXTENSION="${BASENAME##*.}"
42# map Makefile and Makefile.* to .mk 42# map Makefile and Makefile.* to .mk
43[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk 43[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk
44 44
45# highlight versions 2 and 3 have different commandline options. Specifically,
46# the -X option that is used for version 2 is replaced by the -O xhtml option
47# for version 3.
48#
49# Version 2 can be found (for example) on EPEL 5, while version 3 can be
50# found (for example) on EPEL 6.
51#
52# This is for version 2
45exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null 53exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null
54
55# This is for version 3
56#
57# On CentOS 6.2 (using highlight from EPEL), when highlight doesn't know about
58# an EXTENSION, it outputs a lua error and _no_ text, even when the --force
59# option is used.
60#
61# Also see the bug reports at:
62# http://sourceforge.net/tracker/?func=detail&aid=3490017&group_id=215618&atid=1034391
63# https://bugzilla.redhat.com/show_bug.cgi?id=795567
64#
65# This workaround can be removed when the bug is fixed upstream and the new
66# version is packaged in most distributions.
67#
68# The workaround is to set the extension to 'txt' (plain text) when highlight
69# exits with an error (doesn't know the format).
70#
71#echo "test" | highlight -f -I -O xhtml -S $EXTENSION &>/dev/null
72#[ ${?} -ne 0 ] && EXTENSION="txt"
73#exec highlight --force -f -I -O xhtml -S $EXTENSION 2>/dev/null
diff --git a/tests/setup.sh b/tests/setup.sh
index b21908d..e3c6c17 100755
--- a/tests/setup.sh
+++ b/tests/setup.sh
@@ -22,7 +22,7 @@ mkrepo() {
22 count=$2 22 count=$2
23 dir=$PWD 23 dir=$PWD
24 test -d "$name" && return 24 test -d "$name" && return
25 printf "Creating testrepo %s\n" $name 25 printf "Creating testrepo %s\n" "$name"
26 mkdir -p "$name" 26 mkdir -p "$name"
27 cd "$name" 27 cd "$name"
28 git init 28 git init
@@ -41,7 +41,7 @@ mkrepo() {
41 git commit -m "add a+b" 41 git commit -m "add a+b"
42 git branch "1+2" 42 git branch "1+2"
43 fi 43 fi
44 cd $dir 44 cd "$dir"
45} 45}
46 46
47setup_repos() 47setup_repos()
diff --git a/tests/t0108-patch.sh b/tests/t0108-patch.sh
index e608104..6ee70b3 100755
--- a/tests/t0108-patch.sh
+++ b/tests/t0108-patch.sh
@@ -25,7 +25,7 @@ run_test 'find `cgit` signature' '
25' 25'
26 26
27run_test 'find initial commit' ' 27run_test 'find initial commit' '
28 root=$(git --git-dir=$PWD/trash/repos/foo/.git rev-list HEAD | tail -1) 28 root=$(git --git-dir="$PWD/trash/repos/foo/.git" rev-list HEAD | tail -1)
29' 29'
30 30
31run_test 'generate patch for initial commit' ' 31run_test 'generate patch for initial commit' '