aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Ramsay Jones <ramsay@ramsay1.demon.co.uk>2008-11-16 03:26:32 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2008-12-04 07:39:30 (JST)
commit97fdac1608a0b4b07aae26b144c6ee7991e6c5eb (patch)
treee140bc09861b1d7a08a7fd7a3ef89e89b56b939e
parentc7d1402b177f4cf835e81f962e2faa3c9e28c549 (diff)
downloadcgit-97fdac1608a0b4b07aae26b144c6ee7991e6c5eb.zip
cgit-97fdac1608a0b4b07aae26b144c6ee7991e6c5eb.tar.gz
Extra cygwin-specific changes
Signed-off-by: Ramsay Jones <ramsay@ramsay1.demon.co.uk> Signed-off-by: Lars Hjemli <hjemli@gmail.com>
-rw-r--r--Makefile23
-rw-r--r--cgit.h6
2 files changed, 23 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 2107610..dc98072 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,26 @@ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
12# 12#
13-include cgit.conf 13-include cgit.conf
14 14
15# Define NO_STRCASESTR if you don't have strcasestr.
16#
17# Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
18#
19
20#-include config.mak
21
22#
23# Platform specific tweaks
24#
25
26uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
27uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
28uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
29
30ifeq ($(uname_O),Cygwin)
31 NO_STRCASESTR = YesPlease
32 NEEDS_LIBICONV = YesPlease
33endif
34
15# 35#
16# Define a way to invoke make in subdirs quietly, shamelessly ripped 36# Define a way to invoke make in subdirs quietly, shamelessly ripped
17# from git.git 37# from git.git
@@ -96,6 +116,9 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
96ifdef NO_ICONV 116ifdef NO_ICONV
97 CFLAGS += -DNO_ICONV 117 CFLAGS += -DNO_ICONV
98endif 118endif
119ifdef NO_STRCASESTR
120 CFLAGS += -DNO_STRCASESTR
121endif
99 122
100cgit: $(OBJECTS) libgit 123cgit: $(OBJECTS) libgit
101 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS) 124 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
diff --git a/cgit.h b/cgit.h
index 91db98a..92f0c5a 100644
--- a/cgit.h
+++ b/cgit.h
@@ -233,11 +233,5 @@ extern const char *cgit_repobasename(const char *reponame);
233 233
234extern int cgit_parse_snapshots_mask(const char *str); 234extern int cgit_parse_snapshots_mask(const char *str);
235 235
236/* libgit.a either links against or compiles its own implementation of
237 * strcasestr(), and we'd like to reuse it. Simply re-declaring it
238 * seems to do the trick.
239 */
240extern char *strcasestr(const char *haystack, const char *needle);
241
242 236
243#endif /* CGIT_H */ 237#endif /* CGIT_H */