aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2107610..dc98072 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,26 @@ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
12# 12#
13-include cgit.conf 13-include cgit.conf
14 14
15# Define NO_STRCASESTR if you don't have strcasestr.
16#
17# Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
18#
19
20#-include config.mak
21
22#
23# Platform specific tweaks
24#
25
26uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
27uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
28uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
29
30ifeq ($(uname_O),Cygwin)
31 NO_STRCASESTR = YesPlease
32 NEEDS_LIBICONV = YesPlease
33endif
34
15# 35#
16# Define a way to invoke make in subdirs quietly, shamelessly ripped 36# Define a way to invoke make in subdirs quietly, shamelessly ripped
17# from git.git 37# from git.git
@@ -96,6 +116,9 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
96ifdef NO_ICONV 116ifdef NO_ICONV
97 CFLAGS += -DNO_ICONV 117 CFLAGS += -DNO_ICONV
98endif 118endif
119ifdef NO_STRCASESTR
120 CFLAGS += -DNO_STRCASESTR
121endif
99 122
100cgit: $(OBJECTS) libgit 123cgit: $(OBJECTS) libgit
101 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS) 124 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)