aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 07:50:16 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 07:54:45 (JST)
commit76827d8679d1d2bd46e8cddf7da2ce4178e1d676 (patch)
treefd098df26c13d87005a000de0a38ef97c73d04c4
parent7640d90b73c01b16bb04ce4c541f52cbaae5f82a (diff)
downloadcgit-76827d8679d1d2bd46e8cddf7da2ce4178e1d676.zip
cgit-76827d8679d1d2bd46e8cddf7da2ce4178e1d676.tar.gz
Add version identifier in generated files
Signed-off-by: Lars Hjemli <hjemli@gmail.com>
-rw-r--r--Makefile14
-rw-r--r--cgit.c9
2 files changed, 14 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 243f590..21e2eb3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
1CGIT_VERSION = 0.1-pre
1 2
2INSTALL_BIN = /var/www/htdocs/cgit.cgi 3INSTALL_BIN = /var/www/htdocs/cgit.cgi
3INSTALL_CSS = /var/www/htdocs/cgit.css 4INSTALL_CSS = /var/www/htdocs/cgit.css
4 5
5EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 6EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
6OBJECTS = cgit.o config.o html.o cache.o 7OBJECTS = config.o html.o cache.o
7 8
8CFLAGS += -Wall 9CFLAGS += -Wall
9 10
@@ -13,10 +14,11 @@ install: all
13 install cgit $(INSTALL_BIN) 14 install cgit $(INSTALL_BIN)
14 install cgit.css $(INSTALL_CSS) 15 install cgit.css $(INSTALL_CSS)
15 16
16clean: 17cgit: cgit.c cgit.h git.h $(OBJECTS)
17 rm -f cgit *.o 18 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit $(OBJECTS) $(EXTLIBS)
18
19cgit: $(OBJECTS)
20 $(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
21 19
22$(OBJECTS): cgit.h git.h 20$(OBJECTS): cgit.h git.h
21
22.PHONY: clean
23clean:
24 rm -f cgit *.o
diff --git a/cgit.c b/cgit.c
index 808ffe9..110face 100644
--- a/cgit.c
+++ b/cgit.c
@@ -8,14 +8,16 @@
8 8
9#include "cgit.h" 9#include "cgit.h"
10 10
11static const char cgit_doctype[] = 11const char cgit_version[] = CGIT_VERSION;
12
13const char cgit_doctype[] =
12"<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"\n" 14"<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"\n"
13" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"; 15" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n";
14 16
15static const char cgit_error[] = 17const char cgit_error[] =
16"<div class='error'>%s</div>"; 18"<div class='error'>%s</div>";
17 19
18static const char cgit_lib_error[] = 20const char cgit_lib_error[] =
19"<div class='error'>%s: %s</div>"; 21"<div class='error'>%s: %s</div>";
20 22
21int htmlfd = 0; 23int htmlfd = 0;
@@ -200,6 +202,7 @@ static void cgit_print_docstart(char *title)
200 html("<title>"); 202 html("<title>");
201 html_txt(title); 203 html_txt(title);
202 html("</title>\n"); 204 html("</title>\n");
205 htmlf("<meta name='generator' content='cgit v%s'/>\n", cgit_version);
203 html("<link rel='stylesheet' type='text/css' href='"); 206 html("<link rel='stylesheet' type='text/css' href='");
204 html_attr(cgit_css); 207 html_attr(cgit_css);
205 html("'/>\n"); 208 html("'/>\n");