aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 243f590..21e2eb3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
1CGIT_VERSION = 0.1-pre
1 2
2INSTALL_BIN = /var/www/htdocs/cgit.cgi 3INSTALL_BIN = /var/www/htdocs/cgit.cgi
3INSTALL_CSS = /var/www/htdocs/cgit.css 4INSTALL_CSS = /var/www/htdocs/cgit.css
4 5
5EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 6EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
6OBJECTS = cgit.o config.o html.o cache.o 7OBJECTS = config.o html.o cache.o
7 8
8CFLAGS += -Wall 9CFLAGS += -Wall
9 10
@@ -13,10 +14,11 @@ install: all
13 install cgit $(INSTALL_BIN) 14 install cgit $(INSTALL_BIN)
14 install cgit.css $(INSTALL_CSS) 15 install cgit.css $(INSTALL_CSS)
15 16
16clean: 17cgit: cgit.c cgit.h git.h $(OBJECTS)
17 rm -f cgit *.o 18 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit $(OBJECTS) $(EXTLIBS)
18
19cgit: $(OBJECTS)
20 $(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
21 19
22$(OBJECTS): cgit.h git.h 20$(OBJECTS): cgit.h git.h
21
22.PHONY: clean
23clean:
24 rm -f cgit *.o