aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2008-12-06 19:33:05 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2008-12-06 19:33:05 (JST)
commit3157ea3b7e5204dba2892ffb54d641746c4c7ca4 (patch)
tree93198341d83438fce50ffeda19b2510138b7b2e5
parent7b5cee65fd9cf31e4f19ce4ff613778cb95512a9 (diff)
parentd2592a2cb5ca202d9825d8f1ca6f4a712ea8fe2b (diff)
downloadcgit-3157ea3b7e5204dba2892ffb54d641746c4c7ca4.zip
cgit-3157ea3b7e5204dba2892ffb54d641746c4c7ca4.tar.gz
Merge branch 'stable'
-rw-r--r--Makefile23
-rw-r--r--cgit.h6
-rw-r--r--parsing.c4
-rw-r--r--ui-log.c17
-rw-r--r--ui-repolist.c4
5 files changed, 46 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 2107610..2e51c31 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,26 @@ SHA1_HEADER = <openssl/sha.h>
7GIT_VER = 1.6.0.3 7GIT_VER = 1.6.0.3
8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2 8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
9 9
10# Define NO_STRCASESTR if you don't have strcasestr.
11#
12# Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
13#
14
15#-include config.mak
16
17#
18# Platform specific tweaks
19#
20
21uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
22uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
23uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
24
25ifeq ($(uname_O),Cygwin)
26 NO_STRCASESTR = YesPlease
27 NEEDS_LIBICONV = YesPlease
28endif
29
10# 30#
11# Let the user override the above settings. 31# Let the user override the above settings.
12# 32#
@@ -96,6 +116,9 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
96ifdef NO_ICONV 116ifdef NO_ICONV
97 CFLAGS += -DNO_ICONV 117 CFLAGS += -DNO_ICONV
98endif 118endif
119ifdef NO_STRCASESTR
120 CFLAGS += -DNO_STRCASESTR
121endif
99 122
100cgit: $(OBJECTS) libgit 123cgit: $(OBJECTS) libgit
101 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS) 124 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
diff --git a/cgit.h b/cgit.h
index 91db98a..92f0c5a 100644
--- a/cgit.h
+++ b/cgit.h
@@ -233,11 +233,5 @@ extern const char *cgit_repobasename(const char *reponame);
233 233
234extern int cgit_parse_snapshots_mask(const char *str); 234extern int cgit_parse_snapshots_mask(const char *str);
235 235
236/* libgit.a either links against or compiles its own implementation of
237 * strcasestr(), and we'd like to reuse it. Simply re-declaring it
238 * seems to do the trick.
239 */
240extern char *strcasestr(const char *haystack, const char *needle);
241
242 236
243#endif /* CGIT_H */ 237#endif /* CGIT_H */
diff --git a/parsing.c b/parsing.c
index c8f3048..f3f3b15 100644
--- a/parsing.c
+++ b/parsing.c
@@ -96,6 +96,9 @@ char *parse_user(char *t, char **name, char **email, unsigned long *date)
96 return p; 96 return p;
97} 97}
98 98
99#ifdef NO_ICONV
100#define reencode(a, b, c)
101#else
99const char *reencode(char **txt, const char *src_enc, const char *dst_enc) 102const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
100{ 103{
101 char *tmp; 104 char *tmp;
@@ -110,6 +113,7 @@ const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
110 } 113 }
111 return *txt; 114 return *txt;
112} 115}
116#endif
113 117
114struct commitinfo *cgit_parse_commit(struct commit *commit) 118struct commitinfo *cgit_parse_commit(struct commit *commit)
115{ 119{
diff --git a/ui-log.c b/ui-log.c
index 8dd8b89..d212984 100644
--- a/ui-log.c
+++ b/ui-log.c
@@ -64,18 +64,31 @@ void print_commit(struct commit *commit)
64 cgit_free_commitinfo(info); 64 cgit_free_commitinfo(info);
65} 65}
66 66
67static const char *disambiguate_ref(const char *ref)
68{
69 unsigned char sha1[20];
70 const char *longref;
71
72 longref = fmt("refs/heads/%s", ref);
73 if (get_sha1(longref, sha1) == 0)
74 return longref;
75
76 return ref;
77}
67 78
68void cgit_print_log(const char *tip, int ofs, int cnt, char *grep, char *pattern, 79void cgit_print_log(const char *tip, int ofs, int cnt, char *grep, char *pattern,
69 char *path, int pager) 80 char *path, int pager)
70{ 81{
71 struct rev_info rev; 82 struct rev_info rev;
72 struct commit *commit; 83 struct commit *commit;
73 const char *argv[] = {NULL, tip, NULL, NULL, NULL}; 84 const char *argv[] = {NULL, NULL, NULL, NULL, NULL};
74 int argc = 2; 85 int argc = 2;
75 int i, columns = 3; 86 int i, columns = 3;
76 87
77 if (!tip) 88 if (!tip)
78 argv[1] = ctx.qry.head; 89 tip = ctx.qry.head;
90
91 argv[1] = disambiguate_ref(tip);
79 92
80 if (grep && pattern && (!strcmp(grep, "grep") || 93 if (grep && pattern && (!strcmp(grep, "grep") ||
81 !strcmp(grep, "author") || 94 !strcmp(grep, "author") ||
diff --git a/ui-repolist.c b/ui-repolist.c
index c23232c..2324273 100644
--- a/ui-repolist.c
+++ b/ui-repolist.c
@@ -6,6 +6,10 @@
6 * (see COPYING for full license text) 6 * (see COPYING for full license text)
7 */ 7 */
8 8
9/* This is needed for strcasestr to be defined by <string.h> */
10#define _GNU_SOURCE 1
11#include <string.h>
12
9#include <time.h> 13#include <time.h>
10 14
11#include "cgit.h" 15#include "cgit.h"