aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2008-12-06 03:13:32 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2008-12-06 03:13:32 (JST)
commitd2592a2cb5ca202d9825d8f1ca6f4a712ea8fe2b (patch)
tree93198341d83438fce50ffeda19b2510138b7b2e5
parenta1b01b2513510f8f93f7f8ca39969002cd496a19 (diff)
parent14b4e108a73b09ce9b6df2c7f2e417305ad68cf4 (diff)
downloadcgit-d2592a2cb5ca202d9825d8f1ca6f4a712ea8fe2b.zip
cgit-d2592a2cb5ca202d9825d8f1ca6f4a712ea8fe2b.tar.gz
Merge branch 'rj/buildtweaks' into stable
-rw-r--r--Makefile23
-rw-r--r--cgit.h6
-rw-r--r--parsing.c4
-rw-r--r--ui-repolist.c4
4 files changed, 31 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 2107610..2e51c31 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,26 @@ SHA1_HEADER = <openssl/sha.h>
7GIT_VER = 1.6.0.3 7GIT_VER = 1.6.0.3
8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2 8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
9 9
10# Define NO_STRCASESTR if you don't have strcasestr.
11#
12# Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
13#
14
15#-include config.mak
16
17#
18# Platform specific tweaks
19#
20
21uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
22uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
23uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
24
25ifeq ($(uname_O),Cygwin)
26 NO_STRCASESTR = YesPlease
27 NEEDS_LIBICONV = YesPlease
28endif
29
10# 30#
11# Let the user override the above settings. 31# Let the user override the above settings.
12# 32#
@@ -96,6 +116,9 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
96ifdef NO_ICONV 116ifdef NO_ICONV
97 CFLAGS += -DNO_ICONV 117 CFLAGS += -DNO_ICONV
98endif 118endif
119ifdef NO_STRCASESTR
120 CFLAGS += -DNO_STRCASESTR
121endif
99 122
100cgit: $(OBJECTS) libgit 123cgit: $(OBJECTS) libgit
101 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS) 124 $(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
diff --git a/cgit.h b/cgit.h
index 91db98a..92f0c5a 100644
--- a/cgit.h
+++ b/cgit.h
@@ -233,11 +233,5 @@ extern const char *cgit_repobasename(const char *reponame);
233 233
234extern int cgit_parse_snapshots_mask(const char *str); 234extern int cgit_parse_snapshots_mask(const char *str);
235 235
236/* libgit.a either links against or compiles its own implementation of
237 * strcasestr(), and we'd like to reuse it. Simply re-declaring it
238 * seems to do the trick.
239 */
240extern char *strcasestr(const char *haystack, const char *needle);
241
242 236
243#endif /* CGIT_H */ 237#endif /* CGIT_H */
diff --git a/parsing.c b/parsing.c
index c8f3048..f3f3b15 100644
--- a/parsing.c
+++ b/parsing.c
@@ -96,6 +96,9 @@ char *parse_user(char *t, char **name, char **email, unsigned long *date)
96 return p; 96 return p;
97} 97}
98 98
99#ifdef NO_ICONV
100#define reencode(a, b, c)
101#else
99const char *reencode(char **txt, const char *src_enc, const char *dst_enc) 102const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
100{ 103{
101 char *tmp; 104 char *tmp;
@@ -110,6 +113,7 @@ const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
110 } 113 }
111 return *txt; 114 return *txt;
112} 115}
116#endif
113 117
114struct commitinfo *cgit_parse_commit(struct commit *commit) 118struct commitinfo *cgit_parse_commit(struct commit *commit)
115{ 119{
diff --git a/ui-repolist.c b/ui-repolist.c
index c23232c..2324273 100644
--- a/ui-repolist.c
+++ b/ui-repolist.c
@@ -6,6 +6,10 @@
6 * (see COPYING for full license text) 6 * (see COPYING for full license text)
7 */ 7 */
8 8
9/* This is needed for strcasestr to be defined by <string.h> */
10#define _GNU_SOURCE 1
11#include <string.h>
12
9#include <time.h> 13#include <time.h>
10 14
11#include "cgit.h" 15#include "cgit.h"