aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d1950cb..faf7b98 100644
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,13 @@ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
13-include cgit.conf 13-include cgit.conf
14 14
15 15
16#
17# Define a pattern rule for automatic dependency building
18#
19%.d: %.c
20 $(CC) $(CFLAGS) -MM $< | sed -e 's/\($*\)\.o:/\1.o $@:/g' >$@
21
22
16EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto 23EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto
17OBJECTS = 24OBJECTS =
18OBJECTS += cache.o 25OBJECTS += cache.o
@@ -61,6 +68,8 @@ cgit: $(OBJECTS)
61 68
62$(OBJECTS): git/xdiff/lib.a git/libgit.a VERSION 69$(OBJECTS): git/xdiff/lib.a git/libgit.a VERSION
63 70
71-include $(OBJECTS:.o=.d)
72
64git/xdiff/lib.a: | git 73git/xdiff/lib.a: | git
65 74
66git/libgit.a: | git 75git/libgit.a: | git
@@ -84,7 +93,7 @@ uninstall:
84 rm -f $(CGIT_SCRIPT_PATH)/cgit.png 93 rm -f $(CGIT_SCRIPT_PATH)/cgit.png
85 94
86clean: 95clean:
87 rm -f cgit VERSION *.o 96 rm -f cgit VERSION *.o *.d
88 cd git && $(MAKE) clean 97 cd git && $(MAKE) clean
89 98
90distclean: clean 99distclean: clean