aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/cgit.cron.d.ex4
-rw-r--r--debian/cgit.default.ex10
-rw-r--r--debian/cgit.doc-base.EX20
-rw-r--r--debian/init.d.ex166
-rw-r--r--debian/manpage.1.ex56
-rw-r--r--debian/manpage.sgml.ex154
-rw-r--r--debian/manpage.xml.ex291
-rw-r--r--debian/menu.ex2
-rw-r--r--debian/postinst.ex39
-rw-r--r--debian/postrm.ex37
-rw-r--r--debian/preinst.ex35
-rw-r--r--debian/prerm.ex38
-rw-r--r--debian/watch.ex23
13 files changed, 0 insertions, 875 deletions
diff --git a/debian/cgit.cron.d.ex b/debian/cgit.cron.d.ex
deleted file mode 100644
index 85a9e7b..0000000
--- a/debian/cgit.cron.d.ex
+++ /dev/null
@@ -1,4 +0,0 @@
1#
2# Regular cron jobs for the cgit package
3#
40 4 * * * root [ -x /usr/bin/cgit_maintenance ] && /usr/bin/cgit_maintenance
diff --git a/debian/cgit.default.ex b/debian/cgit.default.ex
deleted file mode 100644
index bd6b10c..0000000
--- a/debian/cgit.default.ex
+++ /dev/null
@@ -1,10 +0,0 @@
1# Defaults for cgit initscript
2# sourced by /etc/init.d/cgit
3# installed at /etc/default/cgit by the maintainer scripts
4
5#
6# This is a POSIX shell fragment
7#
8
9# Additional options that are passed to the Daemon.
10DAEMON_OPTS=""
diff --git a/debian/cgit.doc-base.EX b/debian/cgit.doc-base.EX
deleted file mode 100644
index ee68aec..0000000
--- a/debian/cgit.doc-base.EX
+++ /dev/null
@@ -1,20 +0,0 @@
1Document: cgit
2Title: Debian cgit Manual
3Author: <insert document author here>
4Abstract: This manual describes what cgit is
5 and how it can be used to
6 manage online manuals on Debian systems.
7Section: unknown
8
9Format: debiandoc-sgml
10Files: /usr/share/doc/cgit/cgit.sgml.gz
11
12Format: postscript
13Files: /usr/share/doc/cgit/cgit.ps.gz
14
15Format: text
16Files: /usr/share/doc/cgit/cgit.text.gz
17
18Format: HTML
19Index: /usr/share/doc/cgit/html/index.html
20Files: /usr/share/doc/cgit/html/*.html
diff --git a/debian/init.d.ex b/debian/init.d.ex
deleted file mode 100644
index 5bf16a6..0000000
--- a/debian/init.d.ex
+++ /dev/null
@@ -1,166 +0,0 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: cgit
4# Required-Start: $local_fs $network $remote_fs $syslog
5# Required-Stop: $local_fs $network $remote_fs $syslog
6# Default-Start: 2 3 4 5
7# Default-Stop: 0 1 6
8# Short-Description: <Enter a short description of the software>
9# Description: <Enter a long description of the software>
10# <...>
11# <...>
12### END INIT INFO
13
14# Author: YAEGASHI Takeshi <yaegashi@debian.org>
15
16# Do NOT "set -e"
17
18# PATH should only include /usr/* if it runs after the mountnfs.sh script
19PATH=/sbin:/usr/sbin:/bin:/usr/bin
20DESC="cgit"
21NAME=cgit
22DAEMON=/usr/sbin/cgit
23DAEMON_ARGS=""
24PIDFILE=/var/run/$NAME.pid
25SCRIPTNAME=/etc/init.d/$NAME
26
27# Exit if the package is not installed
28[ -x "$DAEMON" ] || exit 0
29
30# Read configuration variable file if it is present
31[ -r /etc/default/$NAME ] && . /etc/default/$NAME
32
33# Load the VERBOSE setting and other rcS variables
34. /lib/init/vars.sh
35
36# Define LSB log_* functions.
37# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
38# and status_of_proc is working.
39. /lib/lsb/init-functions
40
41#
42# Function that starts the daemon/service
43#
44do_start()
45{
46 # Return
47 # 0 if daemon has been started
48 # 1 if daemon was already running
49 # 2 if daemon could not be started
50 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
51 || return 1
52 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
53 $DAEMON_ARGS \
54 || return 2
55 # The above code will not work for interpreted scripts, use the next
56 # six lines below instead (Ref: #643337, start-stop-daemon(8) )
57 #start-stop-daemon --start --quiet --pidfile $PIDFILE --startas $DAEMON \
58 # --name $NAME --test > /dev/null \
59 # || return 1
60 #start-stop-daemon --start --quiet --pidfile $PIDFILE --startas $DAEMON \
61 # --name $NAME -- $DAEMON_ARGS \
62 # || return 2
63
64 # Add code here, if necessary, that waits for the process to be ready
65 # to handle requests from services started subsequently which depend
66 # on this one. As a last resort, sleep for some time.
67}
68
69#
70# Function that stops the daemon/service
71#
72do_stop()
73{
74 # Return
75 # 0 if daemon has been stopped
76 # 1 if daemon was already stopped
77 # 2 if daemon could not be stopped
78 # other if a failure occurred
79 start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile $PIDFILE --name $NAME
80 RETVAL="$?"
81 [ "$RETVAL" = 2 ] && return 2
82 # Wait for children to finish too if this is a daemon that forks
83 # and if the daemon is only ever run from this initscript.
84 # If the above conditions are not satisfied then add some other code
85 # that waits for the process to drop all resources that could be
86 # needed by services started subsequently. A last resort is to
87 # sleep for some time.
88 start-stop-daemon --stop --quiet --oknodo --retry=0/30/KILL/5 --exec $DAEMON
89 [ "$?" = 2 ] && return 2
90 # Many daemons don't delete their pidfiles when they exit.
91 rm -f $PIDFILE
92 return "$RETVAL"
93}
94
95#
96# Function that sends a SIGHUP to the daemon/service
97#
98do_reload() {
99 #
100 # If the daemon can reload its configuration without
101 # restarting (for example, when it is sent a SIGHUP),
102 # then implement that here.
103 #
104 start-stop-daemon --stop --signal 1 --quiet --pidfile $PIDFILE --name $NAME
105 return 0
106}
107
108case "$1" in
109 start)
110 [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
111 do_start
112 case "$?" in
113 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
114 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
115 esac
116 ;;
117 stop)
118 [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
119 do_stop
120 case "$?" in
121 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
122 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
123 esac
124 ;;
125 status)
126 status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
127 ;;
128 #reload|force-reload)
129 #
130 # If do_reload() is not implemented then leave this commented out
131 # and leave 'force-reload' as an alias for 'restart'.
132 #
133 #log_daemon_msg "Reloading $DESC" "$NAME"
134 #do_reload
135 #log_end_msg $?
136 #;;
137 restart|force-reload)
138 #
139 # If the "reload" option is implemented then remove the
140 # 'force-reload' alias
141 #
142 log_daemon_msg "Restarting $DESC" "$NAME"
143 do_stop
144 case "$?" in
145 0|1)
146 do_start
147 case "$?" in
148 0) log_end_msg 0 ;;
149 1) log_end_msg 1 ;; # Old process is still running
150 *) log_end_msg 1 ;; # Failed to start
151 esac
152 ;;
153 *)
154 # Failed to stop
155 log_end_msg 1
156 ;;
157 esac
158 ;;
159 *)
160 #echo "Usage: $SCRIPTNAME {start|stop|restart|reload|force-reload}" >&2
161 echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
162 exit 3
163 ;;
164esac
165
166:
diff --git a/debian/manpage.1.ex b/debian/manpage.1.ex
deleted file mode 100644
index 2b30bf2..0000000
--- a/debian/manpage.1.ex
+++ /dev/null
@@ -1,56 +0,0 @@
1.\" Hey, EMACS: -*- nroff -*-
2.\" (C) Copyright 2014 YAEGASHI Takeshi <yaegashi@debian.org>,
3.\"
4.\" First parameter, NAME, should be all caps
5.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
6.\" other parameters are allowed: see man(7), man(1)
7.TH CGIT SECTION "February 14, 2014"
8.\" Please adjust this date whenever revising the manpage.
9.\"
10.\" Some roff macros, for reference:
11.\" .nh disable hyphenation
12.\" .hy enable hyphenation
13.\" .ad l left justify
14.\" .ad b justify to both left and right margins
15.\" .nf disable filling
16.\" .fi enable filling
17.\" .br insert line break
18.\" .sp <n> insert n+1 empty lines
19.\" for manpage-specific macros, see man(7)
20.SH NAME
21cgit \- program to do something
22.SH SYNOPSIS
23.B cgit
24.RI [ options ] " files" ...
25.br
26.B bar
27.RI [ options ] " files" ...
28.SH DESCRIPTION
29This manual page documents briefly the
30.B cgit
31and
32.B bar
33commands.
34.PP
35.\" TeX users may be more comfortable with the \fB<whatever>\fP and
36.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
37.\" respectively.
38\fBcgit\fP is a program that...
39.SH OPTIONS
40These programs follow the usual GNU command line syntax, with long
41options starting with two dashes (`-').
42A summary of options is included below.
43For a complete description, see the Info files.
44.TP
45.B \-h, \-\-help
46Show summary of options.
47.TP
48.B \-v, \-\-version
49Show version of program.
50.SH SEE ALSO
51.BR bar (1),
52.BR baz (1).
53.br
54The programs are documented fully by
55.IR "The Rise and Fall of a Fooish Bar" ,
56available via the Info system.
diff --git a/debian/manpage.sgml.ex b/debian/manpage.sgml.ex
deleted file mode 100644
index da4bae3..0000000
--- a/debian/manpage.sgml.ex
+++ /dev/null
@@ -1,154 +0,0 @@
1<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
2
3<!-- Process this file with docbook-to-man to generate an nroff manual
4 page: `docbook-to-man manpage.sgml > manpage.1'. You may view
5 the manual page with: `docbook-to-man manpage.sgml | nroff -man |
6 less'. A typical entry in a Makefile or Makefile.am is:
7
8manpage.1: manpage.sgml
9 docbook-to-man $< > $@
10
11
12 The docbook-to-man binary is found in the docbook-to-man package.
13 Please remember that if you create the nroff version in one of the
14 debian/rules file targets (such as build), you will need to include
15 docbook-to-man in your Build-Depends control field.
16
17 -->
18
19 <!-- Fill in your name for FIRSTNAME and SURNAME. -->
20 <!ENTITY dhfirstname "<firstname>FIRSTNAME</firstname>">
21 <!ENTITY dhsurname "<surname>SURNAME</surname>">
22 <!-- Please adjust the date whenever revising the manpage. -->
23 <!ENTITY dhdate "<date>February 14, 2014</date>">
24 <!-- SECTION should be 1-8, maybe w/ subsection other parameters are
25 allowed: see man(7), man(1). -->
26 <!ENTITY dhsection "<manvolnum>SECTION</manvolnum>">
27 <!ENTITY dhemail "<email>yaegashi@debian.org</email>">
28 <!ENTITY dhusername "YAEGASHI Takeshi">
29 <!ENTITY dhucpackage "<refentrytitle>CGIT</refentrytitle>">
30 <!ENTITY dhpackage "cgit">
31
32 <!ENTITY debian "<productname>Debian</productname>">
33 <!ENTITY gnu "<acronym>GNU</acronym>">
34 <!ENTITY gpl "&gnu; <acronym>GPL</acronym>">
35]>
36
37<refentry>
38 <refentryinfo>
39 <address>
40 &dhemail;
41 </address>
42 <author>
43 &dhfirstname;
44 &dhsurname;
45 </author>
46 <copyright>
47 <year>2003</year>
48 <holder>&dhusername;</holder>
49 </copyright>
50 &dhdate;
51 </refentryinfo>
52 <refmeta>
53 &dhucpackage;
54
55 &dhsection;
56 </refmeta>
57 <refnamediv>
58 <refname>&dhpackage;</refname>
59
60 <refpurpose>program to do something</refpurpose>
61 </refnamediv>
62 <refsynopsisdiv>
63 <cmdsynopsis>
64 <command>&dhpackage;</command>
65
66 <arg><option>-e <replaceable>this</replaceable></option></arg>
67
68 <arg><option>--example <replaceable>that</replaceable></option></arg>
69 </cmdsynopsis>
70 </refsynopsisdiv>
71 <refsect1>
72 <title>DESCRIPTION</title>
73
74 <para>This manual page documents briefly the
75 <command>&dhpackage;</command> and <command>bar</command>
76 commands.</para>
77
78 <para>This manual page was written for the &debian; distribution
79 because the original program does not have a manual page.
80 Instead, it has documentation in the &gnu;
81 <application>Info</application> format; see below.</para>
82
83 <para><command>&dhpackage;</command> is a program that...</para>
84
85 </refsect1>
86 <refsect1>
87 <title>OPTIONS</title>
88
89 <para>These programs follow the usual &gnu; command line syntax,
90 with long options starting with two dashes (`-'). A summary of
91 options is included below. For a complete description, see the
92 <application>Info</application> files.</para>
93
94 <variablelist>
95 <varlistentry>
96 <term><option>-h</option>
97 <option>--help</option>
98 </term>
99 <listitem>
100 <para>Show summary of options.</para>
101 </listitem>
102 </varlistentry>
103 <varlistentry>
104 <term><option>-v</option>
105 <option>--version</option>
106 </term>
107 <listitem>
108 <para>Show version of program.</para>
109 </listitem>
110 </varlistentry>
111 </variablelist>
112 </refsect1>
113 <refsect1>
114 <title>SEE ALSO</title>
115
116 <para>bar (1), baz (1).</para>