aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar YAEGASHI Takeshi <yaegashi@debian.org>2014-02-16 20:47:47 (JST)
committerGravatar YAEGASHI Takeshi <yaegashi@debian.org>2014-02-17 07:42:13 (JST)
commitd4829a571e3ef3c56a604e5bbc1d9a39e1e8742d (patch)
tree1943081e5db07f11a6c5c462b140e74528e1779a
parentc8b33b787429d73c1f78d9ff6373a422b74291b1 (diff)
downloadcgit-d4829a571e3ef3c56a604e5bbc1d9a39e1e8742d.zip
cgit-d4829a571e3ef3c56a604e5bbc1d9a39e1e8742d.tar.gz
Remove dh_make example files
-rw-r--r--debian/cgit.cron.d.ex4
-rw-r--r--debian/cgit.default.ex10
-rw-r--r--debian/cgit.doc-base.EX20
-rw-r--r--debian/init.d.ex166
-rw-r--r--debian/manpage.1.ex56
-rw-r--r--debian/manpage.sgml.ex154
-rw-r--r--debian/manpage.xml.ex291
-rw-r--r--debian/menu.ex2
-rw-r--r--debian/postinst.ex39
-rw-r--r--debian/postrm.ex37
-rw-r--r--debian/preinst.ex35
-rw-r--r--debian/prerm.ex38
-rw-r--r--debian/watch.ex23
13 files changed, 0 insertions, 875 deletions
diff --git a/debian/cgit.cron.d.ex b/debian/cgit.cron.d.ex
deleted file mode 100644
index 85a9e7b..0000000
--- a/debian/cgit.cron.d.ex
+++ /dev/null
@@ -1,4 +0,0 @@
1#
2# Regular cron jobs for the cgit package
3#
40 4 * * * root [ -x /usr/bin/cgit_maintenance ] && /usr/bin/cgit_maintenance
diff --git a/debian/cgit.default.ex b/debian/cgit.default.ex
deleted file mode 100644
index bd6b10c..0000000
--- a/debian/cgit.default.ex
+++ /dev/null
@@ -1,10 +0,0 @@
1# Defaults for cgit initscript
2# sourced by /etc/init.d/cgit
3# installed at /etc/default/cgit by the maintainer scripts
4
5#
6# This is a POSIX shell fragment
7#
8
9# Additional options that are passed to the Daemon.
10DAEMON_OPTS=""
diff --git a/debian/cgit.doc-base.EX b/debian/cgit.doc-base.EX
deleted file mode 100644
index ee68aec..0000000
--- a/debian/cgit.doc-base.EX
+++ /dev/null
@@ -1,20 +0,0 @@
1Document: cgit
2Title: Debian cgit Manual
3Author: <insert document author here>
4Abstract: This manual describes what cgit is
5 and how it can be used to
6 manage online manuals on Debian systems.
7Section: unknown
8
9Format: debiandoc-sgml
10Files: /usr/share/doc/cgit/cgit.sgml.gz
11
12Format: postscript
13Files: /usr/share/doc/cgit/cgit.ps.gz
14
15Format: text
16Files: /usr/share/doc/cgit/cgit.text.gz
17
18Format: HTML
19Index: /usr/share/doc/cgit/html/index.html
20Files: /usr/share/doc/cgit/html/*.html
diff --git a/debian/init.d.ex b/debian/init.d.ex
deleted file mode 100644
index 5bf16a6..0000000
--- a/debian/init.d.ex
+++ /dev/null
@@ -1,166 +0,0 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: cgit
4# Required-Start: $local_fs $network $remote_fs $syslog
5# Required-Stop: $local_fs $network $remote_fs $syslog
6# Default-Start: 2 3 4 5
7# Default-Stop: 0 1 6
8# Short-Description: <Enter a short description of the software>
9# Description: <Enter a long description of the software>
10# <...>
11# <...>
12### END INIT INFO
13
14# Author: YAEGASHI Takeshi <yaegashi@debian.org>
15
16# Do NOT "set -e"
17
18# PATH should only include /usr/* if it runs after the mountnfs.sh script
19PATH=/sbin:/usr/sbin:/bin:/usr/bin
20DESC="cgit"
21NAME=cgit
22DAEMON=/usr/sbin/cgit
23DAEMON_ARGS=""
24PIDFILE=/var/run/$NAME.pid
25SCRIPTNAME=/etc/init.d/$NAME
26
27# Exit if the package is not installed
28[ -x "$DAEMON" ] || exit 0
29
30# Read configuration variable file if it is present
31[ -r /etc/default/$NAME ] && . /etc/default/$NAME
32
33# Load the VERBOSE setting and other rcS variables
34. /lib/init/vars.sh
35
36# Define LSB log_* functions.
37# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
38# and status_of_proc is working.
39. /lib/lsb/init-functions
40
41#
42# Function that starts the daemon/service
43#
44do_start()
45{
46 # Return
47 # 0 if daemon has been started
48 # 1 if daemon was already running
49 # 2 if daemon could not be started
50 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
51 || return 1
52 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
53 $DAEMON_ARGS \
54 || return 2
55 # The above code will not work for interpreted scripts, use the next
56 # six lines below instead (Ref: #643337, start-stop-daemon(8) )
57 #start-stop-daemon --start --quiet --pidfile $PIDFILE --startas $DAEMON \
58 # --name $NAME --test > /dev/null \
59 # || return 1
60 #start-stop-daemon --start --quiet --pidfile $PIDFILE --startas $DAEMON \
61 # --name $NAME -- $DAEMON_ARGS \
62 # || return 2
63
64 # Add code here, if necessary, that waits for the process to be ready
65 # to handle requests from services started subsequently which depend
66 # on this one. As a last resort, sleep for some time.
67}
68
69#
70# Function that stops the daemon/service
71#
72do_stop()
73{
74 # Return
75 # 0 if daemon has been stopped
76 # 1 if daemon was already stopped
77 # 2 if daemon could not be stopped
78 # other if a failure occurred
79 start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile $PIDFILE --name $NAME
80 RETVAL="$?"
81 [ "$RETVAL" = 2 ] && return 2
82 # Wait for children to finish too if this is a daemon that forks
83 # and if the daemon is only ever run from this initscript.
84 # If the above conditions are not satisfied then add some other code
85 # that waits for the process to drop all resources that could be
86 # needed by services started subsequently. A last resort is to
87 # sleep for some time.
88 start-stop-daemon --stop --quiet --oknodo --retry=0/30/KILL/5 --exec $DAEMON
89 [ "$?" = 2 ] && return 2
90 # Many daemons don't delete their pidfiles when they exit.
91 rm -f $PIDFILE
92 return "$RETVAL"
93}
94
95#
96# Function that sends a SIGHUP to the daemon/service
97#
98do_reload() {
99 #
100 # If the daemon can reload its configuration without
101 # restarting (for example, when it is sent a SIGHUP),
102 # then implement that here.
103 #
104 start-stop-daemon --stop --signal 1 --quiet --pidfile $PIDFILE --name $NAME
105 return 0
106}
107
108case "$1" in
109 start)
110 [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
111 do_start
112 case "$?" in
113 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
114 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
115 esac
116 ;;
117 stop)
118 [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
119 do_stop
120 case "$?" in
121 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
122 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
123 esac
124 ;;
125 status)
126 status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
127 ;;
128 #reload|force-reload)
129 #
130 # If do_reload() is not implemented then leave this commented out
131 # and leave 'force-reload' as an alias for 'restart'.
132 #
133 #log_daemon_msg "Reloading $DESC" "$NAME"
134 #do_reload
135 #log_end_msg $?
136 #;;
137 restart|force-reload)
138 #
139 # If the "reload" option is implemented then remove the
140 # 'force-reload' alias
141 #
142 log_daemon_msg "Restarting $DESC" "$NAME"
143 do_stop
144 case "$?" in
145 0|1)
146 do_start
147 case "$?" in
148 0) log_end_msg 0 ;;
149 1) log_end_msg 1 ;; # Old process is still running
150 *) log_end_msg 1 ;; # Failed to start
151 esac
152 ;;
153 *)
154 # Failed to stop
155 log_end_msg 1
156 ;;
157 esac
158 ;;
159 *)
160 #echo "Usage: $SCRIPTNAME {start|stop|restart|reload|force-reload}" >&2
161 echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
162 exit 3
163 ;;
164esac
165
166:
diff --git a/debian/manpage.1.ex b/debian/manpage.1.ex
deleted file mode 100644
index 2b30bf2..0000000
--- a/debian/manpage.1.ex
+++ /dev/null
@@ -1,56 +0,0 @@
1.\" Hey, EMACS: -*- nroff -*-
2.\" (C) Copyright 2014 YAEGASHI Takeshi <yaegashi@debian.org>,
3.\"
4.\" First parameter, NAME, should be all caps
5.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
6.\" other parameters are allowed: see man(7), man(1)
7.TH CGIT SECTION "February 14, 2014"
8.\" Please adjust this date whenever revising the manpage.
9.\"
10.\" Some roff macros, for reference:
11.\" .nh disable hyphenation
12.\" .hy enable hyphenation
13.\" .ad l left justify
14.\" .ad b justify to both left and right margins
15.\" .nf disable filling
16.\" .fi enable filling
17.\" .br insert line break
18.\" .sp <n> insert n+1 empty lines
19.\" for manpage-specific macros, see man(7)
20.SH NAME
21cgit \- program to do something
22.SH SYNOPSIS
23.B cgit
24.RI [ options ] " files" ...
25.br
26.B bar
27.RI [ options ] " files" ...
28.SH DESCRIPTION
29This manual page documents briefly the
30.B cgit
31and
32.B bar
33commands.
34.PP
35.\" TeX users may be more comfortable with the \fB<whatever>\fP and
36.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
37.\" respectively.
38\fBcgit\fP is a program that...
39.SH OPTIONS
40These programs follow the usual GNU command line syntax, with long
41options starting with two dashes (`-').
42A summary of options is included below.
43For a complete description, see the Info files.
44.TP
45.B \-h, \-\-help
46Show summary of options.
47.TP
48.B \-v, \-\-version
49Show version of program.
50.SH SEE ALSO
51.BR bar (1),
52.BR baz (1).
53.br
54The programs are documented fully by
55.IR "The Rise and Fall of a Fooish Bar" ,
56available via the Info system.
diff --git a/debian/manpage.sgml.ex b/debian/manpage.sgml.ex
deleted file mode 100644
index da4bae3..0000000
--- a/debian/manpage.sgml.ex
+++ /dev/null
@@ -1,154 +0,0 @@
1<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
2
3<!-- Process this file with docbook-to-man to generate an nroff manual
4 page: `docbook-to-man manpage.sgml > manpage.1'. You may view
5 the manual page with: `docbook-to-man manpage.sgml | nroff -man |
6 less'. A typical entry in a Makefile or Makefile.am is:
7
8manpage.1: manpage.sgml
9 docbook-to-man $< > $@
10
11
12 The docbook-to-man binary is found in the docbook-to-man package.
13 Please remember that if you create the nroff version in one of the
14 debian/rules file targets (such as build), you will need to include
15 docbook-to-man in your Build-Depends control field.
16
17 -->
18
19 <!-- Fill in your name for FIRSTNAME and SURNAME. -->
20 <!ENTITY dhfirstname "<firstname>FIRSTNAME</firstname>">
21 <!ENTITY dhsurname "<surname>SURNAME</surname>">
22 <!-- Please adjust the date whenever revising the manpage. -->
23 <!ENTITY dhdate "<date>February 14, 2014</date>">
24 <!-- SECTION should be 1-8, maybe w/ subsection other parameters are
25 allowed: see man(7), man(1). -->
26 <!ENTITY dhsection "<manvolnum>SECTION</manvolnum>">
27 <!ENTITY dhemail "<email>yaegashi@debian.org</email>">
28 <!ENTITY dhusername "YAEGASHI Takeshi">
29 <!ENTITY dhucpackage "<refentrytitle>CGIT</refentrytitle>">
30 <!ENTITY dhpackage "cgit">
31
32 <!ENTITY debian "<productname>Debian</productname>">
33 <!ENTITY gnu "<acronym>GNU</acronym>">
34 <!ENTITY gpl "&gnu; <acronym>GPL</acronym>">
35]>
36
37<refentry>
38 <refentryinfo>
39 <address>
40 &dhemail;
41 </address>
42 <author>
43 &dhfirstname;
44 &dhsurname;
45 </author>
46 <copyright>
47 <year>2003</year>
48 <holder>&dhusername;</holder>
49 </copyright>
50 &dhdate;
51 </refentryinfo>
52 <refmeta>
53 &dhucpackage;
54
55 &dhsection;
56 </refmeta>
57 <refnamediv>
58 <refname>&dhpackage;</refname>
59
60 <refpurpose>program to do something</refpurpose>
61 </refnamediv>
62 <refsynopsisdiv>
63 <cmdsynopsis>
64 <command>&dhpackage;</command>
65
66 <arg><option>-e <replaceable>this</replaceable></option></arg>
67
68 <arg><option>--example <replaceable>that</replaceable></option></arg>
69 </cmdsynopsis>
70 </refsynopsisdiv>
71 <refsect1>
72 <title>DESCRIPTION</title>
73
74 <para>This manual page documents briefly the
75 <command>&dhpackage;</command> and <command>bar</command>
76 commands.</para>
77
78 <para>This manual page was written for the &debian; distribution
79 because the original program does not have a manual page.
80 Instead, it has documentation in the &gnu;
81 <application>Info</application> format; see below.</para>
82
83 <para><command>&dhpackage;</command> is a program that...</para>
84
85 </refsect1>
86 <refsect1>
87 <title>OPTIONS</title>
88
89 <para>These programs follow the usual &gnu; command line syntax,
90 with long options starting with two dashes (`-'). A summary of
91 options is included below. For a complete description, see the
92 <application>Info</application> files.</para>
93
94 <variablelist>
95 <varlistentry>
96 <term><option>-h</option>
97 <option>--help</option>
98 </term>
99 <listitem>
100 <para>Show summary of options.</para>
101 </listitem>
102 </varlistentry>
103 <varlistentry>
104 <term><option>-v</option>
105 <option>--version</option>
106 </term>
107 <listitem>
108 <para>Show version of program.</para>
109 </listitem>
110 </varlistentry>
111 </variablelist>
112 </refsect1>
113 <refsect1>
114 <title>SEE ALSO</title>
115
116 <para>bar (1), baz (1).</para>
117
118 <para>The programs are documented fully by <citetitle>The Rise and
119 Fall of a Fooish Bar</citetitle> available via the
120 <application>Info</application> system.</para>
121 </refsect1>
122 <refsect1>
123 <title>AUTHOR</title>
124
125 <para>This manual page was written by &dhusername; &dhemail; for
126 the &debian; system (and may be used by others). Permission is
127 granted to copy, distribute and/or modify this document under
128 the terms of the &gnu; General Public License, Version 2 any
129 later version published by the Free Software Foundation.
130 </para>
131 <para>
132 On Debian systems, the complete text of the GNU General Public
133 License can be found in /usr/share/common-licenses/GPL.
134 </para>
135
136 </refsect1>
137</refentry>
138
139<!-- Keep this comment at the end of the file
140Local variables:
141mode: sgml
142sgml-omittag:t
143sgml-shorttag:t
144sgml-minimize-attributes:nil
145sgml-always-quote-attributes:t
146sgml-indent-step:2
147sgml-indent-data:t
148sgml-parent-document:nil
149sgml-default-dtd-file:nil
150sgml-exposed-tags:nil
151sgml-local-catalogs:nil
152sgml-local-ecat-files:nil
153End:
154-->
diff --git a/debian/manpage.xml.ex b/debian/manpage.xml.ex
deleted file mode 100644
index bc254b6..0000000
--- a/debian/manpage.xml.ex
+++ /dev/null
@@ -1,291 +0,0 @@
1<?xml version='1.0' encoding='UTF-8'?>
2<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4
5<!--
6
7`xsltproc -''-nonet \
8 -''-param man.charmap.use.subset "0" \
9 -''-param make.year.ranges "1" \
10 -''-param make.single.year.ranges "1" \
11 /usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl \
12 manpage.xml'
13
14A manual page <package>.<section> will be generated. You may view the
15manual page with: nroff -man <package>.<section> | less'. A typical entry
16in a Makefile or Makefile.am is:
17
18DB2MAN = /usr/share/sgml/docbook/stylesheet/xsl/docbook-xsl/manpages/docbook.xsl
19XP = xsltproc -''-nonet -''-param man.charmap.use.subset "0"
20
21manpage.1: manpage.xml
22 $(XP) $(DB2MAN) $<
23
24The xsltproc binary is found in the xsltproc package. The XSL files are in
25docbook-xsl. A description of the parameters you can use can be found in the
26docbook-xsl-doc-* packages. Please remember that if you create the nroff
27version in one of the debian/rules file targets (such as build), you will need
28to include xsltproc and docbook-xsl in your Build-Depends control field.
29Alternatively use the xmlto command/package. That will also automatically
30pull in xsltproc and docbook-xsl.
31
32Notes for using docbook2x: docbook2x-man does not automatically create the
33AUTHOR(S) and COPYRIGHT sections. In this case, please add them manually as
34<refsect1> ... </refsect1>.
35
36To disable the automatic creation of the AUTHOR(S) and COPYRIGHT sections
37read /usr/share/doc/docbook-xsl/doc/manpages/authors.html. This file can be
38found in the docbook-xsl-doc-html package.
39
40Validation can be done using: `xmllint -''-noout -''-valid manpage.xml`
41
42General documentation about man-pages and man-page-formatting:
43man(1), man(7), http://www.tldp.org/HOWTO/Man-Page/
44
45-->
46
47 <!-- Fill in your name for FIRSTNAME and SURNAME. -->
48 <!ENTITY dhfirstname "FIRSTNAME">
49 <!ENTITY dhsurname "SURNAME">
50 <!-- dhusername could also be set to "&dhfirstname; &dhsurname;". -->
51 <!ENTITY dhusername "YAEGASHI Takeshi">
52 <!ENTITY dhemail "yaegashi@debian.org">
53 <!-- SECTION should be 1-8, maybe w/ subsection other parameters are
54 allowed: see man(7), man(1) and
55 http://www.tldp.org/HOWTO/Man-Page/q2.html. -->
56 <!ENTITY dhsection "SECTION">
57 <!-- TITLE should be something like "User commands" or similar (see
58 http://www.tldp.org/HOWTO/Man-Page/q2.html). -->
59 <!ENTITY dhtitle "cgit User Manual">
60 <!ENTITY dhucpackage "CGIT">
61 <!ENTITY dhpackage "cgit">
62]>
63
64<refentry>
65 <refentryinfo>
66 <title>&dhtitle;</title>
67 <productname>&dhpackage;</productname>
68 <authorgroup>
69 <author>
70 <firstname>&dhfirstname;</firstname>
71 <surname>&dhsurname;</surname>
72 <contrib>Wrote this manpage for the Debian system.</contrib>
73 <address>
74 <email>&dhemail;</email>
75 </address>
76 </author>
77 </authorgroup>
78 <copyright>
79 <year>2007</year>
80 <holder>&dhusername;</holder>
81 </copyright>
82 <legalnotice>
83 <para>This manual page was written for the Debian system
84 (and may be used by others).</para>
85 <para>Permission is granted to copy, distribute and/or modify this
86 document under the terms of the GNU General Public License,
87 Version 2 or (at your option) any later version published by
88 the Free Software Foundation.</para>
89 <para>On Debian systems, the complete text of the GNU General Public
90 License can be found in
91 <filename>/usr/share/common-licenses/GPL</filename>.</para>
92 </legalnotice>
93 </refentryinfo>
94 <refmeta>
95 <refentrytitle>&dhucpackage;</refentrytitle>
96 <manvolnum>&dhsection;</manvolnum>
97 </refmeta>
98 <refnamediv>
99 <refname>&dhpackage;</refname>
100 <refpurpose>program to do something</refpurpose>
101 </refnamediv>
102 <refsynopsisdiv>
103 <cmdsynopsis>
104 <command>&dhpackage;</command>
105 <!-- These are several examples, how syntaxes could look -->
106 <arg choice="plain"><option>-e <replaceable>this</replaceable></option></arg>
107 <arg choice="opt"><option>--example=<parameter>that</parameter></option></arg>
108 <arg choice="opt">
109 <group choice="req">
110 <arg choice="plain"><option>-e</option></arg>
111 <arg choice="plain"><option>--example</option></arg>
112 </group>
113 <replaceable class="option">this</replaceable>
114 </arg>
115 <arg choice="opt">
116 <group choice="req">
117 <arg choice="plain"><option>-e</option></arg>
118 <arg choice="plain"><option>--example</option></arg>
119 </group>
120 <group choice="req">
121 <arg choice="plain"><replaceable>this</replaceable></arg>
122 <arg choice="plain"><replaceable>that</replaceable></arg>
123 </group>
124 </arg>
125 </cmdsynopsis>
126 <cmdsynopsis>
127 <command>&dhpackage;</command>
128 <!-- Normally the help and version options make the programs stop
129 right after outputting the requested information. -->
130 <group choice="opt">
131 <arg choice="plain">
132 <group choice="req">
133 <arg choice="plain"><option>-h</option></arg>
134 <arg choice="plain"><option>--help</option></arg>
135 </group>
136 </arg>
137 <arg choice="plain">
138 <group choice="req">
139 <arg choice="plain"><option>-v</option></arg>
140 <arg choice="plain"><option>--version</option></arg>
141 </group>
142 </arg>
143 </group>
144 </cmdsynopsis>
145 </refsynopsisdiv>
146 <refsect1 id="description">
147 <title>DESCRIPTION</title>
148 <para>This manual page documents briefly the
149 <command>&dhpackage;</command> and <command>bar</command>
150 commands.</para>
151 <para>This manual page was written for the Debian distribution
152 because the original program does not have a manual page.
153 Instead, it has documentation in the GNU <citerefentry>
154 <refentrytitle>info</refentrytitle>
155 <manvolnum>1</manvolnum>
156 </citerefentry> format; see below.</para>
157 <para><command>&dhpackage;</command> is a program that...</para>
158 </refsect1>
159 <refsect1 id="options">
160 <title>OPTIONS</title>
161 <para>The program follows the usual GNU command line syntax,
162 with long options starting with two dashes (`-'). A summary of
163 options is included below. For a complete description, see the
164 <citerefentry>
165 <refentrytitle>info</refentrytitle>
166 <manvolnum>1</manvolnum>
167 </citerefentry> files.</para>
168 <variablelist>
169 <!-- Use the variablelist.term.separator and the
170 variablelist.term.break.after parameters to
171 control the term elements. -->
172 <varlistentry>
173 <term><option>-e <replaceable>this</replaceable></option></term>
174 <term><option>--example=<replaceable>that</replaceable></option></term>
175 <listitem>
176 <para>Does this and that.</para>
177 </listitem>
178 </varlistentry>
179 <varlistentry>
180 <term><option>-h</option></term>
181 <term><option>--help</option></term>
182 <listitem>
183 <para>Show summary of options.</para>
184 </listitem>
185 </varlistentry>
186 <varlistentry>
187 <term><option>-v</option></term>
188 <term><option>--version</option></term>
189 <listitem>
190 <para>Show version of program.</para>
191 </listitem>
192 </varlistentry>
193 </variablelist>
194 </refsect1>
195 <refsect1 id="files">
196 <title>FILES</title>
197 <variablelist>
198 <varlistentry>
199 <term><filename>/etc/foo.conf</filename></term>
200 <listitem>
201 <para>The system-wide configuration file to control the
202 behaviour of <application>&dhpackage;</application>. See
203 <citerefentry>
204 <refentrytitle>foo.conf</refentrytitle>
205 <manvolnum>5</manvolnum>
206 </citerefentry> for further details.</para>
207 </listitem>
208 </varlistentry>
209 <varlistentry>
210 <term><filename>${HOME}/.foo.conf</filename></term>
211 <listitem>
212 <para>The per-user configuration file to control the
213 behaviour of <application>&dhpackage;</application>. See
214 <citerefentry>
215 <refentrytitle>foo.conf</refentrytitle>
216 <manvolnum>5</manvolnum>
217 </citerefentry> for further details.</para>
218 </listitem>
219 </varlistentry>
220 </variablelist>
221 </refsect1>
222 <refsect1 id="environment">
223 <title>ENVIRONMENT</title>
224 <variablelist>
225 <varlistentry>
226 <term><envar>FOO_CONF</envar></term>
227 <listitem>
228 <para>If used, the defined file is used as configuration
229 file (see also <xref linkend="files"/>).</para>
230 </listitem>
231 </varlistentry>
232 </variablelist>
233 </refsect1>
234 <refsect1 id="diagnostics">
235 <title>DIAGNOSTICS</title>
236 <para>The following diagnostics may be issued
237 on <filename class="devicefile">stderr</filename>:</para>
238 <variablelist>
239 <varlistentry>
240 <term><errortext>Bad configuration file. Exiting.</errortext></term>
241 <listitem>
242 <para>The configuration file seems to contain a broken configuration
243 line. Use the <option>--verbose</option> option, to get more info.
244 </para>
245 </listitem>
246 </varlistentry>
247 </variablelist>
248 <para><command>&dhpackage;</command> provides some return codes, that can
249 be used in scripts:</para>
250 <segmentedlist>
251 <segtitle>Code</segtitle>
252 <segtitle>Diagnostic</segtitle>
253 <seglistitem>
254 <seg><errorcode>0</errorcode></seg>
255 <seg>Program exited successfully.</seg>
256 </seglistitem>
257 <seglistitem>
258 <seg><errorcode>1</errorcode></seg>
259 <seg>The configuration file seems to be broken.</seg>
260 </seglistitem>
261 </segmentedlist>
262 </refsect1>
263 <refsect1 id="bugs">
264 <!-- Or use this section to tell about upstream BTS. -->
265 <title>BUGS</title>
266 <para>The program is currently limited to only work
267 with the <package>foobar</package> library.</para>
268 <para>The upstreams <acronym>BTS</acronym> can be found
269 at <ulink url="http://bugzilla.foo.tld"/>.</para>
270 </refsect1>
271 <refsect1 id="see_also">
272 <title>SEE ALSO</title>
273 <!-- In alpabetical order. -->
274 <para><citerefentry>
275 <refentrytitle>bar</refentrytitle>
276 <manvolnum>1</manvolnum>
277 </citerefentry>, <citerefentry>
278 <refentrytitle>baz</refentrytitle>
279 <manvolnum>1</manvolnum>
280 </citerefentry>, <citerefentry>
281 <refentrytitle>foo.conf</refentrytitle>
282 <manvolnum>5</manvolnum>
283 </citerefentry></para>
284 <para>The programs are documented fully by <citetitle>The Rise and
285 Fall of a Fooish Bar</citetitle> available via the <citerefentry>
286 <refentrytitle>info</refentrytitle>
287 <manvolnum>1</manvolnum>
288 </citerefentry> system.</para>
289 </refsect1>
290</refentry>
291
diff --git a/debian/menu.ex b/debian/menu.ex
deleted file mode 100644
index 820599c..0000000
--- a/debian/menu.ex
+++ /dev/null
@@ -1,2 +0,0 @@
1?package(cgit):needs="X11|text|vc|wm" section="Applications/see-menu-manual"\
2 title="cgit" command="/usr/bin/cgit"
diff --git a/debian/postinst.ex b/debian/postinst.ex
deleted file mode 100644
index c20ae2c..0000000
--- a/debian/postinst.ex
+++ /dev/null
@@ -1,39 +0,0 @@
1#!/bin/sh
2# postinst script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postinst> `configure' <most-recently-configured-version>
10# * <old-postinst> `abort-upgrade' <new version>
11# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12# <new-version>
13# * <postinst> `abort-remove'
14# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15# <failed-install-package> <version> `removing'
16# <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22 configure)
23 ;;
24
25 abort-upgrade|abort-remove|abort-deconfigure)
26 ;;
27
28 *)
29 echo "postinst called with unknown argument \`$1'" >&2
30 exit 1
31 ;;
32esac
33
34# dh_installdeb will replace this with shell code automatically
35# generated by other debhelper scripts.
36
37#DEBHELPER#
38
39exit 0
diff --git a/debian/postrm.ex b/debian/postrm.ex
deleted file mode 100644
index 2381e41..0000000
--- a/debian/postrm.ex
+++ /dev/null
@@ -1,37 +0,0 @@
1#!/bin/sh
2# postrm script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postrm> `remove'
10# * <postrm> `purge'
11# * <old-postrm> `upgrade' <new-version>
12# * <new-postrm> `failed-upgrade' <old-version>
13# * <new-postrm> `abort-install'
14# * <new-postrm> `abort-install' <old-version>
15# * <new-postrm> `abort-upgrade' <old-version>
16# * <disappearer's-postrm> `disappear' <overwriter>
17# <overwriter-version>
18# for details, see http://www.debian.org/doc/debian-policy/ or
19# the debian-policy package
20
21
22case "$1" in
23 purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
24 ;;
25
26 *)
27 echo "postrm called with unknown argument \`$1'" >&2
28 exit 1
29 ;;
30esac
31
32# dh_installdeb will replace this with shell code automatically
33# generated by other debhelper scripts.
34
35#DEBHELPER#
36
37exit 0
diff --git a/debian/preinst.ex b/debian/preinst.ex
deleted file mode 100644
index 333ac9b..0000000
--- a/debian/preinst.ex
+++ /dev/null
@@ -1,35 +0,0 @@
1#!/bin/sh
2# preinst script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <new-preinst> `install'
10# * <new-preinst> `install' <old-version>
11# * <new-preinst> `upgrade' <old-version>
12# * <old-preinst> `abort-upgrade' <new-version>
13# for details, see http://www.debian.org/doc/debian-policy/ or
14# the debian-policy package
15
16
17case "$1" in
18 install|upgrade)
19 ;;
20
21 abort-upgrade)
22 ;;
23
24 *)
25 echo "preinst called with unknown argument \`$1'" >&2
26 exit 1
27 ;;
28esac
29
30# dh_installdeb will replace this with shell code automatically
31# generated by other debhelper scripts.
32
33#DEBHELPER#
34
35exit 0
diff --git a/debian/prerm.ex b/debian/prerm.ex
deleted file mode 100644
index b5ad137..0000000
--- a/debian/prerm.ex
+++ /dev/null
@@ -1,38 +0,0 @@
1#!/bin/sh
2# prerm script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <prerm> `remove'
10# * <old-prerm> `upgrade' <new-version>
11# * <new-prerm> `failed-upgrade' <old-version>
12# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
13# * <deconfigured's-prerm> `deconfigure' `in-favour'
14# <package-being-installed> <version> `removing'
15# <conflicting-package> <version>
16# for details, see http://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18
19
20case "$1" in
21 remove|upgrade|deconfigure)
22 ;;
23
24 failed-upgrade)
25 ;;
26
27 *)
28 echo "prerm called with unknown argument \`$1'" >&2
29 exit 1
30 ;;
31esac
32
33# dh_installdeb will replace this with shell code automatically
34# generated by other debhelper scripts.
35
36#DEBHELPER#
37
38exit 0
diff --git a/debian/watch.ex b/debian/watch.ex
deleted file mode 100644
index 657e8a7..0000000
--- a/debian/watch.ex
+++ /dev/null
@@ -1,23 +0,0 @@
1# Example watch control file for uscan
2# Rename this file to "watch" and then you can run the "uscan" command
3# to check for upstream updates and more.
4# See uscan(1) for format
5
6# Compulsory line, this is a version 3 file
7version=3
8
9# Uncomment to examine a Webpage
10# <Webpage URL> <string match>
11#http://www.example.com/downloads.php cgit-(.*)\.tar\.gz
12
13# Uncomment to examine a Webserver directory
14#http://www.example.com/pub/cgit-(.*)\.tar\.gz
15
16# Uncommment to examine a FTP server
17#ftp://ftp.example.com/pub/cgit-(.*)\.tar\.gz debian uupdate
18
19# Uncomment to find new files on sourceforge, for devscripts >= 2.9
20# http://sf.net/cgit/cgit-(.*)\.tar\.gz
21
22# Uncomment to find new files on GooglePages
23# http://example.googlepages.com/foo.html cgit-(.*)\.tar\.gz