aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xfilters/syntax-highlighting.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/filters/syntax-highlighting.sh b/filters/syntax-highlighting.sh
index 0639b10..47f6267 100755
--- a/filters/syntax-highlighting.sh
+++ b/filters/syntax-highlighting.sh
@@ -39,8 +39,11 @@
39BASENAME="$1" 39BASENAME="$1"
40EXTENSION="${BASENAME##*.}" 40EXTENSION="${BASENAME##*.}"
41 41
42[ "${BASENAME}" = "${EXTENSION}" ] && EXTENSION=txt
43[ -z "${EXTENSION}" ] && EXTENSION=txt
44
42# map Makefile and Makefile.* to .mk 45# map Makefile and Makefile.* to .mk
43[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk 46[ "${BASENAME%%.*}" = "Makefile" ] && EXTENSION=mk
44 47
45# highlight versions 2 and 3 have different commandline options. Specifically, 48# highlight versions 2 and 3 have different commandline options. Specifically,
46# the -X option that is used for version 2 is replaced by the -O xhtml option 49# the -X option that is used for version 2 is replaced by the -O xhtml option