aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--cgit.c107
-rw-r--r--cgit.h5
-rw-r--r--ui-log.c115
-rw-r--r--ui-summary.c2
5 files changed, 121 insertions, 111 deletions
diff --git a/Makefile b/Makefile
index 71ddc40..64bbd5c 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,8 @@ INSTALL_CSS = /var/www/htdocs/cgit.css
5CACHE_ROOT = /var/cache/cgit 5CACHE_ROOT = /var/cache/cgit
6 6
7EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 7EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
8OBJECTS = cache.o parsing.o html.o ui-shared.o ui-repolist.o ui-summary.o 8OBJECTS = cache.o parsing.o html.o ui-shared.o ui-repolist.o ui-summary.o \
9 ui-log.o
9 10
10CFLAGS += -Wall 11CFLAGS += -Wall
11 12
diff --git a/cgit.c b/cgit.c
index 300fe46..30a9a2a 100644
--- a/cgit.c
+++ b/cgit.c
@@ -84,111 +84,6 @@ void cgit_querystring_cb(const char *name, const char *value)
84 } 84 }
85} 85}
86 86
87static int get_one_line(char *txt)
88{
89 char *t;
90
91 for(t=txt; *t != '\n' && t != '\0'; t++)
92 ;
93 *t = '\0';
94 return t-txt-1;
95}
96
97static void cgit_print_commit_shortlog(struct commit *commit)
98{
99 char *h, *t, *p;
100 char *tree = NULL, *author = NULL, *subject = NULL;
101 int len;
102 time_t sec;
103 struct tm *time;
104 char buf[32];
105
106 h = t = commit->buffer;
107
108 if (strncmp(h, "tree ", 5))
109 die("Bad commit format: %s",
110 sha1_to_hex(commit->object.sha1));
111
112 len = get_one_line(h);
113 tree = h+5;
114 h += len + 2;
115
116 while (!strncmp(h, "parent ", 7))
117 h += get_one_line(h) + 2;
118
119 if (!strncmp(h, "author ", 7)) {
120 author = h+7;
121 h += get_one_line(h) + 2;
122 t = author;
123 while(t!=h && *t!='<')
124 t++;
125 *t='\0';
126 p = t;
127 while(--t!=author && *t==' ')
128 *t='\0';
129 while(++p!=h && *p!='>')
130 ;
131 while(++p!=h && !isdigit(*p))
132 ;
133
134 t = p;
135 while(++p && isdigit(*p))
136 ;
137 *p = '\0';
138 sec = atoi(t);
139 time = gmtime(&sec);
140 }
141
142 while((len = get_one_line(h)) > 0)
143 h += len+2;
144
145 h++;
146 len = get_one_line(h);
147
148 subject = h;
149
150 html("<tr><td>");
151 strftime(buf, sizeof(buf), "%Y-%m-%d %H:%M:%S", time);
152 html_txt(buf);
153 html("</td><td>");
154 char *qry = fmt("id=%s", sha1_to_hex(commit->object.sha1));
155 char *url = cgit_pageurl(cgit_query_repo, "view", qry);
156 html_link_open(url, NULL, NULL);
157 html_txt(subject);
158 html_link_close();
159 html("</td><td>");
160 html_txt(author);
161 html("</td></tr>\n");
162}
163
164static void cgit_print_log(const char *tip, int ofs, int cnt)
165{
166 struct rev_info rev;
167 struct commit *commit;
168 const char *argv[2] = {NULL, tip};
169 int n = 0;
170
171 init_revisions(&rev, NULL);
172 rev.abbrev = DEFAULT_ABBREV;
173 rev.commit_format = CMIT_FMT_DEFAULT;
174 rev.verbose_header = 1;
175 rev.show_root_diff = 0;
176 setup_revisions(2, argv, &rev, NULL);
177 prepare_revision_walk(&rev);
178
179 html("<h2>Log</h2>");
180 html("<table class='list'>");
181 html("<tr><th>Date</th><th>Message</th><th>Author</th></tr>\n");
182 while ((commit = get_revision(&rev)) != NULL && n++ < 100) {
183 cgit_print_commit_shortlog(commit);
184 free(commit->buffer);
185 commit->buffer = NULL;
186 free_commit_list(commit->parents);
187 commit->parents = NULL;
188 }
189 html("</table>\n");
190}
191
192static void cgit_print_object(char *hex) 87static void cgit_print_object(char *hex)
193{ 88{
194 unsigned char sha1[20]; 89 unsigned char sha1[20];
@@ -238,7 +133,7 @@ static void cgit_print_repo_page(struct cacheitem *item)
238 cgit_print_docstart(title, item); 133 cgit_print_docstart(title, item);
239 cgit_print_pageheader(title); 134 cgit_print_pageheader(title);
240 if (!cgit_query_page) 135 if (!cgit_query_page)
241 cgit_print_repo_summary(); 136 cgit_print_summary();
242 else if (!strcmp(cgit_query_page, "log")) { 137 else if (!strcmp(cgit_query_page, "log")) {
243 cgit_print_log(cgit_query_head, 0, 100); 138 cgit_print_log(cgit_query_head, 0, 100);
244 } else if (!strcmp(cgit_query_page, "view")) { 139 } else if (!strcmp(cgit_query_page, "view")) {
diff --git a/cgit.h b/cgit.h
index 3a153a5..0100763 100644
--- a/cgit.h
+++ b/cgit.h
@@ -75,11 +75,10 @@ extern void cgit_print_docend();
75extern void cgit_print_pageheader(char *title); 75extern void cgit_print_pageheader(char *title);
76 76
77extern void cgit_print_repolist(struct cacheitem *item); 77extern void cgit_print_repolist(struct cacheitem *item);
78 78extern void cgit_print_summary();
79extern void cgit_print_log(const char *tip, int ofs, int cnt);
79 80
80extern void cgit_repo_config_cb(const char *name, const char *value); 81extern void cgit_repo_config_cb(const char *name, const char *value);
81 82
82extern void cgit_print_repo_summary();
83
84 83
85#endif /* CGIT_H */ 84#endif /* CGIT_H */
diff --git a/ui-log.c b/ui-log.c
new file mode 100644
index 0000000..701c392
--- /dev/null
+++ b/ui-log.c
@@ -0,0 +1,115 @@
1/* ui-log.c: functions for log output
2 *
3 * Copyright (C) 2006 Lars Hjemli
4 *
5 * Licensed under GNU General Public License v2
6 * (see COPYING for full license text)
7 */
8
9#include "cgit.h"
10
11static int get_one_line(char *txt)
12{
13 char *t;
14
15 for(t=txt; *t != '\n' && t != '\0'; t++)
16 ;
17 *t = '\0';
18 return t-txt-1;
19}
20
21static void cgit_print_commit_shortlog(struct commit *commit)
22{
23 char *h, *t, *p;
24 char *tree = NULL, *author = NULL, *subject = NULL;
25 int len;
26 time_t sec;
27 struct tm *time;
28 char buf[32];
29
30 h = t = commit->buffer;
31
32 if (strncmp(h, "tree ", 5))
33 die("Bad commit format: %s",
34 sha1_to_hex(commit->object.sha1));
35
36 len = get_one_line(h);
37 tree = h+5;
38 h += len + 2;
39
40 while (!strncmp(h, "parent ", 7))
41 h += get_one_line(h) + 2;
42
43 if (!strncmp(h, "author ", 7)) {
44 author = h+7;
45 h += get_one_line(h) + 2;
46 t = author;
47 while(t!=h && *t!='<')
48 t++;
49 *t='\0';
50 p = t;
51 while(--t!=author && *t==' ')
52 *t='\0';
53 while(++p!=h && *p!='>')
54 ;
55 while(++p!=h && !isdigit(*p))
56 ;
57
58 t = p;
59 while(++p && isdigit(*p))
60 ;
61 *p = '\0';
62 sec = atoi(t);
63 time = gmtime(&sec);
64 }
65
66 while((len = get_one_line(h)) > 0)
67 h += len+2;
68
69 h++;
70 len = get_one_line(h);
71
72 subject = h;
73
74 html("<tr><td>");
75 strftime(buf, sizeof(buf), "%Y-%m-%d %H:%M:%S", time);
76 html_txt(buf);
77 html("</td><td>");
78 char *qry = fmt("id=%s", sha1_to_hex(commit->object.sha1));
79 char *url = cgit_pageurl(cgit_query_repo, "view", qry);
80 html_link_open(url, NULL, NULL);
81 html_txt(subject);
82 html_link_close();
83 html("</td><td>");
84 html_txt(author);
85 html("</td></tr>\n");
86}
87
88void cgit_print_log(const char *tip, int ofs, int cnt)
89{
90 struct rev_info rev;
91 struct commit *commit;
92 const char *argv[2] = {NULL, tip};
93 int n = 0;
94
95 init_revisions(&rev, NULL);
96 rev.abbrev = DEFAULT_ABBREV;
97 rev.commit_format = CMIT_FMT_DEFAULT;
98 rev.verbose_header = 1;
99 rev.show_root_diff = 0;
100 setup_revisions(2, argv, &rev, NULL);
101 prepare_revision_walk(&rev);
102
103 html("<h2>Log</h2>");
104 html("<table class='list'>");
105 html("<tr><th>Date</th><th>Message</th><th>Author</th></tr>\n");
106 while ((commit = get_revision(&rev)) != NULL && n++ < 100) {
107 cgit_print_commit_shortlog(commit);
108 free(commit->buffer);
109 commit->buffer = NULL;
110 free_commit_list(commit->parents);
111 commit->parents = NULL;
112 }
113 html("</table>\n");
114}
115
diff --git a/ui-summary.c b/ui-summary.c
index 532ddbf..cc918ad 100644
--- a/ui-summary.c
+++ b/ui-summary.c
@@ -46,7 +46,7 @@ static void cgit_print_branches()
46 html("</table>"); 46 html("</table>");
47} 47}
48 48
49void cgit_print_repo_summary() 49void cgit_print_summary()
50{ 50{
51 html("<h2>"); 51 html("<h2>");
52 html_txt("Repo summary page"); 52 html_txt("Repo summary page");