diff options
-rw-r--r-- | debian/patches/0001-make-a2x-skip-xmllint.patch | 4 | ||||
-rw-r--r-- | debian/patches/0002-introduce-debian-standard-build-flags.patch | 6 | ||||
-rw-r--r-- | debian/patches/0003-pkg-config-lua5.1.patch | 24 | ||||
-rw-r--r-- | debian/patches/0003-prefer-lua5.1-to-lua5.2.patch | 24 | ||||
-rw-r--r-- | debian/patches/series | 2 |
5 files changed, 30 insertions, 30 deletions
diff --git a/debian/patches/0001-make-a2x-skip-xmllint.patch b/debian/patches/0001-make-a2x-skip-xmllint.patch index 38f48d5..9404554 100644 --- a/debian/patches/0001-make-a2x-skip-xmllint.patch +++ b/debian/patches/0001-make-a2x-skip-xmllint.patch | |||
@@ -8,10 +8,10 @@ Simply avoiding a2x failure caused by xmllint exit code 4 (Validation error). | |||
8 | 1 file changed, 3 insertions(+), 3 deletions(-) | 8 | 1 file changed, 3 insertions(+), 3 deletions(-) |
9 | 9 | ||
10 | diff --git a/Makefile b/Makefile | 10 | diff --git a/Makefile b/Makefile |
11 | index 2dc92df..1dac1ef 100644 | 11 | index 6fac5bd..63e38ab 100644 |
12 | --- a/Makefile | 12 | --- a/Makefile |
13 | +++ b/Makefile | 13 | +++ b/Makefile |
14 | @@ -126,13 +126,13 @@ doc-html: $(DOC_HTML) | 14 | @@ -127,13 +127,13 @@ doc-html: $(DOC_HTML) |
15 | doc-pdf: $(DOC_PDF) | 15 | doc-pdf: $(DOC_PDF) |
16 | 16 | ||
17 | %.5 : %.5.txt | 17 | %.5 : %.5.txt |
diff --git a/debian/patches/0002-introduce-debian-standard-build-flags.patch b/debian/patches/0002-introduce-debian-standard-build-flags.patch index e4b7c6d..d3af5e3 100644 --- a/debian/patches/0002-introduce-debian-standard-build-flags.patch +++ b/debian/patches/0002-introduce-debian-standard-build-flags.patch | |||
@@ -8,10 +8,10 @@ See https://wiki.debian.org/Hardening | |||
8 | 1 file changed, 6 insertions(+), 1 deletion(-) | 8 | 1 file changed, 6 insertions(+), 1 deletion(-) |
9 | 9 | ||
10 | diff --git a/Makefile b/Makefile | 10 | diff --git a/Makefile b/Makefile |
11 | index 1dac1ef..7e1381c 100644 | 11 | index 63e38ab..ff93147 100644 |
12 | --- a/Makefile | 12 | --- a/Makefile |
13 | +++ b/Makefile | 13 | +++ b/Makefile |
14 | @@ -37,6 +37,10 @@ DOC_PDF = $(patsubst %.txt,%.pdf,$(MAN_TXT)) | 14 | @@ -38,6 +38,10 @@ DOC_PDF = $(patsubst %.txt,%.pdf,$(MAN_TXT)) |
15 | # | 15 | # |
16 | -include cgit.conf | 16 | -include cgit.conf |
17 | 17 | ||
@@ -22,7 +22,7 @@ index 1dac1ef..7e1381c 100644 | |||
22 | export CGIT_VERSION CGIT_SCRIPT_NAME CGIT_SCRIPT_PATH CGIT_DATA_PATH CGIT_CONFIG CACHE_ROOT | 22 | export CGIT_VERSION CGIT_SCRIPT_NAME CGIT_SCRIPT_PATH CGIT_DATA_PATH CGIT_CONFIG CACHE_ROOT |
23 | 23 | ||
24 | # | 24 | # |
25 | @@ -65,7 +69,8 @@ endif | 25 | @@ -66,7 +70,8 @@ endif |
26 | all:: cgit | 26 | all:: cgit |
27 | 27 | ||
28 | cgit: | 28 | cgit: |
diff --git a/debian/patches/0003-pkg-config-lua5.1.patch b/debian/patches/0003-pkg-config-lua5.1.patch deleted file mode 100644 index 753ba78..0000000 --- a/debian/patches/0003-pkg-config-lua5.1.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | From: YAEGASHI Takeshi <yaegashi@debian.org> | ||
2 | Date: Tue, 18 Feb 2014 07:24:45 +0900 | ||
3 | Subject: pkg-config lua5.1 | ||
4 | |||
5 | pkg-config must use lua5.1.pc provided by liblua5.1-dev. | ||
6 | --- | ||
7 | cgit.mk | 4 ++-- | ||
8 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
9 | |||
10 | diff --git a/cgit.mk b/cgit.mk | ||
11 | index 056c3f9..32238d4 100644 | ||
12 | --- a/cgit.mk | ||
13 | +++ b/cgit.mk | ||
14 | @@ -31,8 +31,8 @@ ifdef NO_LUA | ||
15 | else | ||
16 | LUAJIT_CFLAGS := $(shell pkg-config --cflags luajit 2>/dev/null) | ||
17 | LUAJIT_LIBS := $(shell pkg-config --libs luajit 2>/dev/null) | ||
18 | -LUA_LIBS := $(shell pkg-config --libs lua 2>/dev/null) | ||
19 | -LUA_CFLAGS := $(shell pkg-config --cflags lua 2>/dev/null) | ||
20 | +LUA_LIBS := $(shell pkg-config --libs lua5.1 2>/dev/null) | ||
21 | +LUA_CFLAGS := $(shell pkg-config --cflags lua5.1 2>/dev/null) | ||
22 | ifeq (JIT,$(LUA_IMPLEMENTATION)) | ||
23 | ifeq ($(strip $(LUAJIT_LIBS)),) | ||
24 | $(error LuaJIT specified via LUA_IMPLEMENTATION=JIT, but library could not be found.) | ||
diff --git a/debian/patches/0003-prefer-lua5.1-to-lua5.2.patch b/debian/patches/0003-prefer-lua5.1-to-lua5.2.patch new file mode 100644 index 0000000..774739c --- /dev/null +++ b/debian/patches/0003-prefer-lua5.1-to-lua5.2.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From: YAEGASHI Takeshi <yaegashi@debian.org> | ||
2 | Date: Sun, 2 Mar 2014 17:15:20 +0900 | ||
3 | Subject: prefer lua5.1 to lua5.2 | ||
4 | |||
5 | Because: | ||
6 | * For wheezy, lua-md5 is not usable by lua 5.2 | ||
7 | * For sid, luajit is based on lua 5.1 | ||
8 | --- | ||
9 | cgit.mk | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/cgit.mk b/cgit.mk | ||
13 | index 5048b09..4fd4235 100644 | ||
14 | --- a/cgit.mk | ||
15 | +++ b/cgit.mk | ||
16 | @@ -30,7 +30,7 @@ ifdef NO_LUA | ||
17 | CGIT_CFLAGS += -DNO_LUA | ||
18 | else | ||
19 | ifeq ($(LUA_PKGCONFIG),) | ||
20 | - LUA_PKGCONFIG := $(shell for pc in luajit lua lua5.2 lua5.1; do \ | ||
21 | + LUA_PKGCONFIG := $(shell for pc in luajit lua lua5.1 lua5.2; do \ | ||
22 | pkg-config --exists $$pc 2>/dev/null && echo $$pc && break; \ | ||
23 | done) | ||
24 | LUA_MODE := autodetected | ||
diff --git a/debian/patches/series b/debian/patches/series index 11ceafc..aaafe37 100644 --- a/debian/patches/series +++ b/debian/patches/series | |||
@@ -1,4 +1,4 @@ | |||
1 | 0001-make-a2x-skip-xmllint.patch | 1 | 0001-make-a2x-skip-xmllint.patch |
2 | 0002-introduce-debian-standard-build-flags.patch | 2 | 0002-introduce-debian-standard-build-flags.patch |
3 | 0003-pkg-config-lua5.1.patch | 3 | 0003-prefer-lua5.1-to-lua5.2.patch |
4 | 0004-rewrite-email-gravater.lua-using-md5.patch | 4 | 0004-rewrite-email-gravater.lua-using-md5.patch |