aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile12
-rw-r--r--cgit.h20
-rw-r--r--git.h699
-rw-r--r--parsing.c6
-rw-r--r--ui-diff.c5
-rw-r--r--ui-summary.c2
-rw-r--r--ui-tree.c24
-rw-r--r--ui-view.c14
-rw-r--r--xdiff.h105
9 files changed, 50 insertions, 837 deletions
diff --git a/Makefile b/Makefile
index b1c3a4e..24c3963 100644
--- a/Makefile
+++ b/Makefile
@@ -3,10 +3,12 @@ CGIT_VERSION = 0.2
3prefix = /var/www/htdocs/cgit 3prefix = /var/www/htdocs/cgit
4gitsrc = ../git 4gitsrc = ../git
5 5
6SHA1_HEADER = <openssl/sha.h>
7
6CACHE_ROOT = /var/cache/cgit 8CACHE_ROOT = /var/cache/cgit
7EXTLIBS = $(gitsrc)/libgit.a $(gitsrc)/xdiff/lib.a -lz -lcrypto 9EXTLIBS = $(gitsrc)/libgit.a $(gitsrc)/xdiff/lib.a -lz -lcrypto
8OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \ 10OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \
9 ui-summary.o ui-log.o ui-view.c ui-tree.c ui-commit.c ui-diff.o \ 11 ui-summary.o ui-log.o ui-view.o ui-tree.o ui-commit.o ui-diff.o \
10 ui-snapshot.o 12 ui-snapshot.o
11 13
12CFLAGS += -Wall 14CFLAGS += -Wall
@@ -15,6 +17,8 @@ ifdef DEBUG
15 CFLAGS += -g 17 CFLAGS += -g
16endif 18endif
17 19
20CFLAGS += -I$(gitsrc) -DSHA1_HEADER='$(SHA1_HEADER)'
21
18all: cgit 22all: cgit
19 23
20install: all clean-cache 24install: all clean-cache
@@ -22,13 +26,11 @@ install: all clean-cache
22 install cgit $(prefix)/cgit.cgi 26 install cgit $(prefix)/cgit.cgi
23 install cgit.css $(prefix)/cgit.css 27 install cgit.css $(prefix)/cgit.css
24 28
25cgit: cgit.c cgit.h git.h $(OBJECTS) $(gitsrc)/libgit.a 29cgit: cgit.c cgit.h $(OBJECTS) $(gitsrc)/libgit.a
26 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit \ 30 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit \
27 $(OBJECTS) $(EXTLIBS) 31 $(OBJECTS) $(EXTLIBS)
28 32
29$(OBJECTS): cgit.h git.h 33$(OBJECTS): cgit.h
30
31ui-diff.o: xdiff.h
32 34
33$(gitsrc)/libgit.a: 35$(gitsrc)/libgit.a:
34 $(MAKE) -C $(gitsrc) 36 $(MAKE) -C $(gitsrc)
diff --git a/cgit.h b/cgit.h
index 6e95673..222c9c2 100644
--- a/cgit.h
+++ b/cgit.h
@@ -1,10 +1,22 @@
1#ifndef CGIT_H 1#ifndef CGIT_H
2#define CGIT_H 2#define CGIT_H
3 3
4#include "git.h" 4
5#include <openssl/sha.h> 5#include <git-compat-util.h>
6#include <ctype.h> 6#include <cache.h>
7#include <sched.h> 7#include <grep.h>
8#include <object.h>
9#include <tree.h>
10#include <commit.h>
11#include <tag.h>
12#include <diff.h>
13#include <diffcore.h>
14#include <refs.h>
15#include <revision.h>
16#include <log-tree.h>
17#include <archive.h>
18#include <xdiff/xdiff.h>
19
8 20
9typedef void (*configfn)(const char *name, const char *value); 21typedef void (*configfn)(const char *name, const char *value);
10 22
diff --git a/git.h b/git.h
deleted file mode 100644
index a1d1c4b..0000000
--- a/git.h
+++ /dev/null
@@ -1,699 +0,0 @@
1#ifndef GIT_H
2#define GIT_H
3
4
5/*
6 * from git:git-compat-util.h
7 */
8
9
10#ifndef FLEX_ARRAY
11#if defined(__GNUC__) && (__GNUC__ < 3)
12#define FLEX_ARRAY 0
13#else
14#define FLEX_ARRAY /* empty */
15#endif
16#endif
17
18
19#include <unistd.h>
20#include <stdio.h>
21#include <sys/stat.h>
22#include <fcntl.h>
23#include <stddef.h>
24#include <stdlib.h>
25#include <stdarg.h>
26#include <string.h>
27#include <errno.h>
28#include <limits.h>
29#include <sys/param.h>
30#include <netinet/in.h>
31#include <sys/types.h>
32#include <dirent.h>
33#include <time.h>
34#include <regex.h>
35
36/* On most systems <limits.h> would have given us this, but
37 * not on some systems (e.g. GNU/Hurd).
38 */
39#ifndef PATH_MAX
40#define PATH_MAX 4096
41#endif
42
43#ifdef __GNUC__
44#define NORETURN __attribute__((__noreturn__))
45#else
46#define NORETURN
47#ifndef __attribute__
48#define __attribute__(x)
49#endif
50#endif
51
52
53extern void die(const char *err, ...) NORETURN __attribute__((format (printf, 1, 2)));
54
55
56static inline char* xstrdup(const char *str)
57{
58 char *ret = strdup(str);
59 if (!ret)
60 die("Out of memory, strdup failed");
61 return ret;
62}
63
64static inline void *xmalloc(size_t size)
65{
66 void *ret = malloc(size);
67 if (!ret && !size)
68 ret = malloc(1);
69 if (!ret)
70 die("Out of memory, malloc failed");
71#ifdef XMALLOC_POISON
72 memset(ret, 0xA5, size);
73#endif
74 return ret;
75}
76
77static inline void *xrealloc(void *ptr, size_t size)
78{
79 void *ret = realloc(ptr, size);
80 if (!ret && !size)
81 ret = realloc(ptr, 1);
82 if (!ret)
83 die("Out of memory, realloc failed");
84 return ret;
85}
86
87static inline void *xcalloc(size_t nmemb, size_t size)
88{
89 void *ret = calloc(nmemb, size);
90 if (!ret && (!nmemb || !size))
91 ret = calloc(1, 1);
92 if (!ret)
93 die("Out of memory, calloc failed");
94 return ret;
95}
96
97static inline ssize_t xread(int fd, void *buf, size_t len)
98{
99 ssize_t nr;
100 while (1) {
101 nr = read(fd, buf, len);
102 if ((nr < 0) && (errno == EAGAIN || errno == EINTR))
103 continue;
104 return nr;
105 }
106}
107
108static inline ssize_t xwrite(int fd, const void *buf, size_t len)
109{
110 ssize_t nr;
111 while (1) {
112 nr = write(fd, buf, len);
113 if ((nr < 0) && (errno == EAGAIN || errno == EINTR))
114 continue;
115 return nr;
116 }
117}
118
119
120
121
122/*
123 * from git:cache.h
124 */
125
126
127enum object_type {
128 OBJ_NONE = 0,
129 OBJ_COMMIT = 1,
130 OBJ_TREE = 2,
131 OBJ_BLOB = 3,
132 OBJ_TAG = 4,
133 /* 5 for future expansion */
134 OBJ_OFS_DELTA = 6,
135 OBJ_REF_DELTA = 7,
136 OBJ_BAD,
137};
138
139
140/* Convert to/from hex/sha1 representation */
141#define MINIMUM_ABBREV 4
142#define DEFAULT_ABBREV 7
143
144extern const unsigned char null_sha1[20];
145
146extern int sha1_object_info(const unsigned char *, char *, unsigned long *);
147
148extern void * read_sha1_file(const unsigned char *sha1, char *type, unsigned long *size);
149
150extern int get_sha1(const char *str, unsigned char *sha1);
151extern int get_sha1_hex(const char *hex, unsigned char *sha1);
152extern char *sha1_to_hex(const unsigned char *sha1); /* static buffer result! */
153
154static inline int is_null_sha1(const unsigned char *sha1)
155{
156 return !memcmp(sha1, null_sha1, 20);
157}
158static inline int hashcmp(const unsigned char *sha1, const unsigned char *sha2)
159{
160 return memcmp(sha1, sha2, 20);
161}
162static inline void hashcpy(unsigned char *sha_dst, const unsigned char *sha_src)
163{
164 memcpy(sha_dst, sha_src, 20);
165}
166static inline void hashclr(unsigned char *hash)
167{
168 memset(hash, 0, 20);
169}
170
171
172/*
173 * from git:grep.h
174 */
175
176enum grep_pat_token {
177 GREP_PATTERN,
178 GREP_PATTERN_HEAD,
179 GREP_PATTERN_BODY,
180 GREP_AND,
181 GREP_OPEN_PAREN,
182 GREP_CLOSE_PAREN,
183 GREP_NOT,
184 GREP_OR,
185};
186
187enum grep_context {
188 GREP_CONTEXT_HEAD,
189 GREP_CONTEXT_BODY,
190};
191
192struct grep_pat {
193 struct grep_pat *next;
194 const char *origin;
195 int no;
196 enum grep_pat_token token;
197 const char *pattern;
198 regex_t regexp;
199};
200
201enum grep_expr_node {
202 GREP_NODE_ATOM,
203 GREP_NODE_NOT,
204 GREP_NODE_AND,
205 GREP_NODE_OR,
206};
207
208struct grep_opt {
209 struct grep_pat *pattern_list;
210 struct grep_pat **pattern_tail;
211 struct grep_expr *pattern_expression;
212 int prefix_length;
213 regex_t regexp;
214 unsigned linenum:1;
215 unsigned invert:1;
216 unsigned status_only:1;
217 unsigned name_only:1;
218 unsigned unmatch_name_only:1;
219 unsigned count:1;
220 unsigned word_regexp:1;
221 unsigned fixed:1;
222 unsigned all_match:1;
223#define GREP_BINARY_DEFAULT 0
224#define GREP_BINARY_NOMATCH 1
225#define GREP_BINARY_TEXT 2
226 unsigned binary:2;
227 unsigned extended:1;
228 unsigned relative:1;
229 unsigned pathname:1;
230 int regflags;
231 unsigned pre_context;
232 unsigned post_context;
233};
234
235
236extern void compile_grep_patterns(struct grep_opt *opt);
237extern void free_grep_patterns(struct grep_opt *opt);
238
239
240/*
241 * from git:object.h
242 */
243
244extern const char *type_names[9];
245
246struct object_list {
247 struct object *item;
248 struct object_list *next;
249};
250
251struct object_refs {
252 unsigned count;
253 struct object *base;
254 struct object *ref[FLEX_ARRAY]; /* more */
255};
256
257struct object_array {
258 unsigned int nr;
259 unsigned int alloc;
260 struct object_array_entry {
261 struct object *item;
262 const char *name;
263 } *objects;
264};
265
266#define TYPE_BITS 3
267#define FLAG_BITS 27
268
269/*
270 * The object type is stored in 3 bits.
271 */
272struct object {
273 unsigned parsed : 1;
274 unsigned used : 1;
275 unsigned type : TYPE_BITS;
276 unsigned flags : FLAG_BITS;
277 unsigned char sha1[20];
278};
279
280
281/** Returns the object, having parsed it to find out what it is. **/
282struct object *parse_object(const unsigned char *sha1);
283
284
285/*
286 * from git:tree.h
287 */
288
289struct tree {
290 struct object object;
291 void *buffer;
292 unsigned long size;
293};
294
295
296struct tree *lookup_tree(const unsigned char *sha1);
297int parse_tree_buffer(struct tree *item, void *buffer, unsigned long size);
298int parse_tree(struct tree *tree);
299struct tree *parse_tree_indirect(const unsigned char *sha1);
300
301typedef int (*read_tree_fn_t)(const unsigned char *, const char *, int, const char *, unsigned int, int);
302
303extern int read_tree_recursive(struct tree *tree,
304 const char *base, int baselen,
305 int stage, const char **match,
306 read_tree_fn_t fn);
307
308extern int read_tree(struct tree *tree, int stage, const char **paths);
309
310
311/* from git:commit.h */
312
313struct commit_list {
314 struct commit *item;
315 struct commit_list *next;
316};
317
318struct commit {
319 struct object object;
320 void *util;
321 unsigned long date;
322 struct commit_list *parents;
323 struct tree *tree;
324 char *buffer;
325};
326
327
328struct commit *lookup_commit(const unsigned char *sha1);
329struct commit *lookup_commit_reference(const unsigned char *sha1);
330struct commit *lookup_commit_reference_gently(const unsigned char *sha1,
331 int quiet);
332
333int parse_commit_buffer(struct commit *item, void *buffer, unsigned long size);
334int parse_commit(struct commit *item);
335
336struct commit_list * commit_list_insert(struct commit *item, struct commit_list **list_p);
337struct commit_list * insert_by_date(struct commit *item, struct commit_list **list);
338
339void free_commit_list(struct commit_list *list);
340
341void sort_by_date(struct commit_list **list);
342
343/* Commit formats */
344enum cmit_fmt {
345 CMIT_FMT_RAW,
346 CMIT_FMT_MEDIUM,
347 CMIT_FMT_DEFAULT = CMIT_FMT_MEDIUM,
348 CMIT_FMT_SHORT,
349 CMIT_FMT_FULL,
350 CMIT_FMT_FULLER,
351 CMIT_FMT_ONELINE,
352 CMIT_FMT_EMAIL,
353
354 CMIT_FMT_UNSPECIFIED,
355};
356
357extern unsigned long pretty_print_commit(enum cmit_fmt fmt, const struct commit *, unsigned long len, char *buf, unsigned long space, int abbrev, const char *subject, const char *after_subject, int relative_date);
358
359
360typedef void (*topo_sort_set_fn_t)(struct commit*, void *data);
361typedef void* (*topo_sort_get_fn_t)(struct commit*);
362
363
364
365/*
366 * from git:tag.h
367 */
368
369extern const char *tag_type;
370
371struct tag {
372 struct object object;
373 struct object *tagged;
374 char *tag;
375 char *signature; /* not actually implemented */
376};
377
378extern struct tag *lookup_tag(const unsigned char *sha1);
379extern int parse_tag_buffer(struct tag *item, void *data, unsigned long size);
380extern int parse_tag(struct tag *item);
381extern struct object *deref_tag(struct object *, const char *, int);
382
383
384/*
385 * from git:diffcore.h
386 */
387
388struct diff_filespec {
389 unsigned char sha1[20];
390 char *path;
391 void *data;
392 void *cnt_data;
393 unsigned long size;
394 int xfrm_flags; /* for use by the xfrm */
395 unsigned short mode; /* file mode */
396 unsigned sha1_valid : 1; /* if true, use sha1 and trust mode;
397 * if false, use the name and read from
398 * the filesystem.
399 */
400#define DIFF_FILE_VALID(spec) (((spec)->mode) != 0)
401 unsigned should_free : 1; /* data should be free()'ed */
402 unsigned should_munmap : 1; /* data should be munmap()'ed */
403};
404
405struct diff_filepair {
406 struct diff_filespec *one;
407 struct diff_filespec *two;
408 unsigned short int score;
409 char status; /* M C R N D U (see Documentation/diff-format.txt) */
410 unsigned source_stays : 1; /* all of R/C are copies */
411 unsigned broken_pair : 1;
412 unsigned renamed_pair : 1;
413};
414
415#define DIFF_PAIR_UNMERGED(p) \
416 (!DIFF_FILE_VALID((p)->one) && !DIFF_FILE_VALID((p)->two))
417
418#define DIFF_PAIR_RENAME(p) ((p)->renamed_pair)
419
420#define DIFF_PAIR_BROKEN(p) \
421