aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorGravatar John Keeping <john@keeping.me.uk>2013-03-20 05:00:29 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-03-21 05:06:50 (JST)
commite1e0e038fd0fee3fe10524d7466deab03e78deb5 (patch)
tree7b73e96d84e4e94a10d31552346acf78be83ab04 /tests
parent0255821e22678d4c58c809efe17bf2798835d5b9 (diff)
downloadcgit-e1e0e038fd0fee3fe10524d7466deab03e78deb5.zip
cgit-e1e0e038fd0fee3fe10524d7466deab03e78deb5.tar.gz
tests: check that Git version are in sync
This ensures that the Git version pointed at by the submodule is the same as the one that will be fetched using "make get-git". Suggested-by: Ferry Huberts <ferry.huberts@pelagic.nl> Signed-off-by: John Keeping <john@keeping.me.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/t0001-validate-git-versions.sh36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/t0001-validate-git-versions.sh b/tests/t0001-validate-git-versions.sh
new file mode 100755
index 0000000..3378358
--- /dev/null
+++ b/tests/t0001-validate-git-versions.sh
@@ -0,0 +1,36 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests 'Check Git version is correct'
6
7run_test 'extract Git version from Makefile' '
8 sed -n -e "/^GIT_VER[ ]*=/ {
9 s/^GIT_VER[ ]*=[ ]*//
10 p
11 }" ../Makefile >trash/makefile_version
12'
13
14run_test 'test Git version matches Makefile' '
15 ( cat ../git/GIT-VERSION-FILE || echo "No GIT-VERSION-FILE" ) |
16 sed -e "s/GIT_VERSION[ ]*=[ ]*//" >trash/git_version &&
17 diff -u trash/git_version trash/makefile_version
18'
19
20run_test 'test submodule version matches Makefile' '
21 if ! test -e ../git/.git
22 then
23 echo "git/ is not a Git repository" >&2
24 else
25 (
26 cd .. &&
27 sm_sha1=$(git ls-files --stage -- git |
28 sed -e "s/^[0-9]* \\([0-9a-f]*\\) [0-9] .*$/\\1/") &&
29 cd git &&
30 git describe --match "v[0-9]*" $sm_sha1
31 ) | sed -e "s/^v//" >trash/sm_version &&
32 diff -u trash/sm_version trash/makefile_version
33 fi
34'
35
36tests_done