aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorGravatar John Keeping <john@keeping.me.uk>2013-04-27 18:48:56 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-04-28 00:21:22 (JST)
commit8d07ad3388429b6c1361074cbac5dec6afee79d7 (patch)
tree46d1c4c7b8fe975aa5afe54151a652f1093e23d3 /tests
parent83115075abe970306a79484dbaa9adfa97fef2d0 (diff)
downloadcgit-8d07ad3388429b6c1361074cbac5dec6afee79d7.zip
cgit-8d07ad3388429b6c1361074cbac5dec6afee79d7.tar.gz
t0001: validate Git -rcN version numbers correctly
When creating the GIT-VERSION-FILE that we use to test that the version of Git in git/ is the same as in the CGit Makefile, Git applies the transform "s/-/./g" to the version string. This doesn't affect released versions but does change RC version numbers such as 1.8.3-rc0. While CGit should only refer to a released Git version in general, it is useful to developers who want to test upcoming Git releases if the tests do work with RCs, so change t0001 to apply the same transform to our Makefile version before comparing it to the contents of GIT-VERSION-FILE. Signed-off-by: John Keeping <john@keeping.me.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/t0001-validate-git-versions.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/t0001-validate-git-versions.sh b/tests/t0001-validate-git-versions.sh
index 416ac30..a65b35e 100755
--- a/tests/t0001-validate-git-versions.sh
+++ b/tests/t0001-validate-git-versions.sh
@@ -11,10 +11,15 @@ test_expect_success 'extract Git version from Makefile' '
11 }" ../../Makefile >makefile_version 11 }" ../../Makefile >makefile_version
12' 12'
13 13
14# Note that Git's GIT-VERSION-GEN script applies "s/-/./g" to the version
15# string to produce the internal version in the GIT-VERSION-FILE, so we
16# must apply the same transformation to the version in the Makefile before
17# comparing them.
14test_expect_success 'test Git version matches Makefile' ' 18test_expect_success 'test Git version matches Makefile' '
15 ( cat ../../git/GIT-VERSION-FILE || echo "No GIT-VERSION-FILE" ) | 19 ( cat ../../git/GIT-VERSION-FILE || echo "No GIT-VERSION-FILE" ) |
16 sed -e "s/GIT_VERSION[ ]*=[ ]*//" -e "s/\\.dirty$//" >git_version && 20 sed -e "s/GIT_VERSION[ ]*=[ ]*//" -e "s/\\.dirty$//" >git_version &&
17 test_cmp git_version makefile_version 21 sed -e "s/-/./g" makefile_version >makefile_git_version &&
22 test_cmp git_version makefile_git_version
18' 23'
19 24
20test_expect_success 'test submodule version matches Makefile' ' 25test_expect_success 'test submodule version matches Makefile' '