aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2007-02-05 07:57:34 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2007-02-05 08:12:04 (JST)
commitc52e84135e6272d008f69a9ac00265875ff4e60e (patch)
tree74cb0a76ea7b69f152766cb5510c6f60a7caf2a1 /Makefile
parent74b0db95560e4c11439d7e0e8016d1e8cd48cdda (diff)
downloadcgit-c52e84135e6272d008f69a9ac00265875ff4e60e.zip
cgit-c52e84135e6272d008f69a9ac00265875ff4e60e.tar.gz
Add support for prefix and gitsrc arguments to 'make'
This should improve the installation a little, especially since the new options are mentioned in the README. Also, add a make-rule to build the git binaries if necessary + a dependency between cgit and libgit.a. Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 72a1cff..e863205 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
1CGIT_VERSION = 0.1 1CGIT_VERSION = 0.1
2 2
3INSTALL_DIR = /var/www/htdocs/cgit 3prefix = /var/www/htdocs/cgit
4CACHE_ROOT = /var/cache/cgit 4gitsrc = ../git
5 5
6EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 6CACHE_ROOT = /var/cache/cgit
7EXTLIBS = $(gitsrc)/libgit.a $(gitsrc)/xdiff/lib.a -lz -lcrypto
7OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \ 8OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \
8 ui-summary.o ui-log.o ui-view.c ui-tree.c ui-commit.c ui-diff.o 9 ui-summary.o ui-log.o ui-view.c ui-tree.c ui-commit.c ui-diff.o
9 10
@@ -16,10 +17,11 @@ endif
16all: cgit 17all: cgit
17 18
18install: all clean-cache 19install: all clean-cache
19 install cgit $(INSTALL_DIR)/cgit.cgi 20 mkdir -p $(prefix)
20 install cgit.css $(INSTALL_DIR)/cgit.css 21 install cgit $(prefix)/cgit.cgi
22 install cgit.css $(prefix)/cgit.css
21 23
22cgit: cgit.c cgit.h git.h $(OBJECTS) 24cgit: cgit.c cgit.h git.h $(OBJECTS) $(gitsrc)/libgit.a
23 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit \ 25 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit \
24 $(OBJECTS) $(EXTLIBS) 26 $(OBJECTS) $(EXTLIBS)
25 27
@@ -27,6 +29,10 @@ $(OBJECTS): cgit.h git.h
27 29
28ui-diff.o: xdiff.h 30ui-diff.o: xdiff.h
29 31
32$(gitsrc)/libgit.a:
33 $(MAKE) -C $(gitsrc)
34
35
30.PHONY: clean 36.PHONY: clean
31clean: 37clean:
32 rm -f cgit *.o 38 rm -f cgit *.o