aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 19:23:05 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 19:23:05 (JST)
commita581ed8d6c15b0734b082fbadf0a907c2b170423 (patch)
tree4d0e9084aaa15b7c516a0fe36dfe5b23898f23ba /Makefile
parentf5069d88dff7a7ed2f4665904b03e906cca75a7c (diff)
downloadcgit-a581ed8d6c15b0734b082fbadf0a907c2b170423.zip
cgit-a581ed8d6c15b0734b082fbadf0a907c2b170423.tar.gz
Let 'make install' clear all cachefiles
Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 21e2eb3..c71e39c 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@ CGIT_VERSION = 0.1-pre
2 2
3INSTALL_BIN = /var/www/htdocs/cgit.cgi 3INSTALL_BIN = /var/www/htdocs/cgit.cgi
4INSTALL_CSS = /var/www/htdocs/cgit.css 4INSTALL_CSS = /var/www/htdocs/cgit.css
5CACHE_ROOT = /var/cache/cgit
5 6
6EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 7EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
7OBJECTS = config.o html.o cache.o 8OBJECTS = config.o html.o cache.o
@@ -13,6 +14,7 @@ all: cgit
13install: all 14install: all
14 install cgit $(INSTALL_BIN) 15 install cgit $(INSTALL_BIN)
15 install cgit.css $(INSTALL_CSS) 16 install cgit.css $(INSTALL_CSS)
17 rm -rf $(CACHE_ROOT)/*
16 18
17cgit: cgit.c cgit.h git.h $(OBJECTS) 19cgit: cgit.c cgit.h git.h $(OBJECTS)
18 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit $(OBJECTS) $(EXTLIBS) 20 $(CC) $(CFLAGS) -DCGIT_VERSION='"$(CGIT_VERSION)"' cgit.c -o cgit $(OBJECTS) $(EXTLIBS)