aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2007-09-04 05:42:54 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2007-09-04 05:49:19 (JST)
commit95eaf2735efffae533ae3b4133bc01b6eb303d5a (patch)
tree0e3a3b53fc643c2b7809eadd85bbd90f9257040a /Makefile
parente8920b52629911f92dbbecdb1d7675760e7a781e (diff)
downloadcgit-95eaf2735efffae533ae3b4133bc01b6eb303d5a.zip
cgit-95eaf2735efffae533ae3b4133bc01b6eb303d5a.tar.gz
Makefile: add target "get-git"
The new target downloads a suitable git.git tarball from kernel.org and unpacks it in the git directory. Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 12fd652..fcbe3e4 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,8 @@ CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
4CGIT_CONFIG = /etc/cgitrc 4CGIT_CONFIG = /etc/cgitrc
5CACHE_ROOT = /var/cache/cgit 5CACHE_ROOT = /var/cache/cgit
6SHA1_HEADER = <openssl/sha.h> 6SHA1_HEADER = <openssl/sha.h>
7GIT_VER = 1.5.2
8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
7 9
8# 10#
9# Let the user override the above settings. 11# Let the user override the above settings.
@@ -17,7 +19,7 @@ OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \
17 ui-snapshot.o ui-blob.o ui-tag.o 19 ui-snapshot.o ui-blob.o ui-tag.o
18 20
19 21
20.PHONY: all git install clean distclean force-version 22.PHONY: all git install clean distclean force-version get-git
21 23
22all: cgit git 24all: cgit git
23 25
@@ -64,3 +66,6 @@ clean:
64distclean: clean 66distclean: clean
65 git clean -d -x 67 git clean -d -x
66 cd git && git clean -d -x 68 cd git && git clean -d -x
69
70get-git:
71 curl $(GIT_URL) | tar -xj && rm -rf git && mv git-$(GIT_VER) git