aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Jamie Couture <jamie.couture@gmail.com>2012-10-09 02:12:17 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2012-10-09 06:40:23 (JST)
commit6419c9b57c33a8a26d2775f01629f899afb61026 (patch)
tree2d2f0e4b2e4956a88f7c993313a8421efc3cb5f2 /Makefile
parent4675b91211fe3119a0def539521ac759b3fb57d0 (diff)
downloadcgit-6419c9b57c33a8a26d2775f01629f899afb61026.zip
cgit-6419c9b57c33a8a26d2775f01629f899afb61026.tar.gz
Makefile: add tag target to generate ctags
Signed-off-by: Jamie Couture <jamie.couture@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index eac24ad..1e34129 100644
--- a/Makefile
+++ b/Makefile
@@ -73,6 +73,7 @@ ifndef V
73 QUIET_SUBDIR0 = +@subdir= 73 QUIET_SUBDIR0 = +@subdir=
74 QUIET_SUBDIR1 = ;$(NO_SUBDIR) echo ' ' SUBDIR $$subdir; \ 74 QUIET_SUBDIR1 = ;$(NO_SUBDIR) echo ' ' SUBDIR $$subdir; \
75 $(MAKE) $(PRINT_DIR) -C $$subdir 75 $(MAKE) $(PRINT_DIR) -C $$subdir
76 QUIET_TAGS = @echo ' ' TAGS $@;
76endif 77endif
77 78
78# 79#
@@ -124,7 +125,7 @@ endif
124 125
125.PHONY: all libgit test install uninstall clean force-version get-git \ 126.PHONY: all libgit test install uninstall clean force-version get-git \
126 doc clean-doc install-doc install-man install-html install-pdf \ 127 doc clean-doc install-doc install-man install-html install-pdf \
127 uninstall-doc uninstall-man uninstall-html uninstall-pdf 128 uninstall-doc uninstall-man uninstall-html uninstall-pdf tags
128 129
129all: cgit 130all: cgit
130 131
@@ -242,3 +243,6 @@ clean-doc:
242 243
243get-git: 244get-git:
244 curl $(GIT_URL) | tar -xjf - && rm -rf git && mv git-$(GIT_VER) git 245 curl $(GIT_URL) | tar -xjf - && rm -rf git && mv git-$(GIT_VER) git
246
247tags:
248 $(QUIET_TAGS)find . -name '*.[ch]' | xargs ctags