aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Ferry Huberts <ferry.huberts@pelagic.nl>2012-11-04 08:49:45 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2012-11-05 02:02:55 (JST)
commit633a66c8226286d4559e72f0dce23586d617faff (patch)
treeb15d738d833dde2ca35f2d20b9f3894d6e33568b /Makefile
parent2b675d20bcc1bf7f520f2d614475c7d3857191ef (diff)
downloadcgit-633a66c8226286d4559e72f0dce23586d617faff.zip
cgit-633a66c8226286d4559e72f0dce23586d617faff.tar.gz
Makefile: get snapshots from github
Github will have more bandwidth than Lars' server.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 93c5003..1873809 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ pdfdir = $(docdir)
13mandir = $(prefix)/share/man 13mandir = $(prefix)/share/man
14SHA1_HEADER = <openssl/sha.h> 14SHA1_HEADER = <openssl/sha.h>
15GIT_VER = 1.7.4 15GIT_VER = 1.7.4
16GIT_URL = http://hjemli.net/git/git/snapshot/git-$(GIT_VER).tar.bz2 16GIT_URL = https://github.com/git/git/archive/v$(GIT_VER).tar.gz
17INSTALL = install 17INSTALL = install
18MAN5_TXT = $(wildcard *.5.txt) 18MAN5_TXT = $(wildcard *.5.txt)
19MAN_TXT = $(MAN5_TXT) 19MAN_TXT = $(MAN5_TXT)
@@ -249,7 +249,7 @@ clean-doc:
249 rm -f cgitrc.5 cgitrc.5.html cgitrc.5.pdf cgitrc.5.xml cgitrc.5.fo 249 rm -f cgitrc.5 cgitrc.5.html cgitrc.5.pdf cgitrc.5.xml cgitrc.5.fo
250 250
251get-git: 251get-git:
252 curl $(GIT_URL) | tar -xjf - && rm -rf git && mv git-$(GIT_VER) git 252 curl -L $(GIT_URL) | tar -xzf - && rm -rf git && mv git-$(GIT_VER) git
253 253
254tags: 254tags:
255 $(QUIET_TAGS)find . -name '*.[ch]' | xargs ctags 255 $(QUIET_TAGS)find . -name '*.[ch]' | xargs ctags