aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2010-11-08 00:13:49 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2010-11-08 00:13:49 (JST)
commit5807fb79faa49e9a8f2da616e9cc821e0198fcb7 (patch)
treeab36f62bc5fea3856603f6653f5c8da31233abea /Makefile
parentd41b2ddcb331caa74c1a90a0253f234142848552 (diff)
downloadcgit-5807fb79faa49e9a8f2da616e9cc821e0198fcb7.zip
cgit-5807fb79faa49e9a8f2da616e9cc821e0198fcb7.tar.gz
Makefile: add -MP option
Work around errors `make` gives when header files are removed without the Makefile being updated. Signed-off-by: Lynn Lin <Lynn.Lin@emc.com> Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dda743d..15c7c20 100644
--- a/Makefile
+++ b/Makefile
@@ -67,7 +67,7 @@ endif
67# Define a pattern rule for automatic dependency building 67# Define a pattern rule for automatic dependency building
68# 68#
69%.d: %.c 69%.d: %.c
70 $(QUIET_MM)$(CC) $(CFLAGS) -MM $< | sed -e 's/\($*\)\.o:/\1.o $@:/g' >$@ 70 $(QUIET_MM)$(CC) $(CFLAGS) -MM -MP $< | sed -e 's/\($*\)\.o:/\1.o $@:/g' >$@
71 71
72# 72#
73# Define a pattern rule for silent object building 73# Define a pattern rule for silent object building