aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 06:31:36 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2006-12-11 06:31:36 (JST)
commit25105d7ecaba474d4b7c364ebb586aac3dfc5abb (patch)
tree8beb08db1399b8efb8c7fbcd936044ae7fc232e6 /Makefile
parent856c026e221d8ed82c5b75bc8da4bd65e89ea953 (diff)
downloadcgit-25105d7ecaba474d4b7c364ebb586aac3dfc5abb.zip
cgit-25105d7ecaba474d4b7c364ebb586aac3dfc5abb.tar.gz
Add caching infrastructure
This enables internal caching of page output. Page requests are split into four groups: 1) repo listing (front page) 2) repo summary 3) repo pages w/symbolic references in query string 4) repo pages w/constant sha1's in query string Each group has a TTL specified in minutes. When a page is requested, a cached filename is stat(2)'ed and st_mtime is compared to time(2). If TTL has expired (or the file didn't exist), the cached file is regenerated. When generating a cached file, locking is used to avoid parallell processing of the request. If multiple processes tries to aquire the same lock, the ones who fail to get the lock serves the (expired) cached file. If the cached file don't exist, the process instead calls sched_yield(2) before restarting the request processing. Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4e72b07..243f590 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,9 @@ INSTALL_BIN = /var/www/htdocs/cgit.cgi
3INSTALL_CSS = /var/www/htdocs/cgit.css 3INSTALL_CSS = /var/www/htdocs/cgit.css
4 4
5EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 5EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
6OBJECTS = cgit.o config.o html.o 6OBJECTS = cgit.o config.o html.o cache.o
7
8CFLAGS += -Wall
7 9
8all: cgit 10all: cgit
9 11
@@ -15,6 +17,6 @@ clean:
15 rm -f cgit *.o 17 rm -f cgit *.o
16 18
17cgit: $(OBJECTS) 19cgit: $(OBJECTS)
18 $(CC) -o cgit $(OBJECTS) $(EXTLIBS) 20 $(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
19 21
20$(OBJECTS): cgit.h git.h 22$(OBJECTS): cgit.h git.h