aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-05-28 21:17:00 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-08-13 04:14:10 (JST)
commit23debef62104c70600be2b745ec3957538eeac6e (patch)
tree3b68eab7624907836b0e614328a529e686224830 /Makefile
parent830eb6f6ff9e6dded2bfae99d7cb46f049790470 (diff)
downloadcgit-23debef62104c70600be2b745ec3957538eeac6e.zip
cgit-23debef62104c70600be2b745ec3957538eeac6e.tar.gz
robots.txt: disallow access to snapshots
My dmesg is filled with the oom killer bringing down processes while the Bingbot downloads every snapshot for every commit of the Linux kernel in tar.xz format. Sure, I should be running with memory limits, and now I'm using cgroups, but a more general solution is to prevent crawlers from wasting resources like that in the first place. Suggested-by: Natanael Copa <ncopa@alpinelinux.org> Suggested-by: Julius Plenz <plenz@cis.fu-berlin.de> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 00b3269..f11b60f 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,7 @@ install: all
78 $(INSTALL) -m 0644 cgit.css $(DESTDIR)$(CGIT_DATA_PATH)/cgit.css 78 $(INSTALL) -m 0644 cgit.css $(DESTDIR)$(CGIT_DATA_PATH)/cgit.css
79 $(INSTALL) -m 0644 cgit.png $(DESTDIR)$(CGIT_DATA_PATH)/cgit.png 79 $(INSTALL) -m 0644 cgit.png $(DESTDIR)$(CGIT_DATA_PATH)/cgit.png
80 $(INSTALL) -m 0644 favicon.ico $(DESTDIR)$(CGIT_DATA_PATH)/favicon.ico 80 $(INSTALL) -m 0644 favicon.ico $(DESTDIR)$(CGIT_DATA_PATH)/favicon.ico
81 $(INSTALL) -m 0644 robots.txt $(DESTDIR)$(CGIT_DATA_PATH)/robots.txt
81 $(INSTALL) -m 0755 -d $(DESTDIR)$(filterdir) 82 $(INSTALL) -m 0755 -d $(DESTDIR)$(filterdir)
82 $(COPYTREE) filters/* $(DESTDIR)$(filterdir) 83 $(COPYTREE) filters/* $(DESTDIR)$(filterdir)
83 84