aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2006-12-09 23:18:17 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2006-12-09 23:18:17 (JST)
commit0d169ada2ba81210ab1191a5f2212662e90db77e (patch)
tree402b54583db269323ebb28e5fbf2075c4c1b3d85 /Makefile
downloadcgit-0d169ada2ba81210ab1191a5f2212662e90db77e.zip
cgit-0d169ada2ba81210ab1191a5f2212662e90db77e.tar.gz
Import cgit prototype from git tree
This enables basic cgit functionality, using libgit.a and xdiff/lib.a from git + a custom "git.h" + openssl for sha1 routines. Signed-off-by: Lars Hjemli <hjemli@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1470c0a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
1
2INSTALL_BIN = /var/www/htdocs/cgit.cgi
3INSTALL_CSS = /var/www/htdocs/cgit.css
4
5EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
6OBJECTS = cgit.o config.o html.o
7
8all: cgit
9
10install: all
11 install cgit $(INSTALL_BIN)
12 install cgit.css $(INSTALL_CSS)
13
14clean:
15 rm -f cgit *.o
16
17cgit: $(OBJECTS)
18 $(CC) -o cgit $(OBJECTS) $(EXTLIBS)
19
20cgit.o: cgit.h git.h config.o html.o
21
22config.o: cgit.h git.h html.c
23
24html.o: cgit.h git.h html.c