aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2008-07-23 02:30:06 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2008-07-23 02:42:06 (JST)
commitbb7485e8d7932ba04a94714bfe6a86a1e323435c (patch)
tree1add8c867ba8ecd54314e131859d985de5f790fe
parentf49ea2c9968a8b30c0c268ca52aa066960fd98f7 (diff)
downloadcgit-bb7485e8d7932ba04a94714bfe6a86a1e323435c.zip
cgit-bb7485e8d7932ba04a94714bfe6a86a1e323435c.tar.gz
Makefile: fix git dependency rules
The objectfiles depends unconditionally on some specific git binaries while those git binaries depends on the phony `git` target and this patch seems to get these dependencies spelled out correctly. Signed-off-by: Lars Hjemli <hjemli@gmail.com>
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 3719e96..e807d1e 100644
--- a/Makefile
+++ b/Makefile
@@ -75,7 +75,7 @@ endif
75 75
76.PHONY: all git test install clean distclean emptycache force-version get-git 76.PHONY: all git test install clean distclean emptycache force-version get-git
77 77
78all: cgit git 78all: cgit
79 79
80VERSION: force-version 80VERSION: force-version
81 @./gen-version.sh "$(CGIT_VERSION)" 81 @./gen-version.sh "$(CGIT_VERSION)"
@@ -93,15 +93,13 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
93cgit: $(OBJECTS) 93cgit: $(OBJECTS)
94 $(QUIET_CC)$(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS) 94 $(QUIET_CC)$(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
95 95
96$(OBJECTS): git/xdiff/lib.a git/libgit.a 96$(OBJECTS): | git/xdiff/lib.a git/libgit.a
97 97
98cgit.o: VERSION 98cgit.o: VERSION
99 99
100-include $(OBJECTS:.o=.d) 100-include $(OBJECTS:.o=.d)
101 101
102git/xdiff/lib.a: | git 102git/xdiff/lib.a, git/libgit.a: git
103
104git/libgit.a: | git
105 103
106git: 104git:
107 $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) xdiff/lib.a 105 $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) xdiff/lib.a