aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2008-11-07 03:18:27 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2008-11-07 03:18:27 (JST)
commitb8a7eb12d459c48943e31762b24b169af8c427a1 (patch)
treebb5bfcf6e5f71a478e7586bd1d128aa94bfd7dbe
parent140012d7a8e51df5a9f9c556696778b86ade4fc9 (diff)
parente4d2f2b042100182ff5b214fd6848b71d70fad7d (diff)
downloadcgit-b8a7eb12d459c48943e31762b24b169af8c427a1.zip
cgit-b8a7eb12d459c48943e31762b24b169af8c427a1.tar.gz
Merge branch 'stable'
-rw-r--r--Makefile2
-rw-r--r--cache.c4
m---------git0
-rwxr-xr-xtests/setup.sh6
-rw-r--r--ui-plain.c2
5 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 561af76..f79688c 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
4CGIT_CONFIG = /etc/cgitrc 4CGIT_CONFIG = /etc/cgitrc
5CACHE_ROOT = /var/cache/cgit 5CACHE_ROOT = /var/cache/cgit
6SHA1_HEADER = <openssl/sha.h> 6SHA1_HEADER = <openssl/sha.h>
7GIT_VER = 1.6.0.2 7GIT_VER = 1.6.0.3
8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2 8GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
9 9
10# 10#
diff --git a/cache.c b/cache.c
index 57068a1..d7a8d5a 100644
--- a/cache.c
+++ b/cache.c
@@ -416,11 +416,11 @@ int cache_ls(const char *path)
416 fullname, strerror(err), err); 416 fullname, strerror(err), err);
417 continue; 417 continue;
418 } 418 }
419 printf("%s %s %10zd %s\n", 419 printf("%s %s %10"PRIuMAX" %s\n",
420 name, 420 name,
421 sprintftime("%Y-%m-%d %H:%M:%S", 421 sprintftime("%Y-%m-%d %H:%M:%S",
422 slot.cache_st.st_mtime), 422 slot.cache_st.st_mtime),
423 slot.cache_st.st_size, 423 (uintmax_t)slot.cache_st.st_size,
424 slot.buf); 424 slot.buf);
425 close_slot(&slot); 425 close_slot(&slot);
426 } 426 }
diff --git a/git b/git
Subproject 97a7a82f199f165f85fe39a3c318b18c621e633 Subproject 031e6c898f61db1ae0c0be641eac6532c1000d5
diff --git a/tests/setup.sh b/tests/setup.sh
index 1457dd5..95acb54 100755
--- a/tests/setup.sh
+++ b/tests/setup.sh
@@ -25,11 +25,13 @@ mkrepo() {
25 mkdir -p $name 25 mkdir -p $name
26 cd $name 26 cd $name
27 git init 27 git init
28 for ((n=1; n<=count; n++)) 28 n=1
29 while test $n -le $count
29 do 30 do
30 echo $n >file-$n 31 echo $n >file-$n
31 git add file-$n 32 git add file-$n
32 git commit -m "commit $n" 33 git commit -m "commit $n"
34 n=$(expr $n + 1)
33 done 35 done
34 if test "$3" = "testplus" 36 if test "$3" = "testplus"
35 then 37 then
@@ -101,7 +103,7 @@ run_test()
101{ 103{
102 desc=$1 104 desc=$1
103 script=$2 105 script=$2
104 ((test_count++)) 106 test_count=$(expr $test_count + 1)
105 printf "\ntest %d: name='%s'\n" $test_count "$desc" >>test-output.log 107 printf "\ntest %d: name='%s'\n" $test_count "$desc" >>test-output.log
106 printf "test %d: eval='%s'\n" $test_count "$2" >>test-output.log 108 printf "test %d: eval='%s'\n" $test_count "$2" >>test-output.log
107 eval "$2" >>test-output.log 2>>test-output.log 109 eval "$2" >>test-output.log 2>>test-output.log
diff --git a/ui-plain.c b/ui-plain.c
index be559e0..5addd9e 100644
--- a/ui-plain.c
+++ b/ui-plain.c
@@ -18,7 +18,7 @@ static void print_object(const unsigned char *sha1, const char *path)
18{ 18{
19 enum object_type type; 19 enum object_type type;
20 char *buf; 20 char *buf;
21 size_t size; 21 unsigned long size;
22 22
23 type = sha1_object_info(sha1, &size); 23 type = sha1_object_info(sha1, &size);
24 if (type == OBJ_BAD) { 24 if (type == OBJ_BAD) {