aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar John Keeping <john@keeping.me.uk>2013-04-05 02:32:24 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-04-08 22:43:17 (JST)
commita5e4ad2d8b9c6bcfc7029894d3a3837166996b35 (patch)
tree7e6f815af5acd62b3c40b7e5f3807a723f64baa5
parentcfb77e97fa63d709c81bc730ea47a06172d78669 (diff)
downloadcgit-a5e4ad2d8b9c6bcfc7029894d3a3837166996b35.zip
cgit-a5e4ad2d8b9c6bcfc7029894d3a3837166996b35.tar.gz
cgit.mk: fix dependency handling
Git calculates the dependency files to be included using a simply expanded Makefile variable, so it does not include the CGit objects that are added after that Makefile has been processed. We therefore need to include the dependency files ourselves in order to get the dependency calculations right. Do this. Signed-off-by: John Keeping <john@keeping.me.uk>
-rw-r--r--cgit.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/cgit.mk b/cgit.mk
index bf3bbb1..8af0041 100644
--- a/cgit.mk
+++ b/cgit.mk
@@ -62,6 +62,14 @@ $(CGIT_VERSION_OBJS): EXTRA_CPPFLAGS = \
62 -DCGIT_VERSION='"$(CGIT_VERSION)"' 62 -DCGIT_VERSION='"$(CGIT_VERSION)"'
63 63
64 64
65# Git handles dependencies using ":=" so dependencies in CGIT_OBJ are not
66# handled by that and we must handle them ourselves.
67cgit_dep_files := $(foreach f,$(CGIT_OBJS),$(dir $f).depend/$(notdir $f).d)
68cgit_dep_files_present := $(wildcard $(cgit_dep_files))
69ifneq ($(cgit_dep_files_present),)
70include $(cgit_dep_files_present)
71endif
72
65ifeq ($(wildcard $(CGIT_PREFIX).depend),) 73ifeq ($(wildcard $(CGIT_PREFIX).depend),)
66missing_dep_dirs += $(CGIT_PREFIX).depend 74missing_dep_dirs += $(CGIT_PREFIX).depend
67endif 75endif