aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar John Keeping <john@keeping.me.uk>2013-04-08 17:00:22 (JST)
committerGravatar Jason A. Donenfeld <Jason@zx2c4.com>2013-04-08 22:41:38 (JST)
commit849ecd961df9454d6f849eac34e6f501395c4f01 (patch)
tree6b7dbd83035c45c8afb34c6607738cf42c8c8d8d
parent1c32e008c8fda46f812c38f46ae7515bcf8002ee (diff)
downloadcgit-849ecd961df9454d6f849eac34e6f501395c4f01.zip
cgit-849ecd961df9454d6f849eac34e6f501395c4f01.tar.gz
Update git to v1.8.2.1
This requires a small change to how we handle notes, but otherwise just works. Note that we can't use anything from v1.8.0 until v1.8.2.1 because some of the symbols that we need for graph drawing were made private in v1.8.0 and this was not reverted until v1.8.2.1. Signed-off-by: John Keeping <john@keeping.me.uk>
-rw-r--r--Makefile2
m---------git0
-rw-r--r--ui-commit.c3
-rw-r--r--ui-log.c6
4 files changed, 6 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 83d4716..59edab0 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ htmldir = $(docdir)
14pdfdir = $(docdir) 14pdfdir = $(docdir)
15mandir = $(prefix)/share/man 15mandir = $(prefix)/share/man
16SHA1_HEADER = <openssl/sha.h> 16SHA1_HEADER = <openssl/sha.h>
17GIT_VER = 1.7.12.4 17GIT_VER = 1.8.2.1
18GIT_URL = https://git-core.googlecode.com/files/git-$(GIT_VER).tar.gz 18GIT_URL = https://git-core.googlecode.com/files/git-$(GIT_VER).tar.gz
19INSTALL = install 19INSTALL = install
20MAN5_TXT = $(wildcard *.5.txt) 20MAN5_TXT = $(wildcard *.5.txt)
diff --git a/git b/git
Subproject 7e2010537e96d0a1144520222f20ba1dc3d6144 Subproject 5bda18c186e455f8e65f976d3bf333ab1f4b5b5
diff --git a/ui-commit.c b/ui-commit.c
index 0783285..5a552a1 100644
--- a/ui-commit.c
+++ b/ui-commit.c
@@ -36,7 +36,8 @@ void cgit_print_commit(char *hex, const char *prefix)
36 } 36 }
37 info = cgit_parse_commit(commit); 37 info = cgit_parse_commit(commit);
38 38
39 format_note(NULL, sha1, &notes, PAGE_ENCODING, 0); 39 init_display_notes(NULL);
40 format_display_notes(sha1, &notes, PAGE_ENCODING, 0);
40 41
41 load_ref_decorations(DECORATE_FULL_REFS); 42 load_ref_decorations(DECORATE_FULL_REFS);
42 43
diff --git a/ui-log.c b/ui-log.c
index aaffb4e..8d8b235 100644
--- a/ui-log.c
+++ b/ui-log.c
@@ -195,9 +195,8 @@ static void print_commit(struct commit *commit, struct rev_info *revs)
195 strbuf_addstr(&msgbuf, info->msg); 195 strbuf_addstr(&msgbuf, info->msg);
196 strbuf_addch(&msgbuf, '\n'); 196 strbuf_addch(&msgbuf, '\n');
197 } 197 }
198 format_note(NULL, commit->object.sha1, &msgbuf, 198 format_display_notes(commit->object.sha1,
199 PAGE_ENCODING, 199 &msgbuf, PAGE_ENCODING, 0);
200 NOTES_SHOW_HEADER | NOTES_INDENT);
201 strbuf_addch(&msgbuf, '\n'); 200 strbuf_addch(&msgbuf, '\n');
202 strbuf_ltrim(&msgbuf); 201 strbuf_ltrim(&msgbuf);
203 } 202 }
@@ -397,6 +396,7 @@ void cgit_print_log(const char *tip, int ofs, int cnt, char *grep, char *pattern
397 commit->parents = NULL; 396 commit->parents = NULL;
398 } 397 }
399 398
399 init_display_notes(NULL);
400 for (i = 0; i < cnt && (commit = get_revision(&rev)) != NULL; i++) { 400 for (i = 0; i < cnt && (commit = get_revision(&rev)) != NULL; i++) {
401 print_commit(commit, &rev); 401 print_commit(commit, &rev);
402 free(commit->buffer); 402 free(commit->buffer);