aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar YAEGASHI Takeshi <yaegashi@debian.org>2014-02-16 17:42:58 (JST)
committerGravatar YAEGASHI Takeshi <yaegashi@debian.org>2014-02-17 07:42:07 (JST)
commit74338eca40104987546da77ad38e8bb96e4bcd18 (patch)
tree76d2cf610f80c734463d7936b7eafbc2bea38a7f
parent5fac26e7ad1e5f710786f2527357cb66ab21d51d (diff)
downloadcgit-74338eca40104987546da77ad38e8bb96e4bcd18.zip
cgit-74338eca40104987546da77ad38e8bb96e4bcd18.tar.gz
Add config files
-rw-r--r--debian/cgit.dirs2
-rw-r--r--debian/cgit.examples2
-rw-r--r--debian/examples/apache2.conf15
-rw-r--r--debian/examples/cgitrc59
-rwxr-xr-xdebian/rules2
5 files changed, 80 insertions, 0 deletions
diff --git a/debian/cgit.dirs b/debian/cgit.dirs
new file mode 100644
index 0000000..cf8f9c6
--- /dev/null
+++ b/debian/cgit.dirs
@@ -0,0 +1,2 @@
1/var/cache/cgit
2/etc/apache2/conf-available
diff --git a/debian/cgit.examples b/debian/cgit.examples
new file mode 100644
index 0000000..7e541b7
--- /dev/null
+++ b/debian/cgit.examples
@@ -0,0 +1,2 @@
1debian/examples/cgitrc
2debian/examples/apache2.conf
diff --git a/debian/examples/apache2.conf b/debian/examples/apache2.conf
new file mode 100644
index 0000000..04b557e
--- /dev/null
+++ b/debian/examples/apache2.conf
@@ -0,0 +1,15 @@
1# Apache2 configuration for Debian cgit package.
2# The CGI executable is /usr/lib/cgi-bin/cgit.cgi
3# Other static assets are installed in /usr/share/cgit/htdocs
4
5Alias /cgit/cgit.css /usr/share/cgit/htdocs/cgit.css
6Alias /cgit/cgit.png /usr/share/cgit/htdocs/cgit.png
7Alias /cgit/robot.txt /usr/share/cgit/htdocs/robots.txt
8Alias /cgit/favicon.ico /usr/share/cgit/htdocs/favicon.ico
9ScriptAlias /cgit/ /usr/lib/cgi-bin/cgit.cgi/
10
11<Directory "/usr/share/cgit/htdocs">
12 AllowOverride None
13 Order allow,deny
14 Allow from all
15</Directory>
diff --git a/debian/examples/cgitrc b/debian/examples/cgitrc
new file mode 100644
index 0000000..1decd2f
--- /dev/null
+++ b/debian/examples/cgitrc
@@ -0,0 +1,59 @@
1## Debian cgit package configuration - see cgitrc(5).
2
3## Enable caching up to 1000 entries in cache-root (/var/cache/cgit).
4cache-size=1000
5
6## Static asset locations (suitting to /etc/apache2/conf-available/cgit.conf).
7css=/cgit/cgit.css
8logo=/cgit/cgit.png
9favicon=/cgit/favicon.ico
10
11## Load system mime types.
12mimetype-file=/etc/mime.types
13
14## Enable downloading snapshots in zip and tar.gz format.
15snapshots=zip tar.gz
16
17## Enable other nice features.
18local-time=1
19side-by-side-diffs=1
20enable-git-config=1
21enable-commit-graph=1
22enable-log-linecount=1
23
24## Enable email gravatar filter.
25#email-filter=exec:/usr/lib/cgit/filters/email-gravatar.py
26
27## Enable source code highlighting filter by pygments.
28## You need suggested package: python-pygments
29#source-filter=exec:/usr/lib/cgit/filters/syntax-highlighting.py
30
31## Configuration for repositories foo and bar.
32#repo.url=foo
33#repo.path=/pub/git/foo.git
34#repo.desc=the master foo repository
35#repo.owner=fooman@example.com
36#repo.readme=info/web/about.html
37#
38#repo.url=bar
39#repo.path=/pub/git/bar.git
40#repo.desc=the bars for your foo
41#repo.owner=barman@example.com
42#repo.readme=info/web/about.html
43
44## Configuration for repositories baz and wiz in the extras section.
45#section=extras
46#
47#repo.url=baz
48#repo.path=/pub/git/baz.git
49#repo.desc=a set of extensions for bar users
50#
51#repo.url=wiz
52#repo.path=/pub/git/wiz.git
53#repo.desc=the wizard of foo
54
55## Configuration for repositories managed by Debian gitolite3 package.
56## See the instructions on the gitweb integration at
57## http://gitolite.com/gitolite/external.html
58#project-list=/var/lib/gitolite3/projects.list
59#scan-path=/var/lib/gitolite3/repositories
diff --git a/debian/rules b/debian/rules
index 66f21de..03e82dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,3 +26,5 @@ override_dh_auto_test:
26 26
27override_dh_auto_install: 27override_dh_auto_install:
28 dh_auto_install -- $(MAKE_ARGS) install-doc 28 dh_auto_install -- $(MAKE_ARGS) install-doc
29 install -m 0644 debian/examples/cgitrc debian/cgit/etc
30 install -m 0644 debian/examples/apache2.conf debian/cgit/etc/apache2/conf-available/cgit.conf