aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGravatar Lars Hjemli <hjemli@gmail.com>2006-12-12 00:55:07 (JST)
committerGravatar Lars Hjemli <hjemli@gmail.com>2006-12-12 00:55:33 (JST)
commit1418034e642fee67c981b31e4c3eb6e8ae14e303 (patch)
tree3addc880197706f2ddd24f35c5d886f1e885b276
parent74620f12e4f7e91cb0a0b4ca731e07272d1b65f6 (diff)
downloadcgit-1418034e642fee67c981b31e4c3eb6e8ae14e303.zip
cgit-1418034e642fee67c981b31e4c3eb6e8ae14e303.tar.gz
Move repo summary functions into ui-summary.c
Signed-off-by: Lars Hjemli <hjemli@gmail.com>
-rw-r--r--Makefile2
-rw-r--r--cgit.c46
-rw-r--r--cgit.h3
-rw-r--r--ui-summary.c55
4 files changed, 59 insertions, 47 deletions
diff --git a/Makefile b/Makefile
index 81ebb18..71ddc40 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ INSTALL_CSS = /var/www/htdocs/cgit.css
5CACHE_ROOT = /var/cache/cgit 5CACHE_ROOT = /var/cache/cgit
6 6
7EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto 7EXTLIBS = ../git/libgit.a ../git/xdiff/lib.a -lz -lcrypto
8OBJECTS = parsing.o html.o cache.o ui-shared.o ui-repolist.o 8OBJECTS = cache.o parsing.o html.o ui-shared.o ui-repolist.o ui-summary.o
9 9
10CFLAGS += -Wall 10CFLAGS += -Wall
11 11
diff --git a/cgit.c b/cgit.c
index b3ff512..300fe46 100644
--- a/cgit.c
+++ b/cgit.c
@@ -84,44 +84,6 @@ void cgit_querystring_cb(const char *name, const char *value)
84 } 84 }
85} 85}
86 86
87static int cgit_print_branch_cb(const char *refname, const unsigned char *sha1,
88 int flags, void *cb_data)
89{
90 struct commit *commit;
91 char buf[256], *url;
92
93 commit = lookup_commit(sha1);
94 if (commit && !parse_commit(commit)){
95 html("<tr><td>");
96 url = cgit_pageurl(cgit_query_repo, "log",
97 fmt("h=%s", refname));
98 html_link_open(url, NULL, NULL);
99 strncpy(buf, refname, sizeof(buf));
100 html_txt(buf);
101 html_link_close();
102 html("</td><td>");
103 pretty_print_commit(CMIT_FMT_ONELINE, commit, ~0, buf,
104 sizeof(buf), 0, NULL, NULL, 0);
105 html_txt(buf);
106 html("</td></tr>\n");
107 } else {
108 html("<tr><td>");
109 html_txt(buf);
110 html("</td><td>");
111 htmlf("*** bad ref %s", sha1_to_hex(sha1));
112 html("</td></tr>\n");
113 }
114 return 0;
115}
116
117static void cgit_print_branches()
118{
119 html("<table class='list'>");
120 html("<tr><th>Branch name</th><th>Head commit</th></tr>\n");
121 for_each_branch_ref(cgit_print_branch_cb, NULL);
122 html("</table>");
123}
124
125static int get_one_line(char *txt) 87static int get_one_line(char *txt)
126{ 88{
127 char *t; 89 char *t;
@@ -227,14 +189,6 @@ static void cgit_print_log(const char *tip, int ofs, int cnt)
227 html("</table>\n"); 189 html("</table>\n");
228} 190}
229 191
230static void cgit_print_repo_summary()
231{
232 html("<h2>");
233 html_txt("Repo summary page");
234 html("</h2>");
235 cgit_print_branches();
236}
237
238static void cgit_print_object(char *hex) 192static void cgit_print_object(char *hex)
239{ 193{
240 unsigned char sha1[20]; 194 unsigned char sha1[20];
diff --git a/cgit.h b/cgit.h
index bf5bd8d..3a153a5 100644
--- a/cgit.h
+++ b/cgit.h
@@ -79,4 +79,7 @@ extern void cgit_print_repolist(struct cacheitem *item);
79 79
80extern void cgit_repo_config_cb(const char *name, const char *value); 80extern void cgit_repo_config_cb(const char *name, const char *value);
81 81
82extern void cgit_print_repo_summary();
83
84
82#endif /* CGIT_H */ 85#endif /* CGIT_H */
diff --git a/ui-summary.c b/ui-summary.c
new file mode 100644
index 0000000..532ddbf
--- /dev/null
+++ b/ui-summary.c
@@ -0,0 +1,55 @@
1/* ui-summary.c: functions for generating repo summary page
2 *
3 * Copyright (C) 2006 Lars Hjemli
4 *
5 * Licensed under GNU General Public License v2
6 * (see COPYING for full license text)
7 */
8
9#include "cgit.h"
10
11static int cgit_print_branch_cb(const char *refname, const unsigned char *sha1,
12 int flags, void *cb_data)
13{
14 struct commit *commit;
15 char buf[256], *url;
16
17 commit = lookup_commit(sha1);
18 if (commit && !parse_commit(commit)){
19 html("<tr><td>");
20 url = cgit_pageurl(cgit_query_repo, "log",
21 fmt("h=%s", refname));
22 html_link_open(url, NULL, NULL);
23 strncpy(buf, refname, sizeof(buf));
24 html_txt(buf);
25 html_link_close();
26 html("</td><td>");
27 pretty_print_commit(CMIT_FMT_ONELINE, commit, ~0, buf,
28 sizeof(buf), 0, NULL, NULL, 0);
29 html_txt(buf);
30 html("</td></tr>\n");
31 } else {
32 html("<tr><td>");
33 html_txt(buf);
34 html("</td><td>");
35 htmlf("*** bad ref %s", sha1_to_hex(sha1));
36 html("</td></tr>\n");
37 }
38 return 0;
39}
40
41static void cgit_print_branches()
42{
43 html("<table class='list'>");
44 html("<tr><th>Branch name</th><th>Head commit</th></tr>\n");
45 for_each_branch_ref(cgit_print_branch_cb, NULL);
46 html("</table>");
47}
48
49void cgit_print_repo_summary()
50{
51 html("<h2>");
52 html_txt("Repo summary page");
53 html("</h2>");
54 cgit_print_branches();
55}