From 74338eca40104987546da77ad38e8bb96e4bcd18 Mon Sep 17 00:00:00 2001
From: YAEGASHI Takeshi <yaegashi@debian.org>
Date: Sun, 16 Feb 2014 17:42:58 +0900
Subject: Add config files


diff --git a/debian/cgit.dirs b/debian/cgit.dirs
new file mode 100644
index 0000000..cf8f9c6
--- /dev/null
+++ b/debian/cgit.dirs
@@ -0,0 +1,2 @@
+/var/cache/cgit
+/etc/apache2/conf-available
diff --git a/debian/cgit.examples b/debian/cgit.examples
new file mode 100644
index 0000000..7e541b7
--- /dev/null
+++ b/debian/cgit.examples
@@ -0,0 +1,2 @@
+debian/examples/cgitrc
+debian/examples/apache2.conf
diff --git a/debian/examples/apache2.conf b/debian/examples/apache2.conf
new file mode 100644
index 0000000..04b557e
--- /dev/null
+++ b/debian/examples/apache2.conf
@@ -0,0 +1,15 @@
+# Apache2 configuration for Debian cgit package.
+# The CGI executable is /usr/lib/cgi-bin/cgit.cgi
+# Other static assets are installed in /usr/share/cgit/htdocs
+
+Alias /cgit/cgit.css /usr/share/cgit/htdocs/cgit.css
+Alias /cgit/cgit.png /usr/share/cgit/htdocs/cgit.png
+Alias /cgit/robot.txt /usr/share/cgit/htdocs/robots.txt
+Alias /cgit/favicon.ico /usr/share/cgit/htdocs/favicon.ico
+ScriptAlias /cgit/ /usr/lib/cgi-bin/cgit.cgi/
+
+<Directory "/usr/share/cgit/htdocs">
+  AllowOverride None
+  Order allow,deny
+  Allow from all
+</Directory>
diff --git a/debian/examples/cgitrc b/debian/examples/cgitrc
new file mode 100644
index 0000000..1decd2f
--- /dev/null
+++ b/debian/examples/cgitrc
@@ -0,0 +1,59 @@
+## Debian cgit package configuration - see cgitrc(5).
+
+## Enable caching up to 1000 entries in cache-root (/var/cache/cgit).
+cache-size=1000
+
+## Static asset locations (suitting to /etc/apache2/conf-available/cgit.conf).
+css=/cgit/cgit.css
+logo=/cgit/cgit.png
+favicon=/cgit/favicon.ico
+
+## Load system mime types.
+mimetype-file=/etc/mime.types
+
+## Enable downloading snapshots in zip and tar.gz format.
+snapshots=zip tar.gz
+
+## Enable other nice features.
+local-time=1
+side-by-side-diffs=1
+enable-git-config=1
+enable-commit-graph=1
+enable-log-linecount=1
+
+## Enable email gravatar filter.
+#email-filter=exec:/usr/lib/cgit/filters/email-gravatar.py
+
+## Enable source code highlighting filter by pygments.
+## You need suggested package: python-pygments
+#source-filter=exec:/usr/lib/cgit/filters/syntax-highlighting.py
+
+## Configuration for repositories foo and bar.
+#repo.url=foo
+#repo.path=/pub/git/foo.git
+#repo.desc=the master foo repository
+#repo.owner=fooman@example.com
+#repo.readme=info/web/about.html
+#
+#repo.url=bar
+#repo.path=/pub/git/bar.git
+#repo.desc=the bars for your foo
+#repo.owner=barman@example.com
+#repo.readme=info/web/about.html
+
+## Configuration for repositories baz and wiz in the extras section.
+#section=extras
+#
+#repo.url=baz
+#repo.path=/pub/git/baz.git
+#repo.desc=a set of extensions for bar users
+#
+#repo.url=wiz
+#repo.path=/pub/git/wiz.git
+#repo.desc=the wizard of foo
+
+## Configuration for repositories managed by Debian gitolite3 package.
+## See the instructions on the gitweb integration at
+## http://gitolite.com/gitolite/external.html
+#project-list=/var/lib/gitolite3/projects.list
+#scan-path=/var/lib/gitolite3/repositories
diff --git a/debian/rules b/debian/rules
index 66f21de..03e82dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,3 +26,5 @@ override_dh_auto_test:
 
 override_dh_auto_install:
 	dh_auto_install -- $(MAKE_ARGS) install-doc
+	install -m 0644 debian/examples/cgitrc debian/cgit/etc
+	install -m 0644 debian/examples/apache2.conf debian/cgit/etc/apache2/conf-available/cgit.conf
-- 
cgit v0.10.1