From b7f33786ef4b155a11b0324f84bbde5d7fc9c998 Mon Sep 17 00:00:00 2001
From: Lars Hjemli <hjemli@gmail.com>
Date: Sun, 5 Oct 2008 19:19:59 +0200
Subject: Use GIT-1.6.0.2

Signed-off-by: Lars Hjemli <hjemli@gmail.com>

diff --git a/Makefile b/Makefile
index 2fe537e..9896b4f 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
 CGIT_CONFIG = /etc/cgitrc
 CACHE_ROOT = /var/cache/cgit
 SHA1_HEADER = <openssl/sha.h>
-GIT_VER = 1.6.0.1
+GIT_VER = 1.6.0.2
 GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
 
 #
diff --git a/git b/git
index 5760a6b..97a7a82 160000
--- a/git
+++ b/git
@@ -1 +1 @@
-Subproject commit 5760a6b094736e6f59eb32c7abb4cdbb7fca1627
+Subproject commit 97a7a82f199f165f85fe39a3c318b18c621e6335
diff --git a/ui-log.c b/ui-log.c
index 746f40b..8dd8b89 100644
--- a/ui-log.c
+++ b/ui-log.c
@@ -92,10 +92,8 @@ void cgit_print_log(const char *tip, int ofs, int cnt, char *grep, char *pattern
 	rev.verbose_header = 1;
 	rev.show_root_diff = 0;
 	setup_revisions(argc, argv, &rev, NULL);
-	if (rev.grep_filter) {
-		rev.grep_filter->regflags |= REG_ICASE;
-		compile_grep_patterns(rev.grep_filter);
-	}
+	rev.grep_filter.regflags |= REG_ICASE;
+	compile_grep_patterns(&rev.grep_filter);
 	prepare_revision_walk(&rev);
 
 	if (pager)
-- 
cgit v0.10.1