From 97fdac1608a0b4b07aae26b144c6ee7991e6c5eb Mon Sep 17 00:00:00 2001
From: Ramsay Jones <ramsay@ramsay1.demon.co.uk>
Date: Sat, 15 Nov 2008 18:26:32 +0000
Subject: Extra cygwin-specific changes

Signed-off-by: Ramsay Jones <ramsay@ramsay1.demon.co.uk>
Signed-off-by: Lars Hjemli <hjemli@gmail.com>

diff --git a/Makefile b/Makefile
index 2107610..dc98072 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,26 @@ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
 #
 -include cgit.conf
 
+# Define NO_STRCASESTR if you don't have strcasestr.
+#
+# Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
+#
+
+#-include config.mak
+
+#
+# Platform specific tweaks
+#
+
+uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
+uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
+uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
+
+ifeq ($(uname_O),Cygwin)
+	NO_STRCASESTR = YesPlease
+	NEEDS_LIBICONV = YesPlease
+endif
+
 #
 # Define a way to invoke make in subdirs quietly, shamelessly ripped
 # from git.git
@@ -96,6 +116,9 @@ CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
 ifdef NO_ICONV
 	CFLAGS += -DNO_ICONV
 endif
+ifdef NO_STRCASESTR
+	CFLAGS += -DNO_STRCASESTR
+endif
 
 cgit: $(OBJECTS) libgit
 	$(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
diff --git a/cgit.h b/cgit.h
index 91db98a..92f0c5a 100644
--- a/cgit.h
+++ b/cgit.h
@@ -233,11 +233,5 @@ extern const char *cgit_repobasename(const char *reponame);
 
 extern int cgit_parse_snapshots_mask(const char *str);
 
-/* libgit.a either links against or compiles its own implementation of
- * strcasestr(), and we'd like to reuse it. Simply re-declaring it
- * seems to do the trick.
- */
-extern char *strcasestr(const char *haystack, const char *needle);
-
 
 #endif /* CGIT_H */
-- 
cgit v0.10.1


From a5e899e4c786e2ed7f58874d66956bf196cef8df Mon Sep 17 00:00:00 2001
From: Lars Hjemli <hjemli@gmail.com>
Date: Fri, 5 Dec 2008 18:47:16 +0100
Subject: Makefile: allow cgit.conf to override platform-specific tweaks

If the makefile doesn't automatically define the correct build variables
it is nice to be able to define them explicitly.

Signed-off-by: Lars Hjemli <hjemli@gmail.com>

diff --git a/Makefile b/Makefile
index dc98072..2e51c31 100644
--- a/Makefile
+++ b/Makefile
@@ -7,11 +7,6 @@ SHA1_HEADER = <openssl/sha.h>
 GIT_VER = 1.6.0.3
 GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
 
-#
-# Let the user override the above settings.
-#
--include cgit.conf
-
 # Define NO_STRCASESTR if you don't have strcasestr.
 #
 # Define NEEDS_LIBICONV if linking with libc is not enough (eg. Darwin).
@@ -33,6 +28,11 @@ ifeq ($(uname_O),Cygwin)
 endif
 
 #
+# Let the user override the above settings.
+#
+-include cgit.conf
+
+#
 # Define a way to invoke make in subdirs quietly, shamelessly ripped
 # from git.git
 #
-- 
cgit v0.10.1


From 7115f7d257b5e3fb5d5d7ad6299214506fb35042 Mon Sep 17 00:00:00 2001
From: Lars Hjemli <hjemli@gmail.com>
Date: Fri, 5 Dec 2008 19:04:17 +0100
Subject: ui-repolist: avoid build warning for strcasestr(3)

The non-standard function strcasestr is only defined if _GNU_SOURCE has
also been defined.

Signed-off-by: Lars Hjemli <hjemli@gmail.com>

diff --git a/ui-repolist.c b/ui-repolist.c
index c23232c..2324273 100644
--- a/ui-repolist.c
+++ b/ui-repolist.c
@@ -6,6 +6,10 @@
  *   (see COPYING for full license text)
  */
 
+/* This is needed for strcasestr to be defined by <string.h> */
+#define _GNU_SOURCE 1
+#include <string.h>
+
 #include <time.h>
 
 #include "cgit.h"
-- 
cgit v0.10.1


From 14b4e108a73b09ce9b6df2c7f2e417305ad68cf4 Mon Sep 17 00:00:00 2001
From: Lars Hjemli <hjemli@gmail.com>
Date: Fri, 5 Dec 2008 19:10:28 +0100
Subject: parsing.c: enable builds with NO_ICONV defined

Signed-off-by: Lars Hjemli <hjemli@gmail.com>

diff --git a/parsing.c b/parsing.c
index c8f3048..f3f3b15 100644
--- a/parsing.c
+++ b/parsing.c
@@ -96,6 +96,9 @@ char *parse_user(char *t, char **name, char **email, unsigned long *date)
 	return p;
 }
 
+#ifdef NO_ICONV
+#define reencode(a, b, c)
+#else
 const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
 {
 	char *tmp;
@@ -110,6 +113,7 @@ const char *reencode(char **txt, const char *src_enc, const char *dst_enc)
 	}
 	return *txt;
 }
+#endif
 
 struct commitinfo *cgit_parse_commit(struct commit *commit)
 {
-- 
cgit v0.10.1