diff options
Diffstat (limited to 'filters')
-rwxr-xr-x | filters/commit-links.sh | 7 | ||||
-rwxr-xr-x | filters/syntax-highlighting.sh | 28 |
2 files changed, 33 insertions, 2 deletions
diff --git a/filters/commit-links.sh b/filters/commit-links.sh index d2cd2b3..5881952 100755 --- a/filters/commit-links.sh +++ b/filters/commit-links.sh | |||
@@ -15,11 +15,14 @@ | |||
15 | # CGIT_REPO_CLONE_URL ( = repo.clone-url setting ) | 15 | # CGIT_REPO_CLONE_URL ( = repo.clone-url setting ) |
16 | # | 16 | # |
17 | 17 | ||
18 | regex='' | ||
19 | |||
18 | # This expression generates links to commits referenced by their SHA1. | 20 | # This expression generates links to commits referenced by their SHA1. |
19 | regex=$regex' | 21 | regex=$regex' |
20 | s|\b([0-9a-fA-F]{8,40})\b|<a href="./?id=\1">\1</a>|g' | 22 | s|\b([0-9a-fA-F]{7,40})\b|<a href="./?id=\1">\1</a>|g' |
23 | |||
21 | # This expression generates links to a fictional bugtracker. | 24 | # This expression generates links to a fictional bugtracker. |
22 | regex=$regex' | 25 | regex=$regex' |
23 | s| #([0-9]+)\b|<a href="http://bugs.example.com/?bug=\1">#\1</a>|g' | 26 | s|#([0-9]+)\b|<a href="http://bugs.example.com/?bug=\1">#\1</a>|g' |
24 | 27 | ||
25 | sed -re "$regex" | 28 | sed -re "$regex" |
diff --git a/filters/syntax-highlighting.sh b/filters/syntax-highlighting.sh index 6283ce9..5fcc9c9 100755 --- a/filters/syntax-highlighting.sh +++ b/filters/syntax-highlighting.sh | |||
@@ -42,4 +42,32 @@ EXTENSION="${BASENAME##*.}" | |||
42 | # map Makefile and Makefile.* to .mk | 42 | # map Makefile and Makefile.* to .mk |
43 | [ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk | 43 | [ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk |
44 | 44 | ||
45 | # highlight versions 2 and 3 have different commandline options. Specifically, | ||
46 | # the -X option that is used for version 2 is replaced by the -O xhtml option | ||
47 | # for version 3. | ||
48 | # | ||
49 | # Version 2 can be found (for example) on EPEL 5, while version 3 can be | ||
50 | # found (for example) on EPEL 6. | ||
51 | # | ||
52 | # This is for version 2 | ||
45 | exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null | 53 | exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null |
54 | |||
55 | # This is for version 3 | ||
56 | # | ||
57 | # On CentOS 6.2 (using highlight from EPEL), when highlight doesn't know about | ||
58 | # an EXTENSION, it outputs a lua error and _no_ text, even when the --force | ||
59 | # option is used. | ||
60 | # | ||
61 | # Also see the bug reports at: | ||
62 | # http://sourceforge.net/tracker/?func=detail&aid=3490017&group_id=215618&atid=1034391 | ||
63 | # https://bugzilla.redhat.com/show_bug.cgi?id=795567 | ||
64 | # | ||
65 | # This workaround can be removed when the bug is fixed upstream and the new | ||
66 | # version is packaged in most distributions. | ||
67 | # | ||
68 | # The workaround is to set the extension to 'txt' (plain text) when highlight | ||
69 | # exits with an error (doesn't know the format). | ||
70 | # | ||
71 | #echo "test" | highlight -f -I -O xhtml -S $EXTENSION &>/dev/null | ||
72 | #[ ${?} -ne 0 ] && EXTENSION="txt" | ||
73 | #exec highlight --force -f -I -O xhtml -S $EXTENSION 2>/dev/null | ||