aboutsummaryrefslogtreecommitdiffstats
path: root/filters/syntax-highlighting.sh
diff options
context:
space:
mode:
Diffstat (limited to 'filters/syntax-highlighting.sh')
-rwxr-xr-xfilters/syntax-highlighting.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/filters/syntax-highlighting.sh b/filters/syntax-highlighting.sh
index 6b1c576..3fe7fa1 100755
--- a/filters/syntax-highlighting.sh
+++ b/filters/syntax-highlighting.sh
@@ -31,4 +31,15 @@ EXTENSION="${BASENAME##*.}"
31# map Makefile and Makefile.* to .mk 31# map Makefile and Makefile.* to .mk
32[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk 32[ "${BASENAME%%.*}" == "Makefile" ] && EXTENSION=mk
33 33
34# highlight versions 2 and 3 have different commandline options. Specifically,
35# the -X option that is used for version 2 is replaced by the -O xhtml option
36# for version 3.
37#
38# Version 2 can be found (for example) on EPEL 5, while version 3 can be
39# found (for example) on EPEL 6.
40#
41# This is for version 2
34exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null 42exec highlight --force -f -I -X -S $EXTENSION 2>/dev/null
43
44# This is for version 3
45#exec highlight --force -f -I -O xhtml -S $EXTENSION 2>/dev/null