aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..982c51e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
1#!/usr/bin/make -f
2# -*- makefile -*-
3
4# Uncomment this to turn on verbose mode.
5#export DH_VERBOSE=1
6
7MAKE_ARGS = \
8 prefix=/usr \
9 CGIT_SCRIPT_PATH=/usr/lib/cgi-bin \
10 CGIT_DATA_PATH=/usr/share/cgit/htdocs
11
12%:
13 dh $@
14
15override_dh_auto_clean:
16 dh_auto_clean
17 rm -rf .depend
18 cd git; if test -e .git; then git clean -ffdx; else make distclean; fi
19
20override_dh_auto_configure:
21
22override_dh_auto_build:
23 dh_auto_build -- $(MAKE_ARGS) all doc
24
25override_dh_auto_test:
26
27override_dh_auto_install:
28 dh_auto_install -- $(MAKE_ARGS) install-doc
29 install -m 0644 debian/examples/cgitrc debian/cgit/etc
30 install -m 0644 debian/examples/apache2.conf debian/cgit/etc/apache2/conf-available/cgit.conf
31
32override_dh_compress:
33 dh_compress -a -X.pdf