aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 914db1c..5e16a4f 100644
--- a/Makefile
+++ b/Makefile
@@ -31,14 +31,12 @@ CFLAGS += -DCGIT_SCRIPT_NAME='"$(CGIT_SCRIPT_NAME)"'
31 31
32 32
33# 33#
34# If make is run on a nongit platform, we need to get the git sources as a tarball. 34# If make is run on a nongit platform, get the git sources as a tarball.
35# But there is currently no recent enough tarball available on kernel.org, so download
36# a zipfile from hjemli.net instead
37# 35#
38GITVER = $(shell git version 2>/dev/null || echo nogit) 36GITVER = $(shell git version 2>/dev/null || echo nogit)
39ifeq ($(GITVER),nogit) 37ifeq ($(GITVER),nogit)
40GITURL = http://hjemli.net/git/git/snapshot/?id=v1.5.2-rc2 38GITURL = http://www.kernel.org/pub/software/scm/git/git-1.5.2.tar.bz2
41INITGIT = test -e git/git.c || (curl "$(GITURL)" > tmp.zip && unzip tmp.zip) 39INITGIT = test -e git/git.c || ((curl "$(GITURL)" | tar -xj) && mv git-1.5.2 git)
42else 40else
43INITGIT = ./submodules.sh -i 41INITGIT = ./submodules.sh -i
44endif 42endif