aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--cgit.css64
-rw-r--r--cgit.h8
-rw-r--r--cgit.pngbin3790 -> 5406 bytes
-rw-r--r--cgitrc5
-rw-r--r--html.c2
-rw-r--r--parsing.c25
-rw-r--r--shared.c5
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile13
-rwxr-xr-xtests/setup.sh108
-rwxr-xr-xtests/t0010-validate-html.sh31
-rwxr-xr-xtests/t0101-index.sh13
-rwxr-xr-xtests/t0102-summary.sh20
-rwxr-xr-xtests/t0103-log.sh15
-rwxr-xr-xtests/t0104-tree.sh21
-rwxr-xr-xtests/t0105-commit.sh22
-rwxr-xr-xtests/t0106-diff.sh20
-rwxr-xr-xtests/t0107-snapshot.sh36
-rw-r--r--ui-commit.c6
-rw-r--r--ui-diff.c2
-rw-r--r--ui-log.c23
-rw-r--r--ui-repolist.c2
-rw-r--r--ui-shared.c42
-rw-r--r--ui-summary.c2
-rw-r--r--ui-tree.c6
26 files changed, 435 insertions, 68 deletions
diff --git a/Makefile b/Makefile
index 27e966d..72c189c 100644
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,12 @@ OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \
19 ui-snapshot.o ui-blob.o ui-tag.o ui-refs.o 19 ui-snapshot.o ui-blob.o ui-tag.o ui-refs.o
20 20
21 21
22.PHONY: all git install clean distclean emptycache force-version get-git 22ifdef NEEDS_LIBICONV
23 EXTLIBS += -liconv
24endif
25
26
27.PHONY: all git test install clean distclean emptycache force-version get-git
23 28
24all: cgit git 29all: cgit git
25 30
@@ -49,6 +54,9 @@ git:
49 cd git && $(MAKE) xdiff/lib.a 54 cd git && $(MAKE) xdiff/lib.a
50 cd git && $(MAKE) libgit.a 55 cd git && $(MAKE) libgit.a
51 56
57test: all
58 $(MAKE) -C tests
59
52install: all 60install: all
53 mkdir -p $(DESTDIR)$(CGIT_SCRIPT_PATH) 61 mkdir -p $(DESTDIR)$(CGIT_SCRIPT_PATH)
54 install cgit $(DESTDIR)$(CGIT_SCRIPT_PATH)/$(CGIT_SCRIPT_NAME) 62 install cgit $(DESTDIR)$(CGIT_SCRIPT_PATH)/$(CGIT_SCRIPT_NAME)
diff --git a/cgit.css b/cgit.css
index 1b2e9d6..17c2712 100644
--- a/cgit.css
+++ b/cgit.css
@@ -8,7 +8,7 @@ body {
8 font-size: 10pt; 8 font-size: 10pt;
9 color: #333; 9 color: #333;
10 background: white; 10 background: white;
11 padding-left: 4px; 11 padding: 4px;
12} 12}
13 13
14table { 14table {
@@ -78,29 +78,39 @@ img {
78 border: none; 78 border: none;
79} 79}
80 80
81div#sidebar { 81table#layout {
82 border-collapse: collapse;
83 border: none;
84 margin: 0px;
85}
86
87td#sidebar {
82 vertical-align: top; 88 vertical-align: top;
83 width: 162px; 89 width: 162px;
84 padding: 0px 0px 0px 0px; 90 padding: 0px 0px 0px 0px;
85 margin: 4px; 91 margin: 0px;
86 float: left;
87} 92}
88 93
89div#logo { 94td#sidebar table {
95 border-collapse: separate;
96 border-spacing: 0px;
90 margin: 0px; 97 margin: 0px;
91 padding: 4px 0px 4px 0px; 98 padding: 0px;
92 text-align: center;
93 background-color: #ccc; 99 background-color: #ccc;
100}
101
102td#sidebar table.sidebar td.sidebar {
103 padding: 4px;
94 border-top: solid 1px #eee; 104 border-top: solid 1px #eee;
95 border-left: solid 1px #eee; 105 border-left: solid 1px #eee;
96 border-right: solid 1px #aaa; 106 border-right: solid 1px #aaa;
97 border-bottom: solid 1px #aaa; 107 border-bottom: solid 1px #aaa;
98} 108}
99 109
100div#sidebar div.infobox { 110div#logo {
101 margin: 0px 0px 0px 0px; 111 margin: 0px;
102 padding: 0.5em; 112 padding: 4px 0px 4px 0px;
103 text-align: left; 113 text-align: center;
104 background-color: #ccc; 114 background-color: #ccc;
105 border-top: solid 1px #eee; 115 border-top: solid 1px #eee;
106 border-left: solid 1px #eee; 116 border-left: solid 1px #eee;
@@ -108,50 +118,44 @@ div#sidebar div.infobox {
108 border-bottom: solid 1px #aaa; 118 border-bottom: solid 1px #aaa;
109} 119}
110 120
111div#sidebar div.infobox h1 { 121td#sidebar h1 {
112 font-size: 11pt; 122 font-size: 10pt;
113 font-weight: bold; 123 font-weight: bold;
114 margin: 0px; 124 margin: 8px 0px 0px 0px;
115} 125}
116 126
117div#sidebar div.infobox a.menu { 127td#sidebar h1.first {
128 margin-top: 0px;
129}
130
131td#sidebar a.menu {
118 display: block; 132 display: block;
119 background-color: #ccc; 133 background-color: #ccc;
120 padding: 0.1em 0.5em; 134 padding: 0.1em 0.5em;
121 text-decoration: none; 135 text-decoration: none;
122} 136}
123 137
124div#sidebar div.infobox a.menu:hover { 138td#sidebar a.menu:hover {
125 background-color: #bbb; 139 background-color: #bbb;
126 text-decoration: none; 140 text-decoration: none;
127} 141}
128 142
129div#sidebar div.infobox select { 143td#sidebar select {
130 width: 100%; 144 width: 100%;
131 border: solid 1px #aaa;
132 background-color: #bbb;
133 margin: 2px 0px 0px 0px; 145 margin: 2px 0px 0px 0px;
134 padding: 0px;
135} 146}
136 147
137td#branch-dropdown-cell { 148td#sidebar form {
138 width: 99%; 149 text-align: right;
139} 150}
140 151
141input#switch-btn { 152input#switch-btn {
142 width: 20px;
143 border: solid 1px #aaa;
144 background-color: #bbb;
145 margin: 2px 0px 0px 0px; 153 margin: 2px 0px 0px 0px;
146 padding: 0px;
147} 154}
148 155
149div#sidebar div.infobox input.txt { 156td#sidebar input.txt {
150 width: 100%; 157 width: 100%;
151 border: solid 1px #aaa;
152 background-color: #bbb;
153 margin: 2px 0px 0px 0px; 158 margin: 2px 0px 0px 0px;
154 padding: 0;
155} 159}
156 160
157table#grid { 161table#grid {
diff --git a/cgit.h b/cgit.h
index 163f355..ab0efeb 100644
--- a/cgit.h
+++ b/cgit.h
@@ -16,6 +16,7 @@
16#include <log-tree.h> 16#include <log-tree.h>
17#include <archive.h> 17#include <archive.h>
18#include <xdiff/xdiff.h> 18#include <xdiff/xdiff.h>
19#include <utf8.h>
19 20
20 21
21/* 22/*
@@ -48,6 +49,11 @@
48#define TM_MONTH (TM_YEAR / 12.0) 49#define TM_MONTH (TM_YEAR / 12.0)
49 50
50 51
52/*
53 * Default encoding
54 */
55#define PAGE_ENCODING "UTF-8"
56
51typedef void (*configfn)(const char *name, const char *value); 57typedef void (*configfn)(const char *name, const char *value);
52typedef void (*filepair_fn)(struct diff_filepair *pair); 58typedef void (*filepair_fn)(struct diff_filepair *pair);
53typedef void (*linediff_fn)(char *line, int len); 59typedef void (*linediff_fn)(char *line, int len);
@@ -90,6 +96,7 @@ struct commitinfo {
90 unsigned long committer_date; 96 unsigned long committer_date;
91 char *subject; 97 char *subject;
92 char *msg; 98 char *msg;
99 char *msg_encoding;
93}; 100};
94 101
95struct taginfo { 102struct taginfo {
@@ -132,6 +139,7 @@ extern char *cgit_virtual_root;
132extern char *cgit_script_name; 139extern char *cgit_script_name;
133extern char *cgit_cache_root; 140extern char *cgit_cache_root;
134extern char *cgit_repo_group; 141extern char *cgit_repo_group;
142extern char *cgit_robots;
135 143
136extern int cgit_nocache; 144extern int cgit_nocache;
137extern int cgit_snapshots; 145extern int cgit_snapshots;
diff --git a/cgit.png b/cgit.png
index ee48197..22f7e95 100644
--- a/cgit.png
+++ b/cgit.png
Binary files differ
diff --git a/cgitrc b/cgitrc
index 6363c9c..8c616e0 100644
--- a/cgitrc
+++ b/cgitrc
@@ -8,6 +8,11 @@
8#nocache=0 8#nocache=0
9 9
10 10
11## This variable can be used to override the default value for "robots"
12## meta-tag. If unset, the meta-tag isn't generated.
13#robots=index, nofollow
14
15
11## Set allowed snapshot types by default. Can be overridden per repo 16## Set allowed snapshot types by default. Can be overridden per repo
12# can be any combination of zip/tar.gz/tar.bz2/tar 17# can be any combination of zip/tar.gz/tar.bz2/tar
13#snapshots=0 18#snapshots=0
diff --git a/html.c b/html.c
index 6c9cc8b..eb163d9 100644
--- a/html.c
+++ b/html.c
@@ -132,7 +132,7 @@ void html_option(char *value, char *text, char *selected_value)
132 html_attr(value); 132 html_attr(value);
133 html("'"); 133 html("'");
134 if (selected_value && !strcmp(selected_value, value)) 134 if (selected_value && !strcmp(selected_value, value))
135 html(" selected"); 135 html(" selected='selected'");
136 html(">"); 136 html(">");
137 html_txt(text); 137 html_txt(text);
138 html("</option>\n"); 138 html("</option>\n");
diff --git a/parsing.c b/parsing.c
index 55a485d..5093b8b 100644
--- a/parsing.c
+++ b/parsing.c
@@ -199,6 +199,7 @@ struct commitinfo *cgit_parse_commit(struct commit *commit)
199 ret->committer_email = NULL; 199 ret->committer_email = NULL;
200 ret->subject = NULL; 200 ret->subject = NULL;
201 ret->msg = NULL; 201 ret->msg = NULL;
202 ret->msg_encoding = NULL;
202 203
203 if (p == NULL) 204 if (p == NULL)
204 return ret; 205 return ret;
@@ -233,6 +234,14 @@ struct commitinfo *cgit_parse_commit(struct commit *commit)
233 p = strchr(t, '\n') + 1; 234 p = strchr(t, '\n') + 1;
234 } 235 }
235 236
237 if (!strncmp(p, "encoding ", 9)) {
238 p += 9;
239 t = strchr(p, '\n') + 1;
240 ret->msg_encoding = substr(p, t);
241 p = t;
242 } else
243 ret->msg_encoding = xstrdup(PAGE_ENCODING);
244
236 while (*p && (*p != '\n')) 245 while (*p && (*p != '\n'))
237 p = strchr(p, '\n') + 1; // skip unknown header fields 246 p = strchr(p, '\n') + 1; // skip unknown header fields
238 247
@@ -253,6 +262,22 @@ struct commitinfo *cgit_parse_commit(struct commit *commit)
253 } else 262 } else
254 ret->subject = substr(p, p+strlen(p)); 263 ret->subject = substr(p, p+strlen(p));
255 264
265 if(strcmp(ret->msg_encoding, PAGE_ENCODING)) {
266 t = reencode_string(ret->subject, PAGE_ENCODING,
267 ret->msg_encoding);
268 if(t) {
269 free(ret->subject);
270 ret->subject = t;
271 }
272
273 t = reencode_string(ret->msg, PAGE_ENCODING,
274 ret->msg_encoding);
275 if(t) {
276 free(ret->msg);
277 ret->msg = t;
278 }
279 }
280
256 return ret; 281 return ret;
257} 282}
258 283
diff --git a/shared.c b/shared.c
index 6117f5c..fd8b1e3 100644
--- a/shared.c
+++ b/shared.c
@@ -26,6 +26,7 @@ char *cgit_virtual_root = NULL;
26char *cgit_script_name = CGIT_SCRIPT_NAME; 26char *cgit_script_name = CGIT_SCRIPT_NAME;
27char *cgit_cache_root = CGIT_CACHE_ROOT; 27char *cgit_cache_root = CGIT_CACHE_ROOT;
28char *cgit_repo_group = NULL; 28char *cgit_repo_group = NULL;
29char *cgit_robots = "index, nofollow";
29 30
30int cgit_nocache = 0; 31int cgit_nocache = 0;
31int cgit_snapshots = 0; 32int cgit_snapshots = 0;
@@ -197,6 +198,8 @@ void cgit_global_config_cb(const char *name, const char *value)
197 cgit_agefile = xstrdup(value); 198 cgit_agefile = xstrdup(value);
198 else if (!strcmp(name, "renamelimit")) 199 else if (!strcmp(name, "renamelimit"))
199 cgit_renamelimit = atoi(value); 200 cgit_renamelimit = atoi(value);
201 else if (!strcmp(name, "robots"))
202 cgit_robots = xstrdup(value);
200 else if (!strcmp(name, "repo.group")) 203 else if (!strcmp(name, "repo.group"))
201 cgit_repo_group = xstrdup(value); 204 cgit_repo_group = xstrdup(value);
202 else if (!strcmp(name, "repo.url")) 205 else if (!strcmp(name, "repo.url"))
@@ -267,6 +270,8 @@ void *cgit_free_commitinfo(struct commitinfo *info)
267 free(info->committer); 270 free(info->committer);
268 free(info->committer_email); 271 free(info->committer_email);
269 free(info->subject); 272 free(info->subject);
273 free(info->msg);
274 free(info->msg_encoding);
270 free(info); 275 free(info);
271 return NULL; 276 return NULL;
272} 277}
diff --git a/tests/.gitignore b/tests/.gitignore
new file mode 100644
index 0000000..c1c1c0b
--- /dev/null
+++ b/tests/.gitignore
@@ -0,0 +1,2 @@
1trash
2test-output.log
diff --git a/tests/Makefile b/tests/Makefile
new file mode 100644
index 0000000..697e5a1
--- /dev/null
+++ b/tests/Makefile
@@ -0,0 +1,13 @@
1
2
3T = $(wildcard t[0-9][0-9][0-9][0-9]-*.sh)
4
5all: $(T)
6
7$(T):
8 @$@
9
10clean:
11 $(RM) -rf trash
12
13.PHONY: $(T) clean
diff --git a/tests/setup.sh b/tests/setup.sh
new file mode 100755
index 0000000..51d5a75
--- /dev/null
+++ b/tests/setup.sh
@@ -0,0 +1,108 @@
1# This file should be sourced by all test-scripts
2#
3# Main functions:
4# prepare_tests(description) - setup for testing, i.e. create repos+config
5# run_test(description, script) - run one test, i.e. eval script
6#
7# Helper functions
8# cgit_query(querystring) - call cgit with the specified querystring
9# cgit_url(url) - call cgit with the specified virtual url
10#
11# Example script:
12#
13# . setup.sh
14# prepare_tests "html validation"
15# run_test 'repo index' 'cgit_url "/" | tidy -e'
16# run_test 'repo summary' 'cgit_url "/foo" | tidy -e'
17
18
19mkrepo() {
20 name=$1
21 count=$2
22 dir=$PWD
23 test -d $name && return
24 printf "Creating testrepo %s\n" $name
25 mkdir -p $name
26 cd $name
27 git init
28 for ((n=1; n<=count; n++))
29 do
30 echo $n >file-$n
31 git add file-$n
32 git commit -m "commit $n"
33 done
34 cd $dir
35}
36
37setup_repos()
38{
39 rm -rf trash/cache
40 mkdir -p trash/cache
41 mkrepo trash/repos/foo 5 >/dev/null
42 mkrepo trash/repos/bar 50 >/dev/null
43 cat >trash/cgitrc <<EOF
44virtual-root=/
45cache-root=$PWD/trash/cache
46
47nocache=0
48snapshots=tar.gz tar.bz zip
49enable-log-filecount=1
50enable-log-linecount=1
51summary-log=5
52summary-branches=5
53summary-tags=5
54
55repo.url=foo
56repo.path=$PWD/trash/repos/foo/.git
57repo.desc=the foo repo
58
59repo.url=bar
60repo.path=$PWD/trash/repos/bar/.git
61repo.desc=the bar repo
62EOF
63}
64
65prepare_tests()
66{
67 setup_repos
68 test_count=0
69 test_failed=0
70 echo "$@" "($0)"
71}
72
73tests_done()
74{
75 printf "\n"
76 if test $test_failed -gt 0
77 then
78 printf "[%s of %s tests failed]\n" $test_failed $test_count
79 false
80 fi
81}
82
83run_test()
84{
85 desc=$1
86 script=$2
87 ((test_count++))
88 eval "$2" >test-output.log
89 res=$?
90 if test $res = 0
91 then
92 printf " %s: ok - %s\n" $test_count "$desc"
93 else
94 ((test_failed++))
95 printf " %s: fail - %s\n" $test_count "$desc"
96 fi
97}
98
99cgit_query()
100{
101 CGIT_CONFIG="$PWD/trash/cgitrc" QUERY_STRING="$1" "$PWD/../cgit"
102}
103
104cgit_url()
105{
106 CGIT_CONFIG="$PWD/trash/cgitrc" QUERY_STRING="url=$1" "$PWD/../cgit"
107}
108
diff --git a/tests/t0010-validate-html.sh b/tests/t0010-validate-html.sh
new file mode 100755
index 0000000..907a415
--- /dev/null
+++ b/tests/t0010-validate-html.sh
@@ -0,0 +1,31 @@
1#!/bin/sh
2
3. ./setup.sh
4
5
6test_url()
7{
8 tidy_opt="-eq"
9 test -z "$NO_TIDY_WARNINGS" || tidy_opt+=" --show-warnings no"
10 cgit_url "$1" | sed -e "1,4d" >trash/tidy-$test_count
11 tidy $tidy_opt trash/tidy-$test_count
12 rc=$?
13 if test $rc = 2
14 then
15 false
16 else
17 :
18 fi
19}
20
21prepare_tests 'Validate html with tidy'
22
23run_test 'index page' 'test_url ""'
24run_test 'foo' 'test_url "foo"'
25run_test 'foo/log' 'test_url "foo/log"'
26run_test 'foo/tree' 'test_url "foo/tree"'
27run_test 'foo/tree/file-1' 'test_url "foo/tree/file-1"'
28run_test 'foo/commit' 'test_url "foo/commit"'
29run_test 'foo/diff' 'test_url "foo/diff"'
30
31tests_done
diff --git a/tests/t0101-index.sh b/tests/t0101-index.sh
new file mode 100755
index 0000000..12ed00c
--- /dev/null
+++ b/tests/t0101-index.sh
@@ -0,0 +1,13 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on index page"
6
7run_test 'generate index page' 'cgit_url "" >trash/tmp'
8run_test 'find foo repo' 'grep -e "foo" trash/tmp'
9run_test 'find bar repo' 'grep -e "bar" trash/tmp'
10run_test 'no tree-link' 'grep -ve "foo/tree" trash/tmp'
11run_test 'no log-link' 'grep -ve "foo/log" trash/tmp'
12
13tests_done
diff --git a/tests/t0102-summary.sh b/tests/t0102-summary.sh
new file mode 100755
index 0000000..7edd675
--- /dev/null
+++ b/tests/t0102-summary.sh
@@ -0,0 +1,20 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on summary page"
6
7run_test 'generate foo summary' 'cgit_url "foo" >trash/tmp'
8run_test 'find commit 1' 'grep -e "commit 1" trash/tmp'
9run_test 'find commit 5' 'grep -e "commit 5" trash/tmp'
10run_test 'find branch master' 'grep -e "master" trash/tmp'
11run_test 'no tags' 'grep -ve "tags" trash/tmp'
12
13run_test 'generate bar summary' 'cgit_url "bar" >trash/tmp'
14run_test 'no commit 45' 'grep -ve "commit 45" trash/tmp'
15run_test 'find commit 46' 'grep -e "commit 46" trash/tmp'
16run_test 'find commit 50' 'grep -e "commit 50" trash/tmp'
17run_test 'find branch master' 'grep -e "master" trash/tmp'
18run_test 'no tags' 'grep -ve "tags" trash/tmp'
19
20tests_done
diff --git a/tests/t0103-log.sh b/tests/t0103-log.sh
new file mode 100755
index 0000000..b08cd29
--- /dev/null
+++ b/tests/t0103-log.sh
@@ -0,0 +1,15 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on log page"
6
7run_test 'generate foo/log' 'cgit_url "foo/log" >trash/tmp'
8run_test 'find commit 1' 'grep -e "commit 1" trash/tmp'
9run_test 'find commit 5' 'grep -e "commit 5" trash/tmp'
10
11run_test 'generate bar/log' 'cgit_url "bar/log" >trash/tmp'
12run_test 'find commit 1' 'grep -e "commit 1" trash/tmp'
13run_test 'find commit 50' 'grep -e "commit 50" trash/tmp'
14
15tests_done
diff --git a/tests/t0104-tree.sh b/tests/t0104-tree.sh
new file mode 100755
index 0000000..2516c72
--- /dev/null
+++ b/tests/t0104-tree.sh
@@ -0,0 +1,21 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on tree page"
6
7run_test 'generate bar/tree' 'cgit_url "bar/tree" >trash/tmp'
8run_test 'find file-1' 'grep -e "file-1" trash/tmp'
9run_test 'find file-50' 'grep -e "file-50" trash/tmp'
10
11run_test 'generate bar/tree/file-50' 'cgit_url "bar/tree/file-50" >trash/tmp'
12
13run_test 'find line 1' '
14 grep -e "<a id=.n1. name=.n1. href=.#n1.>1</a>" trash/tmp
15'
16
17run_test 'no line 2' '
18 grep -e "<a id=.n2. name=.n2. href=.#n2.>2</a>" trash/tmp
19'
20
21tests_done
diff --git a/tests/t0105-commit.sh b/tests/t0105-commit.sh
new file mode 100755
index 0000000..aa2bf33
--- /dev/null
+++ b/tests/t0105-commit.sh
@@ -0,0 +1,22 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on commit page"
6
7run_test 'generate foo/commit' 'cgit_url "foo/commit" >trash/tmp'
8run_test 'find tree link' 'grep -e "<a href=./foo/tree/.>" trash/tmp'
9run_test 'find parent link' 'grep -E "<a href=./foo/commit/\?id=.+>" trash/tmp'
10
11run_test 'find commit subject' '
12 grep -e "<div class=.commit-subject.>commit 5</div>" trash/tmp
13'
14
15run_test 'find commit msg' 'grep -e "<div class=.commit-msg.></div>" trash/tmp'
16run_test 'find diffstat' 'grep -e "<table summary=.diffstat. class=.diffstat.>" trash/tmp'
17
18run_test 'find diff summary' '
19 grep -e "1 files changed, 1 insertions, 0 deletions" trash/tmp
20'
21
22tests_done
diff --git a/tests/t0106-diff.sh b/tests/t0106-diff.sh
new file mode 100755
index 0000000..e140bcc
--- /dev/null
+++ b/tests/t0106-diff.sh
@@ -0,0 +1,20 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Check content on diff page"
6
7run_test 'generate foo/diff' 'cgit_url "foo/diff" >trash/tmp'
8run_test 'find diff header' 'grep -e "a/file-5 b/file-5" trash/tmp'
9run_test 'find blob link' 'grep -e "<a href=./foo/tree/file-5?id=" trash/tmp'
10run_test 'find added file' 'grep -e "new file mode 100644" trash/tmp'
11
12run_test 'find hunk header' '
13 grep -e "<div class=.hunk.>@@ -0,0 +1 @@</div>" trash/tmp
14'
15
16run_test 'find added line' '
17 grep -e "<div class=.add.>+5</div>" trash/tmp
18'
19
20tests_done
diff --git a/tests/t0107-snapshot.sh b/tests/t0107-snapshot.sh
new file mode 100755
index 0000000..8e90e10
--- /dev/null
+++ b/tests/t0107-snapshot.sh
@@ -0,0 +1,36 @@
1#!/bin/sh
2
3. ./setup.sh
4
5prepare_tests "Verify snapshot"
6
7run_test 'get foo/snapshot/test.tar.gz' '
8 cgit_url "foo/snapshot/test.tar.gz" >trash/tmp
9'
10
11run_test 'check html headers' '
12 head -n 1 trash/tmp |
13 grep -e "Content-Type: application/x-tar" &&
14
15 head -n 2 trash/tmp |
16 grep -e "Content-Disposition: inline; filename=.test.tar.gz."
17'
18
19run_test 'strip off the header lines' '
20 tail -n +6 trash/tmp > trash/test.tar.gz
21'
22
23run_test 'verify gzip format' 'gunzip --test trash/test.tar.gz'
24run_test 'untar' 'tar -xf trash/test.tar.gz -C trash'
25
26run_test 'count files' '
27 c=$(ls -1 trash/foo/ | wc -l) &&
28 test $c = 5
29'
30
31run_test 'verify untarred file-5' '
32 grep -e "^5$" trash/foo/file-5 &&
33 test $(cat trash/foo/file-5 | wc -l) = 1
34'
35
36tests_done
diff --git a/ui-commit.c b/ui-commit.c
index 4ac8955..bd55a33 100644
--- a/ui-commit.c
+++ b/ui-commit.c
@@ -84,7 +84,7 @@ void print_fileinfo(struct fileinfo *info)
84 html("</td><td class='right'>"); 84 html("</td><td class='right'>");
85 htmlf("%d", info->added + info->removed); 85 htmlf("%d", info->added + info->removed);
86 html("</td><td class='graph'>"); 86 html("</td><td class='graph'>");
87 htmlf("<table width='%d%%'><tr>", (max_changes > 100 ? 100 : max_changes)); 87 htmlf("<table summary='file diffstat' width='%d%%'><tr>", (max_changes > 100 ? 100 : max_changes));
88 htmlf("<td class='add' style='width: %.1f%%;'/>", 88 htmlf("<td class='add' style='width: %.1f%%;'/>",
89 info->added * 100.0 / max_changes); 89 info->added * 100.0 / max_changes);
90 htmlf("<td class='rem' style='width: %.1f%%;'/>", 90 htmlf("<td class='rem' style='width: %.1f%%;'/>",
@@ -157,7 +157,7 @@ void cgit_print_commit(char *hex)
157 } 157 }
158 info = cgit_parse_commit(commit); 158 info = cgit_parse_commit(commit);
159 159
160 html("<table class='commit-info'>\n"); 160 html("<table summary='commit info' class='commit-info'>\n");
161 html("<tr><th>author</th><td>"); 161 html("<tr><th>author</th><td>");
162 html_txt(info->author); 162 html_txt(info->author);
163 html(" "); 163 html(" ");
@@ -209,7 +209,7 @@ void cgit_print_commit(char *hex)
209 html("</div>"); 209 html("</div>");
210 if (!(commit->parents && commit->parents->next && commit->parents->next->next)) { 210 if (!(commit->parents && commit->parents->next && commit->parents->next->next)) {
211 html("<div class='diffstat-header'>Diffstat</div>"); 211 html("<div class='diffstat-header'>Diffstat</div>");
212 html("<table class='diffstat'>"); 212 html("<table summary='diffstat' class='diffstat'>");
213 max_changes = 0; 213 max_changes = 0;
214 cgit_diff_commit(commit, inspect_filepair); 214 cgit_diff_commit(commit, inspect_filepair);
215 for(i = 0; i<files; i++) 215 for(i = 0; i<files; i++)
diff --git a/ui-diff.c b/ui-diff.c
index ac9a3fa..4fcf852 100644
--- a/ui-diff.c
+++ b/ui-diff.c
@@ -141,7 +141,7 @@ void cgit_print_diff(const char *new_rev, const char *old_rev, const char *prefi
141 if (!commit2 || parse_commit(commit2)) 141 if (!commit2 || parse_commit(commit2))
142 cgit_print_error(fmt("Bad commit: %s", sha1_to_hex(old_rev_sha1))); 142 cgit_print_error(fmt("Bad commit: %s", sha1_to_hex(old_rev_sha1)));
143 } 143 }
144 html("<table class='diff'>"); 144 html("<table summary='diff' class='diff'>");
145 html("<tr><td>"); 145 html("<tr><td>");
146 cgit_diff_tree(old_rev_sha1, new_rev_sha1, filepair_cb, prefix); 146 cgit_diff_tree(old_rev_sha1, new_rev_sha1, filepair_cb, prefix);
147 html("</td></tr>"); 147 html("</td></tr>");
diff --git a/ui-log.c b/ui-log.c
index 9f5fdf6..a41d2b2 100644
--- a/ui-log.c
+++ b/ui-log.c
@@ -8,12 +8,18 @@
8 8
9#include "cgit.h" 9#include "cgit.h"
10 10
11int files, lines; 11int files, add_lines, rem_lines;
12 12
13void count_lines(char *line, int size) 13void count_lines(char *line, int size)
14{ 14{
15 if (size>0 && (line[0] == '+' || line[0] == '-')) 15 if (size <= 0)
16 lines++; 16 return;
17
18 if (line[0] == '+')
19 add_lines++;
20
21 else if (line[0] == '-')
22 rem_lines++;
17} 23}
18 24
19void inspect_files(struct diff_filepair *pair) 25void inspect_files(struct diff_filepair *pair)
@@ -35,13 +41,14 @@ void print_commit(struct commit *commit)
35 sha1_to_hex(commit->object.sha1)); 41 sha1_to_hex(commit->object.sha1));
36 if (cgit_repo->enable_log_filecount) { 42 if (cgit_repo->enable_log_filecount) {
37 files = 0; 43 files = 0;
38 lines = 0; 44 add_lines = 0;
45 rem_lines = 0;
39 cgit_diff_commit(commit, inspect_files); 46 cgit_diff_commit(commit, inspect_files);
40 html("</td><td class='right'>"); 47 html("</td><td class='right'>");
41 htmlf("%d", files); 48 htmlf("%d", files);
42 if (cgit_repo->enable_log_linecount) { 49 if (cgit_repo->enable_log_linecount) {
43 html("</td><td class='right'>"); 50 html("</td><td class='right'>");
44 htmlf("%d", lines); 51 htmlf("-%d/+%d", rem_lines, add_lines);
45 } 52 }
46 } 53 }
47 html("</td><td>"); 54 html("</td><td>");
@@ -83,14 +90,14 @@ void cgit_print_log(const char *tip, int ofs, int cnt, char *grep, char *pattern
83 } 90 }
84 prepare_revision_walk(&rev); 91 prepare_revision_walk(&rev);
85 92
86 html("<table class='list nowrap'>"); 93 html("<table summary='log' class='list nowrap'>");
87 html("<tr class='nohover'><th class='left'>Age</th>" 94 html("<tr class='nohover'><th class='left'>Age</th>"
88 "<th class='left'>Message</th>"); 95 "<th class='left'>Message</th>");
89 96
90 if (cgit_repo->enable_log_filecount) { 97 if (cgit_repo->enable_log_filecount) {
91 html("<th class='left'>Files</th>"); 98 html("<th class='right'>Files</th>");
92 if (cgit_repo->enable_log_linecount) 99 if (cgit_repo->enable_log_linecount)
93 html("<th class='left'>Lines</th>"); 100 html("<th class='right'>Lines</th>");
94 } 101 }
95 html("<th class='left'>Author</th></tr>\n"); 102 html("<th class='left'>Author</th></tr>\n");
96 103
diff --git a/ui-repolist.c b/ui-repolist.c
index 9aa5c1e..3e97ca9 100644
--- a/ui-repolist.c
+++ b/ui-repolist.c
@@ -53,7 +53,7 @@ void cgit_print_repolist(struct cacheitem *item)
53 cgit_print_docstart(cgit_root_title, item); 53 cgit_print_docstart(cgit_root_title, item);
54 cgit_print_pageheader(cgit_root_title, 0); 54 cgit_print_pageheader(cgit_root_title, 0);
55 55
56 html("<table class='list nowrap'>"); 56 html("<table summary='repository list' class='list nowrap'>");
57 if (cgit_index_header) { 57 if (cgit_index_header) {
58 htmlf("<tr class='nohover'><td colspan='%d' class='include-block'>", 58 htmlf("<tr class='nohover'><td colspan='%d' class='include-block'>",
59 columns); 59 columns);
diff --git a/ui-shared.c b/ui-shared.c
index 4944dfd..3e13c86 100644
--- a/ui-shared.c
+++ b/ui-shared.c
@@ -356,18 +356,20 @@ void cgit_print_age(time_t t, time_t max_relative, char *format)
356 356
357void cgit_print_docstart(char *title, struct cacheitem *item) 357void cgit_print_docstart(char *title, struct cacheitem *item)
358{ 358{
359 html("Content-Type: text/html; charset=utf-8\n"); 359 html("Content-Type: text/html; charset=" PAGE_ENCODING "\n");
360 htmlf("Last-Modified: %s\n", http_date(item->st.st_mtime)); 360 htmlf("Last-Modified: %s\n", http_date(item->st.st_mtime));
361 htmlf("Expires: %s\n", http_date(item->st.st_mtime + 361 htmlf("Expires: %s\n", http_date(item->st.st_mtime +
362 ttl_seconds(item->ttl))); 362 ttl_seconds(item->ttl)));
363 html("\n"); 363 html("\n");
364 html(cgit_doctype); 364 html(cgit_doctype);
365 html("<html>\n"); 365 html("<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>\n");
366 html("<head>\n"); 366 html("<head>\n");
367 html("<title>"); 367 html("<title>");
368 html_txt(title); 368 html_txt(title);
369 html("</title>\n"); 369 html("</title>\n");
370 htmlf("<meta name='generator' content='cgit %s'/>\n", cgit_version); 370 htmlf("<meta name='generator' content='cgit %s'/>\n", cgit_version);
371 if (cgit_robots && *cgit_robots)
372 htmlf("<meta name='robots' content='%s'/>\n", cgit_robots);
371 html("<link rel='stylesheet' type='text/css' href='"); 373 html("<link rel='stylesheet' type='text/css' href='");
372 html_attr(cgit_css); 374 html_attr(cgit_css);
373 html("'/>\n"); 375 html("'/>\n");
@@ -377,7 +379,7 @@ void cgit_print_docstart(char *title, struct cacheitem *item)
377 379
378void cgit_print_docend() 380void cgit_print_docend()
379{ 381{
380 html("</td>\n</tr>\n<table>\n</body>\n</html>\n"); 382 html("</td>\n</tr>\n</table>\n</body>\n</html>\n");
381} 383}
382 384
383int print_branch_option(const char *refname, const unsigned char *sha1, 385int print_branch_option(const char *refname, const unsigned char *sha1,
@@ -415,7 +417,7 @@ int print_archive_ref(const char *refname, const unsigned char *sha1,
415 hashcpy(fileid, sha1); 417 hashcpy(fileid, sha1);
416 } 418 }
417 if (!*header) { 419 if (!*header) {
418 html("<p><h1>download</h1>"); 420 html("<h1>download</h1>\n");
419 *header = 1; 421 *header = 1;
420 } 422 }
421 url = cgit_pageurl(cgit_query_repo, "blob", 423 url = cgit_pageurl(cgit_query_repo, "blob",
@@ -459,22 +461,24 @@ void cgit_print_pageheader(char *title, int show_search)
459 static const char *default_info = "This is cgit, a fast webinterface for git repositories"; 461 static const char *default_info = "This is cgit, a fast webinterface for git repositories";
460 int header = 0; 462 int header = 0;
461 463
462 html("<div id='sidebar'>\n"); 464 html("<table id='layout' summary=''>\n");
463 html("<a href='"); 465 html("<tr><td id='sidebar'>\n");
466 html("<table class='sidebar' cellspacing='0' summary=''>\n");
467 html("<tr><td class='sidebar'>\n<a href='");
464 html_attr(cgit_rooturl()); 468 html_attr(cgit_rooturl());
465 htmlf("'><div id='logo'><img src='%s' alt='cgit'/></div></a>\n", 469 htmlf("'><img src='%s' alt='cgit'/></a>\n",
466 cgit_logo); 470 cgit_logo);
467 html("<div class='infobox'>"); 471 html("</td></tr>\n<tr><td class='sidebar'>\n");
468 if (cgit_query_repo) { 472 if (cgit_query_repo) {
469 html("<h1>"); 473 html("<h1 class='first'>");
470 html_txt(strrpart(cgit_repo->name, 20)); 474 html_txt(strrpart(cgit_repo->name, 20));
471 html("</h1>\n"); 475 html("</h1>\n");
472 html_txt(cgit_repo->desc); 476 html_txt(cgit_repo->desc);
473 if (cgit_repo->owner) { 477 if (cgit_repo->owner) {
474 html("<p>\n<h1>owner</h1>\n"); 478 html("<h1>owner</h1>\n");
475 html_txt(cgit_repo->owner); 479 html_txt(cgit_repo->owner);
476 } 480 }
477 html("<p>\n<h1>navigate</h1>\n"); 481 html("<h1>navigate</h1>\n");
478 reporevlink(NULL, "summary", NULL, "menu", cgit_query_head, 482 reporevlink(NULL, "summary", NULL, "menu", cgit_query_head,
479 NULL, NULL); 483 NULL, NULL);
480 cgit_log_link("log", NULL, "menu", cgit_query_head, NULL, NULL, 484 cgit_log_link("log", NULL, "menu", cgit_query_head, NULL, NULL,
@@ -488,19 +492,19 @@ void cgit_print_pageheader(char *title, int show_search)
488 492
489 for_each_ref(print_archive_ref, &header); 493 for_each_ref(print_archive_ref, &header);
490 494
491 html("<p>\n<h1>branch</h1>\n"); 495 html("<h1>branch</h1>\n");
492 html("<form method='get' action=''>\n"); 496 html("<form method='get' action=''>\n");
493 add_hidden_formfields(0, 1, cgit_query_page); 497 add_hidden_formfields(0, 1, cgit_query_page);
494 html("<table class='grid'><tr><td id='branch-dropdown-cell'>"); 498// html("<table summary='branch selector' class='grid'><tr><td id='branch-dropdown-cell'>");
495 html("<select name='h' onchange='this.form.submit();'>\n"); 499 html("<select name='h' onchange='this.form.submit();'>\n");
496 for_each_branch_ref(print_branch_option, cgit_query_head); 500 for_each_branch_ref(print_branch_option, cgit_query_head);
497 html("</select>\n"); 501 html("</select>\n");
498 html("</td><td>"); 502// html("</td><td>");
499 html("<noscript><input type='submit' id='switch-btn' value='..'></noscript>\n"); 503 html("<noscript><input type='submit' id='switch-btn' value='switch'/></noscript>\n");
500 html("</td></tr></table>"); 504// html("</td></tr></table>");
501 html("</form>\n"); 505 html("</form>\n");
502 506
503 html("<p>\n<h1>search</h1>\n"); 507 html("<h1>search</h1>\n");
504 html("<form method='get' action='"); 508 html("<form method='get' action='");
505 if (cgit_virtual_root) 509 if (cgit_virtual_root)
506 html_attr(cgit_fileurl(cgit_query_repo, "log", 510 html_attr(cgit_fileurl(cgit_query_repo, "log",
@@ -521,9 +525,9 @@ void cgit_print_pageheader(char *title, int show_search)
521 html(default_info); 525 html(default_info);
522 } 526 }
523 527
524 html("</div>\n"); 528 html("</td></tr></table></td>\n");
525 529
526 html("</div>\n<table class='grid'><tr><td id='content'>\n"); 530 html("<td id='content'>\n");
527} 531}
528 532
529 533
diff --git a/ui-summary.c b/ui-summary.c
index c856793..b96414e 100644
--- a/ui-summary.c
+++ b/ui-summary.c
@@ -190,7 +190,7 @@ void cgit_print_summary()
190 if (cgit_summary_log > 0) 190 if (cgit_summary_log > 0)
191 cgit_print_log(cgit_query_head, 0, cgit_summary_log, NULL, 191 cgit_print_log(cgit_query_head, 0, cgit_summary_log, NULL,
192 NULL, NULL, 0); 192 NULL, NULL, 0);
193 html("<table class='list nowrap'>"); 193 html("<table summary='repository info' class='list nowrap'>");
194 if (cgit_summary_log > 0) 194 if (cgit_summary_log > 0)
195 html("<tr class='nohover'><td colspan='4'>&nbsp;</td></tr>"); 195 html("<tr class='nohover'><td colspan='4'>&nbsp;</td></tr>");
196 cgit_print_branches(cgit_summary_branches); 196 cgit_print_branches(cgit_summary_branches);
diff --git a/ui-tree.c b/ui-tree.c
index c22e30b..c138877 100644
--- a/ui-tree.c
+++ b/ui-tree.c
@@ -17,7 +17,7 @@ static void print_object(const unsigned char *sha1, char *path)
17 enum object_type type; 17 enum object_type type;
18 char *buf; 18 char *buf;
19 unsigned long size, lineno, start, idx; 19 unsigned long size, lineno, start, idx;
20 const char *linefmt = "<tr><td class='no'><a name='%1$d'>%1$d</a></td><td class='txt'>"; 20 const char *linefmt = "<tr><td class='no'><a id='n%1$d' name='n%1$d' href='#n%1$d'>%1$d</a></td><td class='txt'>";
21 21
22 type = sha1_object_info(sha1, &size); 22 type = sha1_object_info(sha1, &size);
23 if (type == OBJ_BAD) { 23 if (type == OBJ_BAD) {
@@ -37,7 +37,7 @@ static void print_object(const unsigned char *sha1, char *path)
37 html_attr(cgit_pageurl(cgit_query_repo, "blob", fmt("id=%s", sha1_to_hex(sha1)))); 37 html_attr(cgit_pageurl(cgit_query_repo, "blob", fmt("id=%s", sha1_to_hex(sha1))));
38 htmlf("'>%s</a>",sha1_to_hex(sha1)); 38 htmlf("'>%s</a>",sha1_to_hex(sha1));
39 39
40 html("<table class='blob'>\n"); 40 html("<table summary='blob content' class='blob'>\n");
41 idx = 0; 41 idx = 0;
42 start = 0; 42 start = 0;
43 lineno = 0; 43 lineno = 0;
@@ -108,7 +108,7 @@ static int ls_item(const unsigned char *sha1, const char *base, int baselen,
108 108
109static void ls_head() 109static void ls_head()
110{ 110{
111 html("<table class='list'>\n"); 111 html("<table summary='tree listing' class='list'>\n");
112 html("<tr class='nohover'>"); 112 html("<tr class='nohover'>");
113 html("<th class='left'>Mode</th>"); 113 html("<th class='left'>Mode</th>");
114 html("<th class='left'>Name</th>"); 114 html("<th class='left'>Name</th>");