aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/.gitignore5
-rw-r--r--debian/README.Debian22
-rw-r--r--debian/README.source16
-rw-r--r--debian/cgit.dirs2
-rw-r--r--debian/cgit.docs3
-rw-r--r--debian/cgit.examples2
-rw-r--r--debian/cgit.lintian-overrides8
-rw-r--r--debian/cgit.postinst43
-rw-r--r--debian/cgit.postrm44
-rw-r--r--debian/changelog27
-rw-r--r--debian/compat1
-rw-r--r--debian/control41
-rw-r--r--debian/copyright421
-rw-r--r--debian/examples/apache2.conf15
-rw-r--r--debian/examples/cgitrc70
-rw-r--r--debian/gbp.conf4
-rw-r--r--debian/patches/0001-make-a2x-skip-xmllint.patch30
-rw-r--r--debian/patches/0002-introduce-debian-standard-build-flags.patch34
-rw-r--r--debian/patches/0003-pkg-config-lua5.1.patch24
-rw-r--r--debian/patches/0004-rewrite-email-gravater.lua-using-md5.patch38
-rw-r--r--debian/patches/series4
-rwxr-xr-xdebian/rules33
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch2
24 files changed, 890 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..3c69350
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,5 @@
1/cgit.debhelper.log
2/cgit.substvars
3/cgit
4/files
5/build
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..50ed510
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,22 @@
1cgit for Debian
2---------------
3
4To use with apache2 2.4 or later, enable /etc/apache2/conf-available/cgit.conf
5and reload server, then open http://your-server/cgit/.
6
7 # a2enconf cgit.conf
8 # service apache2 reload
9
10For apache2 prior to 2.4, make a symlink of cgit.conf in /etc/apache2/conf.d/
11manually instead.
12
13 # ln -s /etc/apache2/conf-available/cgit.conf /etc/apache2/conf.d
14 # service apache2 reload
15
16Alternatively, you can include cgit.conf from <VirtualHost> defined in any site
17configuration.
18
19The configuration file is /etc/cgitrc or $CGIT_CONFIG if defined. You need to
20add repository definitions in the file. See cgitrc(5) for more details.
21
22 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..8fc864b
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,16 @@
1cgit for Debian
2---------------
3
4cgit integrates the git codebase itself as the core libraries (libgit.a and
5xdiff/lib.a) and the build system. The cgit source package contains the whole
6git distribution of specific version in /git for that purpose.
7
8Some attention would be needed to vulnerabilities in git which might be found
9in future.
10
11The most portion of /git is not relevant to cgit, so it would be better if we
12could remove unneeded files from it to reduce package size and simplify
13debian/copyright.
14
15 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
16
diff --git a/debian/cgit.dirs b/debian/cgit.dirs
new file mode 100644
index 0000000..cf8f9c6
--- /dev/null
+++ b/debian/cgit.dirs
@@ -0,0 +1,2 @@
1/var/cache/cgit
2/etc/apache2/conf-available
diff --git a/debian/cgit.docs b/debian/cgit.docs
new file mode 100644
index 0000000..260845e
--- /dev/null
+++ b/debian/cgit.docs
@@ -0,0 +1,3 @@
1README
2AUTHORS
3cgitrc.5.txt
diff --git a/debian/cgit.examples b/debian/cgit.examples
new file mode 100644
index 0000000..7e541b7
--- /dev/null
+++ b/debian/cgit.examples
@@ -0,0 +1,2 @@
1debian/examples/cgitrc
2debian/examples/apache2.conf
diff --git a/debian/cgit.lintian-overrides b/debian/cgit.lintian-overrides
new file mode 100644
index 0000000..3365816
--- /dev/null
+++ b/debian/cgit.lintian-overrides
@@ -0,0 +1,8 @@
1# For apache2 prior to 2.4 compatibility
2cgit binary: apache2-deprecated-auth-config Order
3cgit binary: apache2-deprecated-auth-config Allow
4
5# Not every user needs python filters so package only suggests python-pygments
6cgit binary: python-script-but-no-python-dep usr/lib/cgit/filters/email-gravatar.py
7cgit binary: python-script-but-no-python-dep usr/lib/cgit/filters/syntax-highlighting.py
8
diff --git a/debian/cgit.postinst b/debian/cgit.postinst
new file mode 100644
index 0000000..a4566a9
--- /dev/null
+++ b/debian/cgit.postinst
@@ -0,0 +1,43 @@
1#!/bin/sh
2# postinst script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postinst> `configure' <most-recently-configured-version>
10# * <old-postinst> `abort-upgrade' <new version>
11# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12# <new-version>
13# * <postinst> `abort-remove'
14# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15# <failed-install-package> <version> `removing'
16# <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20cachedir=/var/cache/cgit
21
22case "$1" in
23 configure)
24 if test -d $cachedir; then
25 chown www-data:www-data $cachedir
26 fi
27 ;;
28
29 abort-upgrade|abort-remove|abort-deconfigure)
30 ;;
31
32 *)
33 echo "postinst called with unknown argument \`$1'" >&2
34 exit 1
35 ;;
36esac
37
38# dh_installdeb will replace this with shell code automatically
39# generated by other debhelper scripts.
40
41#DEBHELPER#
42
43exit 0
diff --git a/debian/cgit.postrm b/debian/cgit.postrm
new file mode 100644
index 0000000..b58613e
--- /dev/null
+++ b/debian/cgit.postrm
@@ -0,0 +1,44 @@
1#!/bin/sh
2# postrm script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postrm> `remove'
10# * <postrm> `purge'
11# * <old-postrm> `upgrade' <new-version>
12# * <new-postrm> `failed-upgrade' <old-version>
13# * <new-postrm> `abort-install'
14# * <new-postrm> `abort-install' <old-version>
15# * <new-postrm> `abort-upgrade' <old-version>
16# * <disappearer's-postrm> `disappear' <overwriter>
17# <overwriter-version>
18# for details, see http://www.debian.org/doc/debian-policy/ or
19# the debian-policy package
20
21cachedir=/var/cache/cgit
22
23case "$1" in
24 purge|remove)
25 if test -d $cachedir; then
26 rm -rf $cachedir
27 fi
28 ;;
29
30 upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
31 ;;
32
33 *)
34 echo "postrm called with unknown argument \`$1'" >&2
35 exit 1
36 ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..9bbf4ac
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,27 @@
1cgit (0.10-1~23) UNRELEASED; urgency=low
2
3 * Debianized by dh_make -s -p cgit_0.10
4 * Add 0001-make-a2x-skip-xmllint.patch
5 * Add git-buildpackage configuration
6 * Add debian/.gitignore
7 * Set CGIT_SCRIPT_PATH and CGIT_DATA_PATH to suit the Debian standard
8 * Update debian/copyright
9 * Update debian/control
10 * Add config files
11 * Add postinst/postrm scripts
12 * Add docs, wont compress pdf files
13 * Remove dh_make example files
14 * Update changelog
15 * Add debian/watch
16 * Fix lintian errors/warnings
17 * Add 0002-introduce-debian-standard-build-flags.patch
18 * Make liblua5.2-dev usable for wheezy compat
19 * Add 0003-pkg-config-lua52.patch
20 * Update changelog using prerelease version 0.10-1~1
21 * Use liblua5.1-dev in wheezy to improve module usability
22 * Update example cgitrc
23 * Add 0004-rewrite-email-gravater.lua-using-md5.patch
24 * Suggest lua-md5 for email-gravater-filter.lua
25 * Fix Vcs-Git and Vcs-Browser
26
27 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..3b0807e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,41 @@
1Source: cgit
2Section: vcs
3Priority: optional
4Maintainer: YAEGASHI Takeshi <yaegashi@debian.org>
5Build-Depends: debhelper (>= 9.0.0),
6 pkg-config,
7 libssl-dev,
8 libluajit-5.1-dev | liblua5.1-dev,
9 asciidoc,
10 libxml2-utils,
11 xsltproc,
12 dblatex,
13Standards-Version: 3.9.5
14Homepage: http://git.zx2c4.com/cgit/about/
15Vcs-Git: http://git.keshi.org/debian/cgit
16Vcs-Browser: http://git.keshi.org/debian/cgit
17
18Package: cgit
19Architecture: any
20Depends: ${shlibs:Depends}, ${misc:Depends}
21Recommends: apache2 | httpd-cgi
22Suggests: lua-md5, python-pygments
23Description: Hyperfast web frontend for git repositories written in C
24 This is an attempt to create a fast web interface for the Git SCM, using a
25 built-in cache to decrease server I/O pressure.
26 .
27 Features:
28 * basic repository browsing (logs, diffs, trees...)
29 * caching of generated HTML
30 * cloneable URLs (implements dumb HTTP transport)
31 * commit feeds (atom format)
32 * discovery of Git repositories
33 * on-the-fly archives for tags and commits
34 * plugin support for e.g. syntax highlighting
35 * side-by-side diffs
36 * simple time/author statistics
37 * simple virtual hosting support (macro expansion)
38 * understands GitWeb project-lists
39 * understands gitweb.owner in Git config files
40 * has extensive filtering framework using scripts or a built-in lua
41 interpreter
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..3273626
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,421 @@
1Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
2Upstream-Name: cgit
3Upstream-Contact: cgit@lists.zx2c4.com
4Source: http://git.zx2c4.com/cgit/
5
6Files: *
7Copyright: 2006-2014 cgit Development Team <cgit@lists.zx2c4.com>
8License: GPL-2
9
10Files: git/*
11Copyright: © 2005-2014, Linus Torvalds and others.
12License: GPL-2
13
14Files: git/xdiff/*
15Copyright: © 2003-2009, Davide Libenzi, Johannes E. Schindelin
16License: LGPL-2.1+
17
18Files: git/xdiff/xhistogram.c
19Copyright: © 2010, Google Inc.
20 and other copyright owners as documented in JGit's IP log.
21License: EDL-1.0
22
23Files: git/gitk-git/*
24Copyright: © 2005-2013, Paul Mackerras, et al.
25License: GPL-2+
26
27Files: git/git-gui/*
28Copyright: © 2005-2010, Shawn Pearce, et. al.
29License: GPL-2+
30
31Files: git/git-gui/po/de.po git/git-gui/po/fr.po git/git-gui/po/glossary/*
32Copyright: © 2007-2008, Shawn Pearce, et al.
33License: GPL-2
34Comment: This file is distributed under the same license as the git package.
35
36Files: git/git-gui/po/glossary/pt_br.po
37Copyright: © 2007, Shawn Pearce, et al.
38License: GPL-2+
39Comment: This file is distributed under the same license as the git-gui package.
40
41Files: git/gitweb/static/js/*
42Copyright: © 2007, Fredrik Kuivinen <frekui@gmail.com>
43 © 2007, Petr Baudis <pasky@suse.cz>
44 © 2008-2011, Jakub Narebski <jnareb@gmail.com>
45 © 2011, John 'Warthog9' Hawley <warthog9@eaglescrag.net>
46License: GPL-2+
47
48Files: git/git-p4
49Copyright: © 2007, Simon Hausmann <simon@lst.de>
50 © 2007, Trolltech ASA
51License: Expat
52
53Files: git/git-svn.perl
54Copyright: © 2006, Eric Wong <normalperson@yhbt.net>
55License: GPL-2+
56
57Files: git/vcs-svn/*
58Copyright: © 2010, David Barr <david.barr@cordelta.com>
59 © 2010, Jonathan Nieder <jrnieder@gmail.com>
60 © 2005, Stefan Hegny, hydrografix Consulting GmbH,
61 Frankfurt/Main, Germany
62 and others, see http://svn2cc.sarovar.org
63License: BSD-2-clause
64
65Files: git/imap-send.c
66Copyright: © 2000-2002, Michael R. Elkins <me@mutt.org>
67 © 2002-2004, Oswald Buddenhagen <ossi@users.sf.net>
68 © 2004, Theodore Y. Ts'o <tytso@mit.edu>
69 © 2006, Mike McCormack
70Name: git-imap-send - drops patches into an imap Drafts folder
71 derived from isync/mbsync - mailbox synchronizer
72License: GPL-2+
73
74Files: git/perl/Git.pm
75Copyright: © 2006, by Petr Baudis <pasky@suse.cz>
76License: GPL-2+
77
78Files: git/perl/private-Error.pm
79Copyright: © 1997-8, Graham Barr <gbarr@ti.com>
80License: GPL-1+ or Artistic-1
81 This program is free software; you can redistribute it and/or modify
82 it under the terms of either:
83 .
84 a) the GNU General Public License as published by the Free Software
85 Foundation; either version 1, or (at your option) any later
86 version, or
87 .
88 b) the "Artistic License" which comes with Perl.
89 .
90 On Debian GNU/Linux systems, the complete text of the GNU General
91 Public License can be found in '/usr/share/common-licenses/GPL' and
92 the Artistic Licence in '/usr/share/common-licenses/Artistic'.
93
94Files: git/kwset.c git/kwset.h
95Copyright: © 1989, 1998, 2000, 2005, Free Software Foundation, Inc.
96License: GPL-2+
97
98Files: git/trace.c
99Copyright: © 2000-2002, Michael R. Elkins <me@mutt.org>
100 © 2002-2004, Oswald Buddenhagen <ossi@users.sf.net>
101 © 2004, Theodore Y. Ts'o <tytso@mit.edu>
102 © 2006, Mike McCormack
103 © 2006, Christian Couder
104License: GPL-2+
105
106Files: git/sh-i18n--envsubst.c
107Copyright: © 2010, Ævar Arnfjörð Bjarmason
108 © 1998-2007, Free Software Foundation, Inc.
109License: GPL-2+
110
111Files: git/t/test-lib.sh
112Copyright: © 2005, Junio C Hamano
113License: GPL-2+
114
115Files: git/compat/fnmatch/*
116Copyright: © 1991-1999, Free Software Foundation, Inc.
117License: LGPL-2+
118Comment: This file is part of the GNU C Library.
119
120Files: git/compat/inet_ntop.c git/compat/inet_pton.c
121Copyright: © 1996-2001, Internet Software Consortium.
122License: ISC
123
124Files: git/compat/poll/poll.c git/compat/poll/poll.h
125Copyright: © 2001-2003, 2006-2011, Free Software Foundation, Inc.
126Name: Emulation for poll(2) from gnulib.
127License: GPL-2+
128
129Files: git/compat/vcbuild/include/sys/utime.h
130Copyright: ?
131License: mingw-runtime
132
133Files: git/compat/nedmalloc/*
134Copyright: © 2005-2006 Niall Douglas
135License: Boost
136
137Files: git/compat/nedmalloc/malloc.c.h
138Copyright: © 2006, KJK::Hyperion <hackbunny@reactos.com>
139License: dlmalloc
140
141Files: git/compat/regex/*
142Copyright: © 1985, 1989-93, 1995-2010, Free Software Foundation, Inc.
143Name: Extended regular expression matching and search library
144License: LGPL-2.1+
145
146Files: git/compat/obstack.c git/compat/obstack.h
147Copyright: © 1988-1994, 1996-2005, 2009, Free Software Foundation, Inc.
148Name: Object stack macros.
149License: LGPL-2.1+
150
151Files: git/contrib/persistent-https/*
152Copyright: © 2012, Google Inc.
153License: Apache-2.0
154
155Files: git/contrib/credential/gnome-keyring/git-credential-gnome-keyring.c
156Copyright: © 2011, John Szakmeister <john@szakmeister.net>
157 © 2012, Philipp A. Hartmann <pah@qo.cx>
158License: GPL-2+
159
160Files: git/contrib/hg-to-git/hg-to-git.py
161Copyright: © 2007, Stelian Pop <stelian@popies.net>
162Name: hg-to-git.py - A Mercurial to GIT converter
163License: GPL-2+
164
165Files: git/contrib/mw-to-git/git-*.perl git/contrib/mw-to-git/t/t*
166Copyright: © 2011
167 Jérémie Nikaes <jeremie.nikaes@ensimag.imag.fr>
168 Arnaud Lacurie <arnaud.lacurie@ensimag.imag.fr>
169 Claire Fousse <claire.fousse@ensimag.imag.fr>
170 David Amouyal <david.amouyal@ensimag.imag.fr>
171 Matthieu Moy <matthieu.moy@grenoble-inp.fr>
172 © 2012
173 Charles Roussel <charles.roussel@ensimag.imag.fr>
174 Simon Cathebras <simon.cathebras@ensimag.imag.fr>
175 Julien Khayat <julien.khayat@ensimag.imag.fr>
176 Guillaume Sasdy <guillaume.sasdy@ensimag.imag.fr>
177 Simon Perrat <simon.perrat@ensimag.imag.fr>
178 © 2013
179 Benoit Person <benoit.person@ensimag.imag.fr>
180 Celestin Matte <celestin.matte@ensimag.imag.fr>
181License: GPL-2+
182
183Files: debian/*
184Copyright: 2014 YAEGASHI Takeshi <yaegashi@debian.org>
185License: GPL-2
186
187License: GPL-2
188 You can redistribute this software and/or modify it under the terms of
189 the GNU General Public License as published by the Free Software
190 Foundation; version 2 dated June, 1991.
191 .
192 This program is distributed in the hope that it will be useful, but
193 WITHOUT ANY WARRANTY; without even the implied warranty of
194 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
195 General Public License for more details.
196 .
197 On Debian systems, the complete text of the GNU General Public License
198 can be found in /usr/share/common-licenses/GPL-2 file.
199
200License: GPL-2+
201 This program is free software; you can redistribute it and/or modify
202 it under the terms of the GNU General Public License as published by
203 the Free Software Foundation; either version 2, or (at your option)
204 any later version.
205 .
206 This program is distributed in the hope that it will be useful,
207 but WITHOUT ANY WARRANTY; without even the implied warranty of
208 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
209 GNU General Public License for more details.
210 .
211 On Debian systems, the complete text of the GNU General Public License
212 can be found in /usr/share/common-licenses/GPL-2 file.
213
214License: LGPL-2+
215 This library is free software; you can redistribute it and/or
216 modify it under the terms of the GNU Library General Public License as
217 published by the Free Software Foundation; either version 2 of the
218 License, or (at your option) any later version.
219 .
220 This library is distributed in the hope that it will be useful,
221 but WITHOUT ANY WARRANTY; without even the implied warranty of
222 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
223 Library General Public License for more details.
224 .
225 On Debian systems, the complete text of the GNU Library General Public License
226 can be found in the /usr/share/common-licenses/LGPL-2 file.
227
228License: LGPL-2.1+
229 This library is free software; you can redistribute it and/or
230 modify it under the terms of the GNU Lesser General Public
231 License as published by the Free Software Foundation; either
232 version 2.1 of the License, or (at your option) any later version.
233 .
234 This library is distributed in the hope that it will be useful,
235 but WITHOUT ANY WARRANTY; without even the implied warranty of
236 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
237 Lesser General Public License for more details.
238 .
239 On Debian systems, the complete text of the GNU Lesser General Public License
240 can be found in /usr/share/common-licenses/LGPL-2.1.
241
242License: Apache-2.0
243 Licensed under the Apache License, Version 2.0 (the "License");
244 you may not use this file except in compliance with the License.
245 You may obtain a copy of the License at
246 .
247 http://www.apache.org/licenses/LICENSE-2.0
248 .
249 Unless required by applicable law or agreed to in writing, software
250 distributed under the License is distributed on an "AS IS" BASIS,
251 WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
252 See the License for the specific language governing permissions and
253 limitations under the License.
254 .
255 On Debian systems, the full text of the Apache License version 2 can
256 be found in /usr/share/common-licenses/Apache-2.0.
257
258License: BSD-2-clause
259 Redistribution and use in source and binary forms, with or without
260 modification, are permitted provided that the following conditions
261 are met:
262 1. Redistributions of source code must retain the above copyright
263 notice(s), this list of conditions and the following disclaimer
264 unmodified other than the allowable addition of one or more
265 copyright notices.
266 2. Redistributions in binary form must reproduce the above copyright
267 notice(s), this list of conditions and the following disclaimer in
268 the documentation and/or other materials provided with the
269 distribution.
270 .
271 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER(S) ``AS IS'' AND ANY
272 EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
273 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
274 PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER(S) BE
275 LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
276 CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
277 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
278 BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
279 WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
280 OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
281 EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
282
283License: ISC
284 Permission to use, copy, modify, and distribute this software for any
285 purpose with or without fee is hereby granted, provided that the above
286 copyright notice and this permission notice appear in all copies.
287 .
288 THE SOFTWARE IS PROVIDED "AS IS" AND INTERNET SOFTWARE CONSORTIUM DISCLAIMS
289 ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES
290 OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL INTERNET SOFTWARE
291 CONSORTIUM BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
292 DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
293 PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
294 ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
295 SOFTWARE.
296
297License: Expat
298 <http://www.opensource.org/licenses/mit-license.php>:
299 .
300 Permission is hereby granted, free of charge, to any person obtaining a copy
301 of this software and associated documentation files (the "Software"), to deal
302 in the Software without restriction, including without limitation the rights
303 to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
304 copies of the Software, and to permit persons to whom the Software is
305 furnished to do so, subject to the following conditions:
306 .
307 The above copyright notice and this permission notice shall be included in
308 all copies or substantial portions of the Software.
309 .
310 THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
311 IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
312 FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
313 AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
314 LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
315 OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
316 THE SOFTWARE.
317
318License: EDL-1.0
319 Redistribution and use in source and binary forms, with or
320 without modification, are permitted provided that the following
321 conditions are met:
322 .
323 - Redistributions of source code must retain the above copyright
324 notice, this list of conditions and the following disclaimer.
325 .
326 - Redistributions in binary form must reproduce the above
327 copyright notice, this list of conditions and the following
328 disclaimer in the documentation and/or other materials provided
329 with the distribution.
330 .
331 - Neither the name of the Eclipse Foundation, Inc. nor the
332 names of its contributors may be used to endorse or promote
333 products derived from this software without specific prior
334 written permission.
335 .
336 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
337 CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
338 INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
339 OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
340 ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
341 CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
342 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
343 NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
344 LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
345 CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
346 STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
347 ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
348 ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
349
350License: mingw-runtime
351 This file has no copyright assigned and is placed in the Public Domain.
352 This file is a part of the mingw-runtime package.
353 .
354 The mingw-runtime package and its code is distributed in the hope that it
355 will be useful but WITHOUT ANY WARRANTY. ALL WARRANTIES, EXPRESSED OR
356 IMPLIED ARE HEREBY DISCLAIMED. This includes but is not limited to
357 warranties of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
358 .
359 You are free to use this package and its code without limitation.
360
361License: Boost
362 It is licensed under the Boost Software License which basically means
363 you can do anything you like with it. This does not apply to the malloc.c.h
364 file which remains copyright to others.
365 .
366 Boost Software License - Version 1.0 - August 17th, 2003
367 .
368 Permission is hereby granted, free of charge, to any person or organization
369 obtaining a copy of the software and accompanying documentation covered by
370 this license (the "Software") to use, reproduce, display, distribute,
371 execute, and transmit the Software, and to prepare derivative works of the
372 Software, and to permit third-parties to whom the Software is furnished to
373 do so, all subject to the following:
374 .
375 The copyright notices in the Software and this entire statement, including
376 the above license grant, this restriction and the following disclaimer,
377 must be included in all copies of the Software, in whole or in part, and
378 all derivative works of the Software, unless such copies or derivative
379 works are solely in the form of machine-executable object code generated by
380 a source language processor.
381 .
382 THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
383 IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
384 FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
385 SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
386 FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
387 ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
388 DEALINGS IN THE SOFTWARE.
389
390License: dlmalloc
391 This is a version (aka dlmalloc) of malloc/free/realloc written by
392 Doug Lea and released to the public domain, as explained at
393 http://creativecommons.org/licenses/publicdomain. Send questions,
394 comments, complaints, performance data, etc to dl@cs.oswego.edu
395 .
396 Incorporates code from intrin_x86.h, which bears the following notice:
397 .
398 Compatibility <intrin_x86.h> header for GCC -- GCC equivalents of intrinsic
399 Microsoft Visual C++ functions. Originally developed for the ReactOS
400 (<http://www.reactos.org/>) and TinyKrnl (<http://www.tinykrnl.org/>)
401 projects.
402 .
403 Copyright (c) 2006 KJK::Hyperion <hackbunny@reactos.com>
404 .
405 Permission is hereby granted, free of charge, to any person obtaining a
406 copy of this software and associated documentation files (the "Software"),
407 to deal in the Software without restriction, including without limitation
408 the rights to use, copy, modify, merge, publish, distribute, sublicense,
409 and/or sell copies of the Software, and to permit persons to whom the
410 Software is furnished to do so, subject to the following conditions:
411 .
412 The above copyright notice and this permission notice shall be included in
413 all copies or substantial portions of the Software.
414 .
415 THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
416 IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
417 FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
418 AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
419 LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
420 FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
421 DEALINGS IN THE SOFTWARE.
diff --git a/debian/examples/apache2.conf b/debian/examples/apache2.conf
new file mode 100644
index 0000000..04b557e
--- /dev/null
+++ b/debian/examples/apache2.conf
@@ -0,0 +1,15 @@
1# Apache2 configuration for Debian cgit package.
2# The CGI executable is /usr/lib/cgi-bin/cgit.cgi
3# Other static assets are installed in /usr/share/cgit/htdocs
4
5Alias /cgit/cgit.css /usr/share/cgit/htdocs/cgit.css
6Alias /cgit/cgit.png /usr/share/cgit/htdocs/cgit.png
7Alias /cgit/robot.txt /usr/share/cgit/htdocs/robots.txt
8Alias /cgit/favicon.ico /usr/share/cgit/htdocs/favicon.ico
9ScriptAlias /cgit/ /usr/lib/cgi-bin/cgit.cgi/
10
11<Directory "/usr/share/cgit/htdocs">
12 AllowOverride None
13 Order allow,deny
14 Allow from all
15</Directory>
diff --git a/debian/examples/cgitrc b/debian/examples/cgitrc
new file mode 100644
index 0000000..95d4216
--- /dev/null
+++ b/debian/examples/cgitrc
@@ -0,0 +1,70 @@
1## Debian cgit package configuration - see cgitrc(5).
2
3## Enable caching up to 1000 entries in cache-root (/var/cache/cgit).
4cache-size=1000
5
6## Static asset locations (suitting to /etc/apache2/conf-available/cgit.conf).
7css=/cgit/cgit.css
8logo=/cgit/cgit.png
9favicon=/cgit/favicon.ico
10
11## Load system mime types.
12mimetype-file=/etc/mime.types
13
14## Enable downloading snapshots in zip and tar.gz format.
15snapshots=zip tar.gz
16
17## Enable other nice features.
18local-time=1
19remove-suffix=1
20side-by-side-diffs=1
21enable-git-config=1
22enable-commit-graph=1
23enable-log-linecount=1
24max-stats=quarter
25
26## Display clone URL information.
27#clone-prefix=http://your-server/cgit
28
29## Enable email gravatar filter using built-in lua interpreter.
30## You need suggested package: lua-md5
31#email-filter=lua:/usr/lib/cgit/filters/email-gravatar.lua
32
33## Enable source code highlighting filter by pygments.
34## You need suggested package: python-pygments
35#source-filter=exec:/usr/lib/cgit/filters/syntax-highlighting.py
36
37## Enable the "about" page.
38## about-formatting.sh supports various formats.
39#readme=about:index.html about:index.textile about:index.md
40#about-filter=/usr/lib/cgit/filters/about-formatting.sh
41
42## Configuration for repositories foo and bar.
43#repo.url=foo
44#repo.path=/pub/git/foo.git
45#repo.desc=the master foo repository
46#repo.owner=fooman@example.com
47#repo.readme=info/web/about.html
48#
49#repo.url=bar
50#repo.path=/pub/git/bar.git
51#repo.desc=the bars for your foo
52#repo.owner=barman@example.com
53#repo.readme=info/web/about.html
54
55## Configuration for repositories baz and wiz in the extras section.
56#section=extras
57#
58#repo.url=baz
59#repo.path=/pub/git/baz.git
60#repo.desc=a set of extensions for bar users
61#
62#repo.url=wiz
63#repo.path=/pub/git/wiz.git
64#repo.desc=the wizard of foo
65
66## Configuration for repositories managed by Debian gitolite3 package.
67## See the instructions on the gitweb integration at
68## http://gitolite.com/gitolite/external.html
69#project-list=/var/lib/gitolite3/projects.list
70#scan-path=/var/lib/gitolite3/repositories
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..7cb135b
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,4 @@
1[DEFAULT]
2upstream-tag = v%(version)s
3submodules = True
4compression = xz
diff --git a/debian/patches/0001-make-a2x-skip-xmllint.patch b/debian/patches/0001-make-a2x-skip-xmllint.patch
new file mode 100644
index 0000000..38f48d5
--- /dev/null
+++ b/debian/patches/0001-make-a2x-skip-xmllint.patch
@@ -0,0 +1,30 @@
1From: YAEGASHI Takeshi <yaegashi@debian.org>
2Date: Sat, 15 Feb 2014 19:15:53 +0900
3Subject: make a2x skip xmllint
4
5Simply avoiding a2x failure caused by xmllint exit code 4 (Validation error).
6---
7 Makefile | 6 +++---
8 1 file changed, 3 insertions(+), 3 deletions(-)
9
10diff --git a/Makefile b/Makefile
11index 2dc92df..1dac1ef 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -126,13 +126,13 @@ doc-html: $(DOC_HTML)
15 doc-pdf: $(DOC_PDF)
16
17 %.5 : %.5.txt
18- a2x -f manpage $<
19+ a2x -L -f manpage $<
20
21 $(DOC_HTML): %.html : %.txt
22- a2x -f xhtml --stylesheet=cgit-doc.css $<
23+ a2x -L -f xhtml --stylesheet=cgit-doc.css $<
24
25 $(DOC_PDF): %.pdf : %.txt
26- a2x -f pdf cgitrc.5.txt
27+ a2x -L -f pdf cgitrc.5.txt
28
29 clean: clean-doc
30 $(RM) cgit VERSION CGIT-CFLAGS *.o tags
diff --git a/debian/patches/0002-introduce-debian-standard-build-flags.patch b/debian/patches/0002-introduce-debian-standard-build-flags.patch
new file mode 100644
index 0000000..e4b7c6d
--- /dev/null
+++ b/debian/patches/0002-introduce-debian-standard-build-flags.patch
@@ -0,0 +1,34 @@
1From: YAEGASHI Takeshi <yaegashi@debian.org>
2Date: Mon, 17 Feb 2014 06:51:44 +0900
3Subject: introduce debian standard build flags
4
5See https://wiki.debian.org/Hardening
6---
7 Makefile | 7 ++++++-
8 1 file changed, 6 insertions(+), 1 deletion(-)
9
10diff --git a/Makefile b/Makefile
11index 1dac1ef..7e1381c 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -37,6 +37,10 @@ DOC_PDF = $(patsubst %.txt,%.pdf,$(MAN_TXT))
15 #
16 -include cgit.conf
17
18+# Import Debian standard build flags.
19+DPKG_EXPORT_BUILDFLAGS = 1
20+include /usr/share/dpkg/buildflags.mk
21+
22 export CGIT_VERSION CGIT_SCRIPT_NAME CGIT_SCRIPT_PATH CGIT_DATA_PATH CGIT_CONFIG CACHE_ROOT
23
24 #
25@@ -65,7 +69,8 @@ endif
26 all:: cgit
27
28 cgit:
29- $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) -f ../cgit.mk ../cgit $(EXTRA_GIT_TARGETS) NO_CURL=1
30+ $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) -f ../cgit.mk ../cgit $(EXTRA_GIT_TARGETS) NO_CURL=1 \
31+ CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
32
33 test:
34 @$(MAKE) --no-print-directory cgit EXTRA_GIT_TARGETS=all
diff --git a/debian/patches/0003-pkg-config-lua5.1.patch b/debian/patches/0003-pkg-config-lua5.1.patch
new file mode 100644
index 0000000..753ba78
--- /dev/null
+++ b/debian/patches/0003-pkg-config-lua5.1.patch
@@ -0,0 +1,24 @@
1From: YAEGASHI Takeshi <yaegashi@debian.org>
2Date: Tue, 18 Feb 2014 07:24:45 +0900
3Subject: pkg-config lua5.1
4
5pkg-config must use lua5.1.pc provided by liblua5.1-dev.
6---
7 cgit.mk | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/cgit.mk b/cgit.mk
11index 056c3f9..32238d4 100644
12--- a/cgit.mk
13+++ b/cgit.mk
14@@ -31,8 +31,8 @@ ifdef NO_LUA
15 else
16 LUAJIT_CFLAGS := $(shell pkg-config --cflags luajit 2>/dev/null)
17 LUAJIT_LIBS := $(shell pkg-config --libs luajit 2>/dev/null)
18-LUA_LIBS := $(shell pkg-config --libs lua 2>/dev/null)
19-LUA_CFLAGS := $(shell pkg-config --cflags lua 2>/dev/null)
20+LUA_LIBS := $(shell pkg-config --libs lua5.1 2>/dev/null)
21+LUA_CFLAGS := $(shell pkg-config --cflags lua5.1 2>/dev/null)
22 ifeq (JIT,$(LUA_IMPLEMENTATION))
23 ifeq ($(strip $(LUAJIT_LIBS)),)
24 $(error LuaJIT specified via LUA_IMPLEMENTATION=JIT, but library could not be found.)
diff --git a/debian/patches/0004-rewrite-email-gravater.lua-using-md5.patch b/debian/patches/0004-rewrite-email-gravater.lua-using-md5.patch
new file mode 100644
index 0000000..8119c07
--- /dev/null
+++ b/debian/patches/0004-rewrite-email-gravater.lua-using-md5.patch
@@ -0,0 +1,38 @@
1From: YAEGASHI Takeshi <yaegashi@debian.org>
2Date: Thu, 20 Feb 2014 03:12:26 +0900
3Subject: rewrite email-gravater.lua using md5
4
5Unfortunately luacrypto is unavailable in Debian. Use lua-md5 instead.
6---
7 filters/email-gravatar.lua | 10 +++++-----
8 1 file changed, 5 insertions(+), 5 deletions(-)
9
10diff --git a/filters/email-gravatar.lua b/filters/email-gravatar.lua
11index 52cf426..8f985f1 100644
12--- a/filters/email-gravatar.lua
13+++ b/filters/email-gravatar.lua
14@@ -3,19 +3,19 @@
15 -- prefix in filters. It is much faster than the corresponding python script.
16 --
17 -- Requirements:
18--- luacrypto >= 0.3
19--- <http://mkottman.github.io/luacrypto/>
20+-- md5
21+-- <http://keplerproject.org/md5/>
22 --
23
24-local crypto = require("crypto")
25+local md5 = require("md5")
26
27 function filter_open(email, page)
28 buffer = ""
29- md5 = crypto.digest("md5", email:sub(2, -2):lower())
30+ digest = md5.sumhexa(email:sub(2, -2):lower())
31 end
32
33 function filter_close()
34- html("<img src='//www.gravatar.com/avatar/" .. md5 .. "?s=13&amp;d=retro' width='13' height='13' alt='Gravatar' /> " .. buffer)
35+ html("<img src='//www.gravatar.com/avatar/" .. digest .. "?s=13&amp;d=retro' width='13' height='13' alt='Gravatar' /> " .. buffer)
36 return 0
37 end
38
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..11ceafc
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
10001-make-a2x-skip-xmllint.patch
20002-introduce-debian-standard-build-flags.patch
30003-pkg-config-lua5.1.patch
40004-rewrite-email-gravater.lua-using-md5.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..982c51e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
1#!/usr/bin/make -f
2# -*- makefile -*-
3
4# Uncomment this to turn on verbose mode.
5#export DH_VERBOSE=1
6
7MAKE_ARGS = \
8 prefix=/usr \
9 CGIT_SCRIPT_PATH=/usr/lib/cgi-bin \
10 CGIT_DATA_PATH=/usr/share/cgit/htdocs
11
12%:
13 dh $@
14
15override_dh_auto_clean:
16 dh_auto_clean
17 rm -rf .depend
18 cd git; if test -e .git; then git clean -ffdx; else make distclean; fi
19
20override_dh_auto_configure:
21
22override_dh_auto_build:
23 dh_auto_build -- $(MAKE_ARGS) all doc
24
25override_dh_auto_test:
26
27override_dh_auto_install:
28 dh_auto_install -- $(MAKE_ARGS) install-doc
29 install -m 0644 debian/examples/cgitrc debian/cgit/etc
30 install -m 0644 debian/examples/apache2.conf debian/cgit/etc/apache2/conf-available/cgit.conf
31
32override_dh_compress:
33 dh_compress -a -X.pdf
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..f9bc954
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
1version=3
2http://git.zx2c4.com/cgit /cgit/snapshot/cgit-(\d\S*)\.tar\.xz