aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/.gitignore5
-rw-r--r--debian/README.Debian22
-rw-r--r--debian/README.source16
-rw-r--r--debian/cgit.dirs2
-rw-r--r--debian/cgit.docs3
-rw-r--r--debian/cgit.examples2
-rw-r--r--debian/cgit.lintian-overrides8
-rw-r--r--debian/cgit.postinst43
-rw-r--r--debian/cgit.postrm44
-rw-r--r--debian/changelog27
-rw-r--r--debian/compat1
-rw-r--r--debian/control41
-rw-r--r--debian/copyright421
-rw-r--r--debian/examples/apache2.conf15
-rw-r--r--debian/examples/cgitrc70
-rw-r--r--debian/gbp.conf4
-rw-r--r--debian/patches/0001-make-a2x-skip-xmllint.patch30
-rw-r--r--debian/patches/0002-introduce-debian-standard-build-flags.patch34
-rw-r--r--debian/patches/0003-pkg-config-lua5.1.patch24
-rw-r--r--debian/patches/0004-rewrite-email-gravater.lua-using-md5.patch38
-rw-r--r--debian/patches/series4
-rwxr-xr-xdebian/rules33
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch2
24 files changed, 890 insertions, 0 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..3c69350
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,5 @@
1/cgit.debhelper.log
2/cgit.substvars
3/cgit
4/files
5/build
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..50ed510
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,22 @@
1cgit for Debian
2---------------
3
4To use with apache2 2.4 or later, enable /etc/apache2/conf-available/cgit.conf
5and reload server, then open http://your-server/cgit/.
6
7 # a2enconf cgit.conf
8 # service apache2 reload
9
10For apache2 prior to 2.4, make a symlink of cgit.conf in /etc/apache2/conf.d/
11manually instead.
12
13 # ln -s /etc/apache2/conf-available/cgit.conf /etc/apache2/conf.d
14 # service apache2 reload
15
16Alternatively, you can include cgit.conf from <VirtualHost> defined in any site
17configuration.
18
19The configuration file is /etc/cgitrc or $CGIT_CONFIG if defined. You need to
20add repository definitions in the file. See cgitrc(5) for more details.
21
22 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..8fc864b
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,16 @@
1cgit for Debian
2---------------
3
4cgit integrates the git codebase itself as the core libraries (libgit.a and
5xdiff/lib.a) and the build system. The cgit source package contains the whole
6git distribution of specific version in /git for that purpose.
7
8Some attention would be needed to vulnerabilities in git which might be found
9in future.
10
11The most portion of /git is not relevant to cgit, so it would be better if we
12could remove unneeded files from it to reduce package size and simplify
13debian/copyright.
14
15 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
16
diff --git a/debian/cgit.dirs b/debian/cgit.dirs
new file mode 100644
index 0000000..cf8f9c6
--- /dev/null
+++ b/debian/cgit.dirs
@@ -0,0 +1,2 @@
1/var/cache/cgit
2/etc/apache2/conf-available
diff --git a/debian/cgit.docs b/debian/cgit.docs
new file mode 100644
index 0000000..260845e
--- /dev/null
+++ b/debian/cgit.docs
@@ -0,0 +1,3 @@
1README
2AUTHORS
3cgitrc.5.txt
diff --git a/debian/cgit.examples b/debian/cgit.examples
new file mode 100644
index 0000000..7e541b7
--- /dev/null
+++ b/debian/cgit.examples
@@ -0,0 +1,2 @@
1debian/examples/cgitrc
2debian/examples/apache2.conf
diff --git a/debian/cgit.lintian-overrides b/debian/cgit.lintian-overrides
new file mode 100644
index 0000000..3365816
--- /dev/null
+++ b/debian/cgit.lintian-overrides
@@ -0,0 +1,8 @@
1# For apache2 prior to 2.4 compatibility
2cgit binary: apache2-deprecated-auth-config Order
3cgit binary: apache2-deprecated-auth-config Allow
4
5# Not every user needs python filters so package only suggests python-pygments
6cgit binary: python-script-but-no-python-dep usr/lib/cgit/filters/email-gravatar.py
7cgit binary: python-script-but-no-python-dep usr/lib/cgit/filters/syntax-highlighting.py
8
diff --git a/debian/cgit.postinst b/debian/cgit.postinst
new file mode 100644
index 0000000..a4566a9
--- /dev/null
+++ b/debian/cgit.postinst
@@ -0,0 +1,43 @@
1#!/bin/sh
2# postinst script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postinst> `configure' <most-recently-configured-version>
10# * <old-postinst> `abort-upgrade' <new version>
11# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12# <new-version>
13# * <postinst> `abort-remove'
14# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15# <failed-install-package> <version> `removing'
16# <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20cachedir=/var/cache/cgit
21
22case "$1" in
23 configure)
24 if test -d $cachedir; then
25 chown www-data:www-data $cachedir
26 fi
27 ;;
28
29 abort-upgrade|abort-remove|abort-deconfigure)
30 ;;
31
32 *)
33 echo "postinst called with unknown argument \`$1'" >&2
34 exit 1
35 ;;
36esac
37
38# dh_installdeb will replace this with shell code automatically
39# generated by other debhelper scripts.
40
41#DEBHELPER#
42
43exit 0
diff --git a/debian/cgit.postrm b/debian/cgit.postrm
new file mode 100644
index 0000000..b58613e
--- /dev/null
+++ b/debian/cgit.postrm
@@ -0,0 +1,44 @@
1#!/bin/sh
2# postrm script for cgit
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9# * <postrm> `remove'
10# * <postrm> `purge'
11# * <old-postrm> `upgrade' <new-version>
12# * <new-postrm> `failed-upgrade' <old-version>
13# * <new-postrm> `abort-install'
14# * <new-postrm> `abort-install' <old-version>
15# * <new-postrm> `abort-upgrade' <old-version>
16# * <disappearer's-postrm> `disappear' <overwriter>
17# <overwriter-version>
18# for details, see http://www.debian.org/doc/debian-policy/ or
19# the debian-policy package
20
21cachedir=/var/cache/cgit
22
23case "$1" in
24 purge|remove)
25 if test -d $cachedir; then
26 rm -rf $cachedir
27 fi
28 ;;
29
30 upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
31 ;;
32
33 *)
34 echo "postrm called with unknown argument \`$1'" >&2
35 exit 1
36 ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..9bbf4ac
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,27 @@
1cgit (0.10-1~23) UNRELEASED; urgency=low
2
3 * Debianized by dh_make -s -p cgit_0.10
4 * Add 0001-make-a2x-skip-xmllint.patch
5 * Add git-buildpackage configuration
6 * Add debian/.gitignore
7 * Set CGIT_SCRIPT_PATH and CGIT_DATA_PATH to suit the Debian standard
8 * Update debian/copyright
9 * Update debian/control
10 * Add config files
11 * Add postinst/postrm scripts
12 * Add docs, wont compress pdf files
13 * Remove dh_make example files
14 * Update changelog
15 * Add debian/watch
16 * Fix lintian errors/warnings
17 * Add 0002-introduce-debian-standard-build-flags.patch
18 * Make liblua5.2-dev usable for wheezy compat
19 * Add 0003-pkg-config-lua52.patch
20 * Update changelog using prerelease version 0.10-1~1
21 * Use liblua5.1-dev in wheezy to improve module usability
22 * Update example cgitrc
23 * Add 0004-rewrite-email-gravater.lua-using-md5.patch
24 * Suggest lua-md5 for email-gravater-filter.lua
25 * Fix Vcs-Git and Vcs-Browser
26
27 -- YAEGASHI Takeshi <yaegashi@debian.org> Fri, 14 Feb 2014 20:57:51 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..3b0807e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,41 @@
1Source: cgit
2Section: vcs
3Priority: optional
4Maintainer: YAEGASHI Takeshi <yaegashi@debian.org>
5Build-Depends: debhelper (>= 9.0.0),
6 pkg-config,
7 libssl-dev,
8 libluajit-5.1-dev | liblua5.1-dev,
9 asciidoc,
10 libxml2-utils,
11 xsltproc,
12 dblatex,
13Standards-Version: 3.9.5
14Homepage: http://git.zx2c4.com/cgit/about/
15Vcs-Git: http://git.keshi.org/debian/cgit
16Vcs-Browser: http://git.keshi.org/debian/cgit
17
18Package: cgit
19Architecture: any
20Depends: ${shlibs:Depends}, ${misc:Depends}
21Recommends: apache2 | httpd-cgi
22Suggests: lua-md5, python-pygments
23Description: Hyperfast web frontend for git repositories written in C
24 This is an attempt to create a fast web interface for the Git SCM, using a
25 built-in cache to decrease server I/O pressure.
26 .
27 Features:
28 * basic repository browsing (logs, diffs, trees...)
29 * caching of generated HTML
30 * cloneable URLs (implements dumb HTTP transport)
31 * commit feeds (atom format)
32 * discovery of Git repositories
33 * on-the-fly archives for tags and commits
34 * plugin support for e.g. syntax highlighting
35 * side-by-side diffs
36 * simple time/author statistics
37 * simple virtual hosting support (macro expansion)
38 * understands GitWeb project-lists
39 * understands gitweb.owner in Git config files
40 * has extensive filtering framework using scripts or a built-in lua
41 interpreter
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..3273626
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,421 @@
1Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
2Upstream-Name: cgit
3Upstream-Contact: cgit@lists.zx2c4.com
4Source: http://git.zx2c4.com/cgit/
5
6Files: *
7Copyright: 2006-2014 cgit Development Team <cgit@lists.zx2c4.com>
8License: GPL-2
9
10Files: git/*
11Copyright: © 2005-2014, Linus Torvalds and others.
12License: GPL-2
13
14Files: git/xdiff/*
15Copyright: © 2003-2009, Davide Libenzi, Johannes E. Schindelin
16License: LGPL-2.1+
17
18Files: git/xdiff/xhistogram.c
19Copyright: © 2010, Google Inc.
20 and other copyright owners as documented in JGit's IP log.
21License: EDL-1.0
22
23Files: git/gitk-git/*
24Copyright: © 2005-2013, Paul Mackerras, et al.
25License: GPL-2+
26
27Files: git/git-gui/*
28Copyright: © 2005-2010, Shawn Pearce, et. al.
29License: GPL-2+
30
31Files: git/git-gui/po/de.po git/git-gui/po/fr.po git/git-gui/po/glossary/*
32Copyright: © 2007-2008, Shawn Pearce, et al.
33License: GPL-2
34Comment: This file is distributed under the same license as the git package.
35
36Files: git/git-gui/po/glossary/pt_br.po
37Copyright: © 2007, Shawn Pearce, et al.
38License: GPL-2+
39Comment: This file is distributed under the same license as the git-gui package.
40
41Files: git/gitweb/static/js/*
42Copyright: © 2007, Fredrik Kuivinen <frekui@gmail.com>
43 © 2007, Petr Baudis <pasky@suse.cz>
44 © 2008-2011, Jakub Narebski <jnareb@gmail.com>
45 © 2011, John 'Warthog9' Hawley <warthog9@eaglescrag.net>
46License: GPL-2+
47
48Files: git/git-p4
49Copyright: © 2007, Simon Hausmann <simon@lst.de>
50 © 2007, Trolltech ASA
51License: Expat
52
53Files: git/git-svn.perl
54Copyright: © 2006, Eric Wong <normalperson@yhbt.net>
55License: GPL-2+
56
57Files: git/vcs-svn/*
58Copyright: © 2010, David Barr <david.barr@cordelta.com>
59 © 2010, Jonathan Nieder <jrnieder@gmail.com>
60 © 2005, Stefan Hegny, hydrografix Consulting GmbH,
61 Frankfurt/Main, Germany
62 and others, see http://svn2cc.sarovar.org
63License: BSD-2-clause
64
65Files: git/imap-send.c
66Copyright: © 2000-2002, Michael R. Elkins <me@mutt.org>
67 © 2002-2004, Oswald Buddenhagen <ossi@users.sf.net>
68 © 2004, Theodore Y. Ts'o <tytso@mit.edu>
69 © 2006, Mike McCormack
70Name: git-imap-send - drops patches into an imap Drafts folder
71 derived from isync/mbsync - mailbox synchronizer
72License: GPL-2+
73
74Files: git/perl/Git.pm
75Copyright: © 2006, by Petr Baudis <pasky@suse.cz>
76License: GPL-2+
77
78Files: git/perl/private-Error.pm
79Copyright: © 1997-8, Graham Barr <gbarr@ti.com>
80License: GPL-1+ or Artistic-1
81 This program is free software; you can redistribute it and/or modify
82 it under the terms of either:
83 .
84 a) the GNU General Public License as published by the Free Software
85 Foundation; either version 1, or (at your option) any later
86 version, or
87 .
88 b) the "Artistic License" which comes with Perl.
89 .
90 On Debian GNU/Linux systems, the complete text of the GNU General
91 Public License can be found in '/usr/share/common-licenses/GPL' and
92 the Artistic Licence in '/usr/share/common-licenses/Artistic'.
93
94Files: git/kwset.c git/kwset.h
95Copyright: © 1989, 1998, 2000, 2005, Free Software Foundation, Inc.
96License: GPL-2+
97
98Files: git/trace.c
99Copyright: © 2000-2002, Michael R. Elkins <me@mutt.org>
100 © 2002-2004, Oswald Buddenhagen <ossi@users.sf.net>
101 © 2004, Theodore Y. Ts'o <tytso@mit.edu>
102 © 2006, Mike McCormack
103 © 2006, Christian Couder
104License: GPL-2+
105
106Files: git/sh-i18n--envsubst.c
107Copyright: © 2010, Ævar Arnfjörð Bjarmason
108 © 1998-2007, Free Software Foundation, Inc.
109License: GPL-2+
110
111Files: git/t/test-lib.sh
112Copyright: © 2005, Junio C Hamano
113License: GPL-2+
114
115Files: git/compat/fnmatch/*
116Copyright: © 1991-1999, Free Software Foundation, Inc.
117License: LGPL-2+
118Comment: This file is part of the GNU C Library.
119
120Files: git/compat/inet_ntop.c git/compat/inet_pton.c
121Copyright: © 1996-2001, Internet Software Consortium.
122License: ISC
123
124Files: git/compat/poll/poll.c git/compat/poll/poll.h
125Copyright: © 2001-2003, 2006-2011, Free Software Foundation, Inc.
126Name: Emulation for poll(2) from gnulib.
127License: GPL-2+
128
129Files: git/compat/vcbuild/include/sys/utime.h
130Copyright: ?
131License: mingw-runtime
132
133Files: git/compat/nedmalloc/*
134Copyright: © 2005-2006 Niall Douglas
135License: Boost
136
137Files: git/compat/nedmalloc/malloc.c.h
138Copyright: © 2006, KJK::Hyperion <hackbunny@reactos.com>
139License: dlmalloc
140
141Files: git/compat/regex/*
142Copyright: © 1985, 1989-93, 1995-2010, Free Software Foundation, Inc.
143Name: Extended regular expression matching and search library
144License: LGPL-2.1+
145
146Files: git/compat/obstack.c git/compat/obstack.h
147Copyright: © 1988-1994, 1996-2005, 2009, Free Software Foundation, Inc.
148Name: Object stack macros.
149License: LGPL-2.1+
150
151Files: git/contrib/persistent-https/*
152Copyright: © 2012, Google Inc.
153License: Apache-2.0
154
155Files: git/contrib/credential/gnome-keyring/git-credential-gnome-keyring.c
156Copyright: © 2011, John Szakmeister <john@szakmeister.net>
157 © 2012, Philipp A. Hartmann <pah@qo.cx>
158License: GPL-2+
159
160Files: git/contrib/hg-to-git/hg-to-git.py
161Copyright: © 2007, Stelian Pop <stelian@popies.net>
162Name: hg-to-git.py - A Mercurial to GIT converter
163License: GPL-2+
164
165Files: git/contrib/mw-to-git/git-*.perl git/contrib/mw-to-git/t/t*
166Copyright: © 2011
167 Jérémie Nikaes <jeremie.nikaes@ensimag.imag.fr>
168 Arnaud Lacurie <arnaud.lacurie@ensimag.imag.fr>
169 Claire Fousse <claire.fousse@ensimag.imag.fr>
170 David Amouyal <david.amouyal@ensimag.imag.fr>
171 Matthieu Moy <matthieu.moy@grenoble-inp.fr>
172 © 2012
173 Charles Roussel <charles.roussel@ensimag.imag.fr>
174 Simon Cathebras <simon.cathebras@ensimag.imag.fr>
175 Julien Khayat <julien.khayat@ensimag.imag.fr>
176 Guillaume Sasdy <guillaume.sasdy@ensimag.imag.fr>
177 Simon Perrat <simon.perrat@ensimag.imag.fr>
178 © 2013
179 Benoit Person <benoit.person@ensimag.imag.fr>
180 Celestin Matte <celestin.matte@ensimag.imag.fr>
181License: GPL-2+
182
183Files: debian/*
184Copyright: 2014 YAEGASHI Takeshi <yaegashi@debian.org>
185License: GPL-2
186
187License: GPL-2
188 You can redistribute this software and/or modify it under the terms of
189 the GNU General Public License as published by the Free Software
190 Foundation; version 2 dated June, 1991.
191 .
192 This program is distributed in the hope that it will be useful, but
193 WITHOUT ANY WARRANTY; without even the implied warranty of
194 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU