aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile75
-rw-r--r--cache.c21
-rw-r--r--cache.h23
-rw-r--r--cgit.c391
-rw-r--r--cgit.h237
-rw-r--r--cmd.c112
-rw-r--r--cmd.h15
-rw-r--r--configfile.c87
-rw-r--r--configfile.h8
-rw-r--r--html.c95
-rw-r--r--html.h20
-rw-r--r--parsing.c146
-rw-r--r--shared.c257
-rw-r--r--ui-blob.c16
-rw-r--r--ui-blob.h6
-rw-r--r--ui-commit.c26
-rw-r--r--ui-commit.h6
-rw-r--r--ui-diff.c9
-rw-r--r--ui-diff.h7
-rw-r--r--ui-log.c32
-rw-r--r--ui-log.h7
-rw-r--r--ui-patch.c10
-rw-r--r--ui-patch.h6
-rw-r--r--ui-refs.c175
-rw-r--r--ui-refs.h8
-rw-r--r--ui-repolist.c54
-rw-r--r--ui-repolist.h6
-rw-r--r--ui-shared.c237
-rw-r--r--ui-shared.h36
-rw-r--r--ui-snapshot.c123
-rw-r--r--ui-snapshot.h8
-rw-r--r--ui-summary.c189
-rw-r--r--ui-summary.h6
-rw-r--r--ui-tag.c3
-rw-r--r--ui-tag.h6
-rw-r--r--ui-tree.c26
-rw-r--r--ui-tree.h6
38 files changed, 1379 insertions, 1117 deletions
diff --git a/.gitignore b/.gitignore
index aa36ff7..1e016e5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ cgit
3cgit.conf 3cgit.conf
4VERSION 4VERSION
5*.o 5*.o
6*.d
diff --git a/Makefile b/Makefile
index 8bf47f2..931c60e 100644
--- a/Makefile
+++ b/Makefile
@@ -12,13 +12,62 @@ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
12# 12#
13-include cgit.conf 13-include cgit.conf
14 14
15#
16# Define a way to invoke make in subdirs quietly, shamelessly ripped
17# from git.git
18#
19QUIET_SUBDIR0 = +$(MAKE) -C # space to separate -C and subdir
20QUIET_SUBDIR1 =
15 21
16EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto 22ifneq ($(findstring $(MAKEFLAGS),w),w)
17OBJECTS = shared.o cache.o parsing.o html.o ui-shared.o ui-repolist.o \ 23PRINT_DIR = --no-print-directory
18 ui-summary.o ui-log.o ui-tree.o ui-commit.o ui-diff.o \ 24else # "make -w"
19 ui-snapshot.o ui-blob.o ui-tag.o ui-refs.o ui-patch.o 25NO_SUBDIR = :
26endif
27
28ifndef V
29 QUIET_CC = @echo ' ' CC $@;
30 QUIET_MM = @echo ' ' MM $@;
31 QUIET_SUBDIR0 = +@subdir=
32 QUIET_SUBDIR1 = ;$(NO_SUBDIR) echo ' ' SUBDIR $$subdir; \
33 $(MAKE) $(PRINT_DIR) -C $$subdir
34endif
35
36#
37# Define a pattern rule for automatic dependency building
38#
39%.d: %.c
40 $(QUIET_MM)$(CC) $(CFLAGS) -MM $< | sed -e 's/\($*\)\.o:/\1.o $@:/g' >$@
41
42#
43# Define a pattern rule for silent object building
44#
45%.o: %.c
46 $(QUIET_CC)$(CC) -o $*.o -c $(CFLAGS) $<
20 47
21 48
49EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto
50OBJECTS =
51OBJECTS += cache.o
52OBJECTS += cgit.o
53OBJECTS += cmd.o
54OBJECTS += configfile.o
55OBJECTS += html.o
56OBJECTS += parsing.o
57OBJECTS += shared.o
58OBJECTS += ui-blob.o
59OBJECTS += ui-commit.o
60OBJECTS += ui-diff.o
61OBJECTS += ui-log.o
62OBJECTS += ui-patch.o
63OBJECTS += ui-refs.o
64OBJECTS += ui-repolist.o
65OBJECTS += ui-shared.o
66OBJECTS += ui-snapshot.o
67OBJECTS += ui-summary.o
68OBJECTS += ui-tag.o
69OBJECTS += ui-tree.o
70
22ifdef NEEDS_LIBICONV 71ifdef NEEDS_LIBICONV
23 EXTLIBS += -liconv 72 EXTLIBS += -liconv
24endif 73endif
@@ -41,21 +90,25 @@ CFLAGS += -DCGIT_SCRIPT_NAME='"$(CGIT_SCRIPT_NAME)"'
41CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"' 90CFLAGS += -DCGIT_CACHE_ROOT='"$(CACHE_ROOT)"'
42 91
43 92
44cgit: cgit.c $(OBJECTS) 93cgit: $(OBJECTS)
45 $(CC) $(CFLAGS) cgit.c -o cgit $(OBJECTS) $(EXTLIBS) 94 $(QUIET_CC)$(CC) $(CFLAGS) -o cgit $(OBJECTS) $(EXTLIBS)
95
96$(OBJECTS): git/xdiff/lib.a git/libgit.a
97
98cgit.o: VERSION
46 99
47$(OBJECTS): cgit.h git/xdiff/lib.a git/libgit.a VERSION 100-include $(OBJECTS:.o=.d)
48 101
49git/xdiff/lib.a: | git 102git/xdiff/lib.a: | git
50 103
51git/libgit.a: | git 104git/libgit.a: | git
52 105
53git: 106git:
54 cd git && $(MAKE) xdiff/lib.a 107 $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) xdiff/lib.a
55 cd git && $(MAKE) libgit.a 108 $(QUIET_SUBDIR0)git $(QUIET_SUBDIR1) libgit.a
56 109
57test: all 110test: all
58 $(MAKE) -C tests 111 $(QUIET_SUBDIR0)tests $(QUIET_SUBDIR1) all
59 112
60install: all 113install: all
61 mkdir -p $(DESTDIR)$(CGIT_SCRIPT_PATH) 114 mkdir -p $(DESTDIR)$(CGIT_SCRIPT_PATH)
@@ -69,7 +122,7 @@ uninstall:
69 rm -f $(CGIT_SCRIPT_PATH)/cgit.png 122 rm -f $(CGIT_SCRIPT_PATH)/cgit.png
70 123
71clean: 124clean:
72 rm -f cgit VERSION *.o 125 rm -f cgit VERSION *.o *.d
73 cd git && $(MAKE) clean 126 cd git && $(MAKE) clean
74 127
75distclean: clean 128distclean: clean
diff --git a/cache.c b/cache.c
index 372e38d..89f7ecd 100644
--- a/cache.c
+++ b/cache.c
@@ -7,6 +7,7 @@
7 */ 7 */
8 8
9#include "cgit.h" 9#include "cgit.h"
10#include "cache.h"
10 11
11const int NOLOCK = -1; 12const int NOLOCK = -1;
12 13
@@ -44,23 +45,23 @@ int cache_create_dirs()
44{ 45{
45 char *path; 46 char *path;
46 47
47 path = fmt("%s", cgit_cache_root); 48 path = fmt("%s", ctx.cfg.cache_root);
48 if (mkdir(path, S_IRWXU) && errno!=EEXIST) 49 if (mkdir(path, S_IRWXU) && errno!=EEXIST)
49 return 0; 50 return 0;
50 51
51 if (!cgit_repo) 52 if (!ctx.repo)
52 return 0; 53 return 0;
53 54
54 path = fmt("%s/%s", cgit_cache_root, 55 path = fmt("%s/%s", ctx.c